summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-02-03 17:53:15 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-04 22:17:54 +0700
commit9da2ff4cacd4f533a2c35ea0e93bea2a93e0cb08 (patch)
treec875c9c9eaed37370b5652248d02835171090ca6
parenta3fad6671946420e17525be546d2f2daa87a0620 (diff)
downloadslackbuilds-9da2ff4cacd4f533a2c35ea0e93bea2a93e0cb08.tar.gz
slackbuilds-9da2ff4cacd4f533a2c35ea0e93bea2a93e0cb08.tar.xz
python/python-dbus-next: Removed (replaced by python3-dbus-next)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-dbus-next/README3
-rw-r--r--python/python-dbus-next/python-dbus-next.SlackBuild94
-rw-r--r--python/python-dbus-next/python-dbus-next.info10
-rw-r--r--python/python-dbus-next/slack-desc19
4 files changed, 0 insertions, 126 deletions
diff --git a/python/python-dbus-next/README b/python/python-dbus-next/README
deleted file mode 100644
index 1622ad9b26..0000000000
--- a/python/python-dbus-next/README
+++ /dev/null
@@ -1,3 +0,0 @@
-python-dbus-next is a Python library for DBus that aims to be a fully
-featured high level library primarily geared towards integration of
-applications into Linux desktop and mobile environments.
diff --git a/python/python-dbus-next/python-dbus-next.SlackBuild b/python/python-dbus-next/python-dbus-next.SlackBuild
deleted file mode 100644
index 831f19aa6b..0000000000
--- a/python/python-dbus-next/python-dbus-next.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-dbus-next
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-dbus-next
-VERSION=${VERSION:-0.2.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-dbus-next/python-dbus-next.info b/python/python-dbus-next/python-dbus-next.info
deleted file mode 100644
index 59c7711182..0000000000
--- a/python/python-dbus-next/python-dbus-next.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-dbus-next"
-VERSION="0.2.3"
-HOMEPAGE="https://github.com/altdesktop/python-dbus-next"
-DOWNLOAD="https://github.com/altdesktop/python-dbus-next/archive/v0.2.3/python-dbus-next-0.2.3.tar.gz"
-MD5SUM="5cf7deebebf4c4e77328bc9b7539170f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python-dbus-next/slack-desc b/python/python-dbus-next/slack-desc
deleted file mode 100644
index 8bc7bb7c3f..0000000000
--- a/python/python-dbus-next/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-dbus-next: python-dbus-next (The next great DBus library for Python)
-python-dbus-next:
-python-dbus-next: python-dbus-next is a Python library for DBus that aims to be a fully
-python-dbus-next: featured high level library primarily geared towards integration of
-python-dbus-next: applications into Linux desktop and mobile environments.
-python-dbus-next:
-python-dbus-next:
-python-dbus-next:
-python-dbus-next:
-python-dbus-next:
-python-dbus-next: