summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-02-03 17:50:06 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-04 22:18:41 +0700
commita9b1af93330a4bd77893affe9ac07e927dfff85a (patch)
treeef343d5c91a9e9ce085a3181e9d692d6b731aad4
parente90d8786e5c0e8116c1dda05308b96584d30b8d4 (diff)
downloadslackbuilds-a9b1af93330a4bd77893affe9ac07e927dfff85a.tar.gz
slackbuilds-a9b1af93330a4bd77893affe9ac07e927dfff85a.tar.xz
python/pure_eval: Removed (replaced by python3-pure_eval)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pure_eval/README3
-rw-r--r--python/pure_eval/pure_eval.SlackBuild95
-rw-r--r--python/pure_eval/pure_eval.info10
-rw-r--r--python/pure_eval/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/pure_eval/README b/python/pure_eval/README
deleted file mode 100644
index 7b94568df9..0000000000
--- a/python/pure_eval/README
+++ /dev/null
@@ -1,3 +0,0 @@
-pure_eval is a Python package that lets you safely evaluate certain
-AST nodes without triggering arbitrary code that may have unwanted
-side effects.
diff --git a/python/pure_eval/pure_eval.SlackBuild b/python/pure_eval/pure_eval.SlackBuild
deleted file mode 100644
index 3fd128e058..0000000000
--- a/python/pure_eval/pure_eval.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pure_eval
-
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pure_eval
-VERSION=${VERSION:-0.2.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pure_eval/pure_eval.info b/python/pure_eval/pure_eval.info
deleted file mode 100644
index 0b8c11e645..0000000000
--- a/python/pure_eval/pure_eval.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pure_eval"
-VERSION="0.2.2"
-HOMEPAGE="https://github.com/alexmojaki/pure_eval"
-DOWNLOAD="https://files.pythonhosted.org/packages/97/5a/0bc937c25d3ce4e0a74335222aee05455d6afa2888032185f8ab50cdf6fd/pure_eval-0.2.2.tar.gz"
-MD5SUM="212fd27ca2c58d9effddec69748d738a"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/pure_eval/slack-desc b/python/pure_eval/slack-desc
deleted file mode 100644
index 59a0c52b16..0000000000
--- a/python/pure_eval/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pure_eval: pure_eval (Safely evaluate AST nodes)
-pure_eval:
-pure_eval: pure_eval is a Python package that lets you safely evaluate certain
-pure_eval: AST nodes without triggering arbitrary code that may have unwanted
-pure_eval: side effects.
-pure_eval:
-pure_eval:
-pure_eval:
-pure_eval:
-pure_eval:
-pure_eval: