summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Christoph Willing <c.willing@uq.edu.au>2013-03-11 21:13:24 -0400
committer dsomero <xgizzmo@slackbuilds.org>2013-03-22 07:16:44 -0400
commit06195887da295d66b7934634d994aadf905dce3f (patch)
tree7fbe86c344707ef2051e3c58efe6f22db34532e6
parent38db011e7f8c59e558c18f8b65a26ed0a7530a09 (diff)
downloadslackbuilds-06195887da295d66b7934634d994aadf905dce3f.tar.gz
slackbuilds-06195887da295d66b7934634d994aadf905dce3f.tar.xz
python/euca2ools: Added (Amazon & OpenStack Command Line Tools)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--python/euca2ools/README2
-rw-r--r--python/euca2ools/euca2ools.SlackBuild93
-rw-r--r--python/euca2ools/euca2ools.info10
-rw-r--r--python/euca2ools/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/euca2ools/README b/python/euca2ools/README
new file mode 100644
index 0000000000..93a1dd6481
--- /dev/null
+++ b/python/euca2ools/README
@@ -0,0 +1,2 @@
+Euca2ools are command line tools for interacting with Amazon Web Services (AWS)
+and other AWS-compatible web services, such as Eucalyptus and OpenStack.
diff --git a/python/euca2ools/euca2ools.SlackBuild b/python/euca2ools/euca2ools.SlackBuild
new file mode 100644
index 0000000000..f4de6fe80f
--- /dev/null
+++ b/python/euca2ools/euca2ools.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for euca2ools
+
+# Copyright 2013 Christoph Willing, Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=euca2ools
+VERSION=${VERSION:-2.1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -ev
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/man/man1
+install -m0644 man/*.1 $PKG/usr/man/man1/
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG COPYING INSTALL README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/euca2ools/euca2ools.info b/python/euca2ools/euca2ools.info
new file mode 100644
index 0000000000..d82613d57f
--- /dev/null
+++ b/python/euca2ools/euca2ools.info
@@ -0,0 +1,10 @@
+PRGNAM="euca2ools"
+VERSION="2.1.3"
+HOMEPAGE="http://www.eucalyptus.com"
+DOWNLOAD="http://downloads.eucalyptus.com/software/euca2ools/2.1/source/euca2ools-2.1.3.tar.gz"
+MD5SUM="c8c1b21f5edb05dbc2c0d4d1193ef0d5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="boto"
+MAINTAINER="Christoph Willing"
+EMAIL="c.willing@uq.edu.au"
diff --git a/python/euca2ools/slack-desc b/python/euca2ools/slack-desc
new file mode 100644
index 0000000000..e59cdbe1c5
--- /dev/null
+++ b/python/euca2ools/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+euca2ools: euca2ools (Amazon & OpenStack Command Line Tools)
+euca2ools:
+euca2ools: Euca2ools are command line tools for interacting with Amazon Web
+euca2ools: Services (AWS) and other AWS-compatible web services, such as
+euca2ools: Eucalyptus and OpenStack.
+euca2ools:
+euca2ools:
+euca2ools:
+euca2ools:
+euca2ools:
+euca2ools: