summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2021-07-31 01:13:34 -0500
committer Robby Workman <rworkman@slackbuilds.org>2021-08-01 04:20:54 -0500
commit064d0f8d2261e3ec6502ac3be63d6d4a2eab310a (patch)
tree54019b34ba58f6667072fd7824fc0691b8658085
parent288e994678b37294db6129b2932af9c6e2716ce9 (diff)
downloadslackbuilds-064d0f8d2261e3ec6502ac3be63d6d4a2eab310a.tar.gz
slackbuilds-064d0f8d2261e3ec6502ac3be63d6d4a2eab310a.tar.xz
games/m64py: Build using qt5
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--games/m64py/README7
-rw-r--r--games/m64py/m64py.SlackBuild17
-rw-r--r--games/m64py/m64py.info6
-rw-r--r--games/m64py/slack-desc10
4 files changed, 21 insertions, 19 deletions
diff --git a/games/m64py/README b/games/m64py/README
index 868980f98d..2a7b210c6d 100644
--- a/games/m64py/README
+++ b/games/m64py/README
@@ -1,3 +1,4 @@
-M64Py is a Qt4 front-end (GUI) for Mupen64Plus 2.0, a cross-platform
-plugin-based Nintendo 64 emulator. Front-end is written in Python and it
-provides a user-friendly interface over Mupen64Plus shared library.
+M64Py is a Qt5 front-end (GUI) for Mupen64Plus, a cross-platform
+plugin-based Nintendo 64 emulator. Front-end is written in Python
+and it provides a user-friendly interface over the Mupen64Plus
+shared library.
diff --git a/games/m64py/m64py.SlackBuild b/games/m64py/m64py.SlackBuild
index eec81bf999..16248d4ad1 100644
--- a/games/m64py/m64py.SlackBuild
+++ b/games/m64py/m64py.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for m64py
-# Copyright 2015 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
+# Copyright 2021 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -34,6 +34,7 @@ if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -74,19 +75,19 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS CHANGELOG COPYING LICENSES PKG-INFO README.rst \
+ AUTHORS CHANGELOG LICENSES README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/games/m64py/m64py.info b/games/m64py/m64py.info
index ceb0ea20e0..df39e40163 100644
--- a/games/m64py/m64py.info
+++ b/games/m64py/m64py.info
@@ -1,10 +1,10 @@
PRGNAM="m64py"
VERSION="0.2.5"
-HOMEPAGE="http://m64py.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/m64py/m64py-0.2.5.tar.gz"
+HOMEPAGE="https://github.com/mupen64plus/mupen64plus-ui-python"
+DOWNLOAD="https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/0.2.5/m64py-0.2.5.tar.gz"
MD5SUM="201a5b08a7ed43db26af6067a064e116"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="PySDL2 mupen64plus"
+REQUIRES="mupen64plus python3-pysdl2"
MAINTAINER="M.Dinslage"
EMAIL="daedra1980@gmail.com"
diff --git a/games/m64py/slack-desc b/games/m64py/slack-desc
index cea93c835e..51f40b61d8 100644
--- a/games/m64py/slack-desc
+++ b/games/m64py/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-m64py: m64py (mupen64plus GUI)
+m64py: m64py (A GUI frontend for Mupen64Plus)
m64py:
-m64py: M64Py is a Qt4 front-end (GUI) for Mupen64Plus 2.0, a cross-platform
+m64py: M64Py is a Qt5 front-end (GUI) for Mupen64Plus, a cross-platform
m64py: plugin-based Nintendo 64 emulator. Front-end is written in Python
-m64py: and it provides a user-friendly interface over Mupen64Plus shared
-m64py: library.
+m64py: and it provides a user-friendly interface over the Mupen64Plus
+m64py: shared library.
m64py:
-m64py: Homepage: http://m64py.sourceforge.net
+m64py: Homepage: https://github.com/mupen64plus/mupen64plus-ui-python
m64py:
m64py:
m64py: