summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-23 07:27:06 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-24 07:05:14 +0700
commit109664c77a3795bd4acfd68f5fe1c80239c12b13 (patch)
treec68cfe5c4470d28a6bf40723b4568d18593298ec
parentefae70dff62cf882144e37cbff5155b5d0c93b05 (diff)
downloadslackbuilds-109664c77a3795bd4acfd68f5fe1c80239c12b13.tar.gz
slackbuilds-109664c77a3795bd4acfd68f5fe1c80239c12b13.tar.xz
system/termenu: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--system/termenu/termenu.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/system/termenu/termenu.SlackBuild b/system/termenu/termenu.SlackBuild
index f77f292e46..c4465e0689 100644
--- a/system/termenu/termenu.SlackBuild
+++ b/system/termenu/termenu.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for termenu
-# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +22,6 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
PRGNAM=termenu
VERSION=${VERSION:-1.1.6}
BUILD=${BUILD:-1}
@@ -30,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -68,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG