summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Brouwers <abrouwers@gmail.com>2010-05-11 14:03:45 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-11 14:03:45 +0200
commit1c82b445645863711f08d4a2554a3ee5eae259a0 (patch)
treefb3a966f3e8abb2939c50ba72d1b0530abba73b9
parent0f09c18c6ffe76c66c1cd8ec625736c1772a3392 (diff)
downloadslackbuilds-1c82b445645863711f08d4a2554a3ee5eae259a0.tar.gz
slackbuilds-1c82b445645863711f08d4a2554a3ee5eae259a0.tar.xz
desktop/gtk-chtheme: Initial import
-rw-r--r--desktop/gtk-chtheme/README7
-rw-r--r--desktop/gtk-chtheme/gtk-chtheme.SlackBuild76
-rw-r--r--desktop/gtk-chtheme/gtk-chtheme.info8
-rw-r--r--desktop/gtk-chtheme/slack-desc9
4 files changed, 100 insertions, 0 deletions
diff --git a/desktop/gtk-chtheme/README b/desktop/gtk-chtheme/README
new file mode 100644
index 0000000000..fc8a7d225d
--- /dev/null
+++ b/desktop/gtk-chtheme/README
@@ -0,0 +1,7 @@
+gtk_chtheme, as the name suggests, allows you to change
+your gtk+2.0 theme.
+
+Themes installed on the system are presented for selection
+and available for preview on the fly. This works very well
+for any user wanting to utilize a gtk2 theme for a window
+manager environment.
diff --git a/desktop/gtk-chtheme/gtk-chtheme.SlackBuild b/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
new file mode 100644
index 0000000000..190f73b84a
--- /dev/null
+++ b/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for gtk-chtheme
+
+# Copyright 2006 Andrew Brouwers <abrouwers@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuilds.org project
+
+PRGNAM=gtk-chtheme
+VERSION=0.3.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG=_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING ChangeLog"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvjf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Rewrite CFLAGS
+if [ "$ARCH" = "i486" ]; then
+ sed -i 's#CFLAGS += -Wall#CFLAGS += -O2 -march=i486 -mtune=i686#' $TMP/$PRGNAM-$VERSION/Makefile
+elif [ "$ARCH" = "i686" ]; then
+ sed -i 's#CFLAGS += -Wall#CFLAGS += -O2 -march=i686 -mtune=i686#' $TMP/$PRGNAM-$VERSION/Makefile
+fi
+
+make || exit 1
+make install DESTDIR=$PKG MANDIR=usr/man || exit 1
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ find . -type f -exec chmod 644 {} \;
+ for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+# Docs, slack-desc, buildscript
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/desktop/gtk-chtheme/gtk-chtheme.info b/desktop/gtk-chtheme/gtk-chtheme.info
new file mode 100644
index 0000000000..8beb40ada1
--- /dev/null
+++ b/desktop/gtk-chtheme/gtk-chtheme.info
@@ -0,0 +1,8 @@
+PRGNAM="gtk-chtheme"
+VERSION="0.3.1"
+HOMEPAGE="http://plasmasturm.org/code/gtk-chtheme/"
+DOWNLOAD="http://plasmasturm.org/code/gtk-chtheme/gtk-chtheme-0.3.1.tar.bz2"
+MD5SUM="f688053bf26dd6c4f1cd0bf2ee33de2a"
+MAINTAINER="Andrew Brouwers"
+EMAIL="abrouwers@gmail.com"
+APPROVED="BP{k}"
diff --git a/desktop/gtk-chtheme/slack-desc b/desktop/gtk-chtheme/slack-desc
new file mode 100644
index 0000000000..581ec34c96
--- /dev/null
+++ b/desktop/gtk-chtheme/slack-desc
@@ -0,0 +1,9 @@
+gtk-chtheme: gtk-chtheme (GTK+2.0 Theme changer)
+gtk-chtheme:
+gtk-chtheme: gtk-chtheme, as the name suggests, allows you to change
+gtk-chtheme: your gtk+2.0 theme.
+gtk-chtheme:
+gtk-chtheme: Themes installed on the system are presented for selection
+gtk-chtheme: and available for preview on the fly.
+gtk-chtheme:
+