summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:47 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:52 +0700
commit289662417467d15824a2959e7d517df764c81f71 (patch)
tree09a9d111995e6432d258e6b428aa9d3eed42cb3a
parentb54746b77dd18736d92a2d98b7c3d6d01a00e1f9 (diff)
downloadslackbuilds-289662417467d15824a2959e7d517df764c81f71.tar.gz
slackbuilds-289662417467d15824a2959e7d517df764c81f71.tar.xz
python/python-xlwt: Renamed python2-xlwt.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-xlwt/README6
-rw-r--r--python/python-xlwt/slack-desc19
-rw-r--r--python/python2-xlwt/README7
-rw-r--r--python/python2-xlwt/python2-xlwt.SlackBuild (renamed from python/python-xlwt/python-xlwt.SlackBuild)13
-rw-r--r--python/python2-xlwt/python2-xlwt.info (renamed from python/python-xlwt/python-xlwt.info)2
-rw-r--r--python/python2-xlwt/slack-desc19
6 files changed, 33 insertions, 33 deletions
diff --git a/python/python-xlwt/README b/python/python-xlwt/README
deleted file mode 100644
index 4d58db130a..0000000000
--- a/python/python-xlwt/README
+++ /dev/null
@@ -1,6 +0,0 @@
-python-xlwt is a library for generating spreadsheet files that are compatible
-with Excel 97/2000/XP/2003, OpenOffice.org Calc, and Gnumeric.
-
-python-xlwt has full support for Unicode. Excel spreadsheets can be generated
-on any platform without needing Excel or a COM server.
-The only requirement is Python 2.3 to 2.7.
diff --git a/python/python-xlwt/slack-desc b/python/python-xlwt/slack-desc
deleted file mode 100644
index fc1d19cb38..0000000000
--- a/python/python-xlwt/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-xlwt: python-xlwt (Python package for generating MS Excel spreadsheets)
-python-xlwt:
-python-xlwt: python-xlwt is a library to create spreadsheet files compatible with
-python-xlwt: MS Excel 97/2000/XP/2003 XLS files, on any platform, with
-python-xlwt: Python 2.3 to 2.7.
-python-xlwt:
-python-xlwt: Homepage: http://www.python-excel.org/
-python-xlwt:
-python-xlwt:
-python-xlwt:
-python-xlwt:
diff --git a/python/python2-xlwt/README b/python/python2-xlwt/README
new file mode 100644
index 0000000000..2c2f5aae5d
--- /dev/null
+++ b/python/python2-xlwt/README
@@ -0,0 +1,7 @@
+python-xlwt is a library for generating spreadsheet files that are
+compatible with Excel 97/2000/XP/2003, OpenOffice.org Calc, and
+Gnumeric.
+
+python-xlwt has full support for Unicode. Excel spreadsheets can be
+generated on any platform without needing Excel or a COM server. The
+only requirement is Python 2.3 to 2.7.
diff --git a/python/python-xlwt/python-xlwt.SlackBuild b/python/python2-xlwt/python2-xlwt.SlackBuild
index baf84f4f67..30c44e9838 100644
--- a/python/python-xlwt/python-xlwt.SlackBuild
+++ b/python/python2-xlwt/python2-xlwt.SlackBuild
@@ -22,7 +22,7 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-xlwt
+PRGNAM=python2-xlwt
SRCNAM=xlwt
VERSION=${VERSION:-0.7.5}
BUILD=${BUILD:-1}
@@ -30,7 +30,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +43,8 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="licences.py README.html"
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -70,9 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build || exit 1
-
-python setup.py install --root $PKG || exit 1
+python2 setup.py build || exit 1
+python2 setup.py install --root $PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-xlwt/python-xlwt.info b/python/python2-xlwt/python2-xlwt.info
index fb4969c8b9..b3634e038c 100644
--- a/python/python-xlwt/python-xlwt.info
+++ b/python/python2-xlwt/python2-xlwt.info
@@ -1,4 +1,4 @@
-PRGNAM="python-xlwt"
+PRGNAM="python2-xlwt"
VERSION="0.7.5"
HOMEPAGE="http://www.python-excel.org"
DOWNLOAD="https://pypi.python.org/packages/source/x/xlwt/xlwt-0.7.5.tar.gz"
diff --git a/python/python2-xlwt/slack-desc b/python/python2-xlwt/slack-desc
new file mode 100644
index 0000000000..057897e198
--- /dev/null
+++ b/python/python2-xlwt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-xlwt: python2-xlwt (Python package for generating MS Excel spreadsheets)
+python2-xlwt:
+python2-xlwt: python2-xlwt is a library to create spreadsheet files compatible with
+python2-xlwt: MS Excel 97/2000/XP/2003 XLS files, on any platform, with
+python2-xlwt: Python 2.3 to 2.7.
+python2-xlwt:
+python2-xlwt: Homepage: http://www.python-excel.org/
+python2-xlwt:
+python2-xlwt:
+python2-xlwt:
+python2-xlwt: