summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pr. HORSTMANN <wmh@eipg.fr>2021-01-02 10:31:00 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-01-02 10:48:19 +0700
commit2dae5f56ccfa3f338fc48dd54113e255762a91e7 (patch)
tree3e060ca9648b640609d4677256e6467283f17132
parentc82d7a36b7b8ff4c8d4855c40354925070cb012e (diff)
downloadslackbuilds-2dae5f56ccfa3f338fc48dd54113e255762a91e7.tar.gz
slackbuilds-2dae5f56ccfa3f338fc48dd54113e255762a91e7.tar.xz
python/pynacl: Added (Python binding to libsodium).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pynacl/README1
-rw-r--r--python/pynacl/pynacl.SlackBuild81
-rw-r--r--python/pynacl/pynacl.info10
-rw-r--r--python/pynacl/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/python/pynacl/README b/python/pynacl/README
new file mode 100644
index 0000000000..6e2ecf09ff
--- /dev/null
+++ b/python/pynacl/README
@@ -0,0 +1 @@
+Python binding to the Networking and Cryptography (NaCl) library
diff --git a/python/pynacl/pynacl.SlackBuild b/python/pynacl/pynacl.SlackBuild
new file mode 100644
index 0000000000..556c55790d
--- /dev/null
+++ b/python/pynacl/pynacl.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# SlackBuild build script for pynacl
+
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pynacl
+SRCPKG=${SRCPKG-PyNaCl}
+VERSION=${VERSION:-1.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $SRCPKG | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pynacl/pynacl.info b/python/pynacl/pynacl.info
new file mode 100644
index 0000000000..ebbf3676ab
--- /dev/null
+++ b/python/pynacl/pynacl.info
@@ -0,0 +1,10 @@
+PRGNAM="pynacl"
+VERSION="1.4.0"
+HOMEPAGE="https://pypi.org/project/pynacl/"
+DOWNLOAD="https://files.pythonhosted.org/packages/cf/5a/25aeb636baeceab15c8e57e66b8aa930c011ec1c035f284170cacb05025e/PyNaCl-1.4.0.tar.gz"
+MD5SUM="8c6c57893327a694c72510fb620e4744"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=" six cffi wheel"
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/pynacl/slack-desc b/python/pynacl/slack-desc
new file mode 100644
index 0000000000..708708b537
--- /dev/null
+++ b/python/pynacl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pynacl: pynacl (Binding to the Networking and Cryptography (NaCl) library)
+pynacl:
+pynacl: PyNaCl is a Python binding to libsodium, which is a fork of the
+pynacl: Networking and Cryptography library. These libraries have a stated
+pynacl: goal of improving usability, security and speed.
+pynacl: It supports Python 2.7 and 3.5+ as well as PyPy 2.6+.
+pynacl:
+pynacl:
+pynacl: Homepage: https://pypi.org/project/PyNaCl/
+pynacl:
+pynacl: