summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-11-28 08:31:09 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-03 07:21:53 +0700
commit350c6df1da3868fed6fdf6fbca74adc97d0ebc28 (patch)
treec7d8dafe585ad9bab285638ff9e665a0f28bc5b6
parentdb549e9ab9903a7f14e644d5036229487fd28d64 (diff)
downloadslackbuilds-350c6df1da3868fed6fdf6fbca74adc97d0ebc28.tar.gz
slackbuilds-350c6df1da3868fed6fdf6fbca74adc97d0ebc28.tar.xz
python/cssselect: Updated for version 1.0.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/cssselect/README8
-rw-r--r--python/cssselect/cssselect.SlackBuild18
-rw-r--r--python/cssselect/cssselect.info6
3 files changed, 19 insertions, 13 deletions
diff --git a/python/cssselect/README b/python/cssselect/README
index 9d2c7d4aae..4609431248 100644
--- a/python/cssselect/README
+++ b/python/cssselect/README
@@ -2,5 +2,9 @@ cssselect parses CSS3 Selectors and translate them to XPath 1.0 expressions.
Such expressions can be used in lxml or another XPath engine to find the
matching elements in an XML or HTML document.
-Optionally: lxml can be installed for running tests. Sphinx and Pygments
-can be installed for man pages.
+Optional dependencies: lxml, Sphinx and python3
+
+Note: To install Python 3 bindings, install python3 and set PYTHON3="yes"
+to the slackbuild.
+
+ # PYTHON3="yes" ./cssselect.SlackBuild
diff --git a/python/cssselect/cssselect.SlackBuild b/python/cssselect/cssselect.SlackBuild
index ec8b466634..0f0749f458 100644
--- a/python/cssselect/cssselect.SlackBuild
+++ b/python/cssselect/cssselect.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cssselect
-VERSION=${VERSION:-0.9.2}
+VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,13 +50,17 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -69,9 +73,7 @@ if python -c 'import sphinx.pygments_styles' 2>/dev/null; then
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS CHANGES LICENSE PKG-INFO README.rst docs/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/cssselect/cssselect.info b/python/cssselect/cssselect.info
index a50bad1e4c..4f37b59c22 100644
--- a/python/cssselect/cssselect.info
+++ b/python/cssselect/cssselect.info
@@ -1,8 +1,8 @@
PRGNAM="cssselect"
-VERSION="0.9.2"
+VERSION="1.0.0"
HOMEPAGE="http://packages.python.org/cssselect/"
-DOWNLOAD="https://pypi.python.org/packages/11/21/47b5d2696a945da177d2344b6e330b7b0d1c52404063cb387d2261517ccb/cssselect-0.9.2.tar.gz"
-MD5SUM="4c5931d8456dfe72fa4662f9c0509bfa"
+DOWNLOAD="https://pypi.python.org/packages/a1/19/a65236b0cc4b497a62bb6bd93c53f58814ab2540403b1994ea859d77c96b/cssselect-1.0.0.tar.gz"
+MD5SUM="9776aa9f552d830fac45aa979610b406"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""