summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2018-05-06 18:28:02 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-05-12 06:58:31 +0700
commit37f1da8d4d9470b89ea98d18ec01772851b9ba95 (patch)
treefb9a9d9aaf9dfbaef29cb82645f384bb12c1953e
parent760ce5c7cc51c45057d3da926c150e706453c785 (diff)
downloadslackbuilds-37f1da8d4d9470b89ea98d18ec01772851b9ba95.tar.gz
slackbuilds-37f1da8d4d9470b89ea98d18ec01772851b9ba95.tar.xz
network/youtube-dl: Updated for version 2018.05.01.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--network/youtube-dl/setup.patch46
-rw-r--r--network/youtube-dl/youtube-dl.173
-rw-r--r--network/youtube-dl/youtube-dl.SlackBuild5
-rw-r--r--network/youtube-dl/youtube-dl.info6
4 files changed, 65 insertions, 65 deletions
diff --git a/network/youtube-dl/setup.patch b/network/youtube-dl/setup.patch
index 5636ddc786..ca72728805 100644
--- a/network/youtube-dl/setup.patch
+++ b/network/youtube-dl/setup.patch
@@ -1,9 +1,9 @@
---- youtube-dl-2016.05.30.2/Makefile.orig 2016-05-30 16:14:38.003087066 +0300
-+++ youtube-dl-2016.05.30.2/Makefile 2016-05-30 16:19:03.597103047 +0300
+--- youtube-dl-2018.05.01/Makefile.orig 2018-05-06 18:08:39.581459715 +0200
++++ youtube-dl-2018.05.01/Makefile 2018-05-06 18:10:24.291462210 +0200
@@ -5,11 +5,11 @@
find . -name "*.pyc" -delete
find . -name "*.class" -delete
-
+
-PREFIX ?= /usr/local
+PREFIX ?= /usr
BINDIR ?= $(PREFIX)/bin
@@ -11,35 +11,35 @@
SHAREDIR ?= $(PREFIX)/share
-PYTHON ?= /usr/bin/env python
+PYTHON ?= /usr/bin/python
-
+
# set SYSCONFDIR to /etc if PREFIX=/usr or PREFIX=/usr/local
- SYSCONFDIR != if [ $(PREFIX) = /usr -o $(PREFIX) = /usr/local ]; then echo /etc; else echo $(PREFIX)/etc; fi
-@@ -43,7 +43,7 @@
-
+ SYSCONFDIR = $(shell if [ $(PREFIX) = /usr -o $(PREFIX) = /usr/local ]; then echo /etc; else echo $(PREFIX)/etc; fi)
+@@ -55,7 +55,7 @@
+
.PHONY: all clean install test tar bash-completion pypi-files zsh-completion fish-completion ot offlinetest codetest supportedsites
-
+
-pypi-files: youtube-dl.bash-completion README.txt youtube-dl.1 youtube-dl.fish
+pypi-files: youtube-dl.bash-completion README.md youtube-dl.1 youtube-dl.fish
-
+
youtube-dl: youtube_dl/*.py youtube_dl/*/*.py
- zip --quiet youtube-dl youtube_dl/*.py youtube_dl/*/*.py
-@@ -66,11 +66,11 @@
+ mkdir -p zip
+@@ -85,11 +85,11 @@
$(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
-
+
README.txt: README.md
-- pandoc -f markdown -t plain README.md -o README.txt
-+ # pandoc -f markdown -t plain README.md -o README.txt
-
+- pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
++ #pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
+
youtube-dl.1: README.md
$(PYTHON) devscripts/prepare_manpage.py youtube-dl.1.temp.md
-- pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
-+ # pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
+- pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
++ #pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
rm -f youtube-dl.1.temp.md
-
+
youtube-dl.bash-completion: youtube_dl/*.py youtube_dl/*/*.py devscripts/bash-completion.in
---- youtube-dl-2016.05.30.2/setup.orig 2016-05-30 16:14:52.766087954 +0300
-+++ youtube-dl-2016.05.30.2/setup.py 2016-05-30 16:22:55.100116977 +0300
-@@ -47,10 +47,10 @@
+--- youtube-dl-2018.05.01/setup.py.orig 2018-05-06 18:08:48.362459924 +0200
++++ youtube-dl-2018.05.01/setup.py 2018-05-06 18:11:02.935463131 +0200
+@@ -59,10 +59,10 @@
params = py2exe_params
else:
files_spec = [
@@ -49,8 +49,8 @@
- ('share/man/man1', ['youtube-dl.1'])
+ ('/etc/bash_completion.d', ['youtube-dl.bash-completion']),
+ ('/etc/fish/completions', ['youtube-dl.fish']),
-+ ('/usr/doc/youtube_dl', ['README.txt']),
-+ ('/usr/man/man1', ['youtube-dl.1'])
++ ('usr/doc/youtube_dl', ['README.txt']),
++ ('usr/man/man1', ['youtube-dl.1'])
]
root = os.path.dirname(os.path.abspath(__file__))
data_files = []
diff --git a/network/youtube-dl/youtube-dl.1 b/network/youtube-dl/youtube-dl.1
index 74f83dc59b..976505407a 100644
--- a/network/youtube-dl/youtube-dl.1
+++ b/network/youtube-dl/youtube-dl.1
@@ -1,4 +1,7 @@
+.\" Automatically generated by Pandoc 2.1.3
+.\"
.TH "YOUTUBE\-DL" "1" "" "" ""
+.hy
.SH NAME
.PP
youtube\-dl \- download videos from youtube.com or other video platforms
@@ -997,7 +1000,7 @@ machine\ twitch\ login\ my_twitch_account_name\ password\ my_twitch_password
.PP
To activate authentication with the \f[C]\&.netrc\f[] file you should
pass \f[C]\-\-netrc\f[] to youtube\-dl or place it in the configuration
-file (#configuration).
+file.
.PP
On Windows you may also need to setup the \f[C]%HOME%\f[] environment
variable manually.
@@ -1013,7 +1016,7 @@ set\ HOME=%USERPROFILE%
The \f[C]\-o\f[] option allows users to indicate a template for the
output file names.
.PP
-\f[B]tl;dr:\f[] navigate me to examples (#output-template-examples).
+\f[B]tl;dr:\f[] navigate me to examples.
.PP
The basic usage is not to set any template arguments when downloading a
single file, like in
@@ -1293,7 +1296,7 @@ expression\f[], i.e.
an expression that describes format or formats you would like to
download.
.PP
-\f[B]tl;dr:\f[] navigate me to examples (#format-selection-examples).
+\f[B]tl;dr:\f[] navigate me to examples.
.PP
The simplest case is requesting a specific format, for example with
\f[C]\-f\ 22\f[] you can download the format with format code equal to
@@ -1418,8 +1421,8 @@ If you want to preserve the old format selection behavior (prior to
youtube\-dl 2015.04.26), i.e.
you want to download the best available quality media served as a single
file, you should explicitly specify your choice with \f[C]\-f\ best\f[].
-You may want to add it to the configuration file (#configuration) in
-order not to type it every time you run youtube\-dl.
+You may want to add it to the configuration file in order not to type it
+every time you run youtube\-dl.
.SS Format selection examples
.PP
Note that on Windows you may need to use double quotes instead of
@@ -1629,12 +1632,12 @@ youtube\-dl in turn.
.PP
YouTube has switched to a new video info format in July 2011 which is
not supported by old versions of youtube\-dl.
-See above (#how-do-i-update-youtube-dl) for how to update youtube\-dl.
+See above for how to update youtube\-dl.
.SS ERROR: unable to download video
.PP
YouTube requires an additional signature since September 2012 which is
not supported by old versions of youtube\-dl.
-See above (#how-do-i-update-youtube-dl) for how to update youtube\-dl.
+See above for how to update youtube\-dl.
.SS Video URL contains an ampersand and I\[aq]m getting some strange
output \f[C][1]\ 2839\f[] or
\f[C]\[aq]v\[aq]\ is\ not\ recognized\ as\ an\ internal\ or\ external\ command\f[]
@@ -1665,15 +1668,15 @@ For Windows you have to use the double quotes:
.PP
In February 2015, the new YouTube player contained a character sequence
in a string that was misinterpreted by old versions of youtube\-dl.
-See above (#how-do-i-update-youtube-dl) for how to update youtube\-dl.
+See above for how to update youtube\-dl.
.SS HTTP Error 429: Too Many Requests or 402: Payment Required
.PP
These two error codes indicate that the service is blocking your IP
address because of overuse.
Contact the service and ask them to unblock your IP address, or \- if
you have acquired a whitelisted IP address already \- use the
-\f[C]\-\-proxy\f[] or \f[C]\-\-source\-address\f[]
-options (#network-options) to select another IP address.
+\f[C]\-\-proxy\f[] or \f[C]\-\-source\-address\f[] options to select
+another IP address.
.SS SyntaxError: Non\-ASCII character
.PP
The error
@@ -1721,10 +1724,10 @@ ffmpeg) by simply typing \f[C]youtube\-dl\f[] or \f[C]ffmpeg\f[], no
matter what directory you\[aq]re in.
.SS How do I put downloads into a specific folder?
.PP
-Use the \f[C]\-o\f[] to specify an output template (#output-template),
-for example \f[C]\-o\ "/home/user/videos/%(title)s\-%(id)s.%(ext)s"\f[].
+Use the \f[C]\-o\f[] to specify an output template, for example
+\f[C]\-o\ "/home/user/videos/%(title)s\-%(id)s.%(ext)s"\f[].
If you want this for all of your downloads, put the option into your
-configuration file (#configuration).
+configuration file.
.SS How do I download a video starting with a \f[C]\-\f[]?
.PP
Either prepend \f[C]https://www.youtube.com/watch?v=\f[] or separate the
@@ -1872,7 +1875,7 @@ serves as a unified point.
Unfortunately, the youtube\-dl project has grown too large to use
personal email as an effective communication channel.
.PP
-Please read the bug reporting instructions (#bugs) below.
+Please read the bug reporting instructions below.
A lot of bugs lack all the necessary information.
If you can, offer proxy, VPN, or shell access to the youtube\-dl
developers.
@@ -1918,15 +1921,14 @@ you run it from a Python program.
.SH Why do I need to go through that much red tape when filing bugs?
.PP
Before we had the issue template, despite our extensive bug reporting
-instructions (#bugs), about 80% of the issue reports we got were
-useless, for instance because people used ancient versions hundreds of
-releases old, because of simple syntactic errors (not in youtube\-dl but
-in general shell usage), because the problem was already reported
-multiple times before, because people did not actually read an error
-message, even if it said "please install ffmpeg", because people did not
-mention the URL they were trying to download and many more simple,
-easy\-to\-avoid problems, many of whom were totally unrelated to
-youtube\-dl.
+instructions, about 80% of the issue reports we got were useless, for
+instance because people used ancient versions hundreds of releases old,
+because of simple syntactic errors (not in youtube\-dl but in general
+shell usage), because the problem was already reported multiple times
+before, because people did not actually read an error message, even if
+it said "please install ffmpeg", because people did not mention the URL
+they were trying to download and many more simple, easy\-to\-avoid
+problems, many of whom were totally unrelated to youtube\-dl.
.PP
youtube\-dl is an open\-source project manned by too few volunteers, so
we\[aq]d rather spend time fixing bugs where we are certain none of
@@ -1963,8 +1965,8 @@ nosetests
\f[]
.fi
.PP
-See item 6 of new extractor tutorial (#adding-support-for-a-new-site)
-for how to run extractor specific test cases.
+See item 6 of new extractor tutorial for how to run extractor specific
+test cases.
.PP
If you want to create a build of youtube\-dl yourself, you\[aq]ll need
.IP \[bu] 2
@@ -1996,7 +1998,7 @@ Check out the source code with:
.IP
.nf
\f[C]
-git\ clone\ git\@github.com:YOUR_GITHUB_USERNAME/youtube\-dl.git
+\ git\ clone\ git\@github.com:YOUR_GITHUB_USERNAME/youtube\-dl.git
\f[]
.fi
.RE
@@ -2006,8 +2008,8 @@ Start a new git branch with
.IP
.nf
\f[C]
-cd\ youtube\-dl
-git\ checkout\ \-b\ yourextractor
+\ cd\ youtube\-dl
+\ git\ checkout\ \-b\ yourextractor
\f[]
.fi
.RE
@@ -2082,9 +2084,8 @@ extractor should and may
return (https://github.com/rg3/youtube-dl/blob/master/youtube_dl/extractor/common.py#L74-L252).
Add tests and code for as many as you want.
.IP " 8." 4
-Make sure your code follows youtube\-dl coding
-conventions (#youtube-dl-coding-conventions) and check the code with
-flake8 (https://pypi.python.org/pypi/flake8).
+Make sure your code follows youtube\-dl coding conventions and check the
+code with flake8 (https://pypi.python.org/pypi/flake8).
Also make sure your code works under all
Python (https://www.python.org/) versions claimed supported by
youtube\-dl, namely 2.6, 2.7, and 3.2+.
@@ -2096,10 +2097,10 @@ push (https://git-scm.com/docs/git-push) the result, like this:
.IP
.nf
\f[C]
-$\ git\ add\ youtube_dl/extractor/extractors.py
-$\ git\ add\ youtube_dl/extractor/yourextractor.py
-$\ git\ commit\ \-m\ \[aq][yourextractor]\ Add\ new\ extractor\[aq]
-$\ git\ push\ origin\ yourextractor
+\ $\ git\ add\ youtube_dl/extractor/extractors.py
+\ $\ git\ add\ youtube_dl/extractor/yourextractor.py
+\ $\ git\ commit\ \-m\ \[aq][yourextractor]\ Add\ new\ extractor\[aq]
+\ $\ git\ push\ origin\ yourextractor
\f[]
.fi
.RE
@@ -2404,7 +2405,7 @@ For discussions, join us in the IRC channel
(webchat (https://webchat.freenode.net/?randomnick=1&channels=youtube-dl)).
.PP
\f[B]Please include the full output of youtube\-dl when run with
-\f[C]\-v\f[]\f[], i.e.
+\f[BC]\-v\f[B]\f[], i.e.
\f[B]add\f[] \f[C]\-v\f[] flag to \f[B]your command line\f[], copy the
\f[B]whole\f[] output and post it in the issue body wrapped in ``` for
better formatting.
diff --git a/network/youtube-dl/youtube-dl.SlackBuild b/network/youtube-dl/youtube-dl.SlackBuild
index db7fe3faf9..a9ba5e25fe 100644
--- a/network/youtube-dl/youtube-dl.SlackBuild
+++ b/network/youtube-dl/youtube-dl.SlackBuild
@@ -24,8 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=youtube-dl
-SRCNAM=$(echo $PRGNAM | tr - _)
-VERSION=${VERSION:-2018.04.09}
+VERSION=${VERSION:-2018.05.01}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,7 +61,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
diff --git a/network/youtube-dl/youtube-dl.info b/network/youtube-dl/youtube-dl.info
index 4db14b4b3e..1a9ed93ebe 100644
--- a/network/youtube-dl/youtube-dl.info
+++ b/network/youtube-dl/youtube-dl.info
@@ -1,8 +1,8 @@
PRGNAM="youtube-dl"
-VERSION="2018.04.09"
+VERSION="2018.05.01"
HOMEPAGE="https://rg3.github.io/youtube-dl"
-DOWNLOAD="https://github.com/rg3/youtube-dl/archive/2018.04.09/youtube_dl-2018.04.09.tar.gz"
-MD5SUM="fabb9bd95e22d89ee1c60cc955fce525"
+DOWNLOAD="https://github.com/rg3/youtube-dl/archive/2018.04.09/youtube-dl-2018.05.01.tar.gz"
+MD5SUM="f8c1a79c58a46c72cb4b323d4723b002"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""