summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author dsomero <xgizzmo@slackbuilds.org>2011-04-10 13:30:06 -0400
committer Robby Workman <rworkman@slackbuilds.org>2011-04-11 00:10:58 -0500
commit422df92bd666700bd5ac51ff2a4205721359e40f (patch)
treec557f200ffde46cf9a6796f20eaec188c2ce7d2a
parenta1bf72c0c035200806022b852379eac76947b5d0 (diff)
downloadslackbuilds-422df92bd666700bd5ac51ff2a4205721359e40f.tar.gz
slackbuilds-422df92bd666700bd5ac51ff2a4205721359e40f.tar.xz
perl/perl-SOAP-Lite: Added (SOAP::Lite module)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--perl/perl-SOAP-Lite/README7
-rw-r--r--perl/perl-SOAP-Lite/SOAP-Lite-0.710.08.patch12
-rw-r--r--perl/perl-SOAP-Lite/SOAP-Lite-0.712_sysread.patch38
-rw-r--r--perl/perl-SOAP-Lite/perl-SOAP-Lite.SlackBuild113
-rw-r--r--perl/perl-SOAP-Lite/perl-SOAP-Lite.info10
-rw-r--r--perl/perl-SOAP-Lite/slack-desc19
6 files changed, 199 insertions, 0 deletions
diff --git a/perl/perl-SOAP-Lite/README b/perl/perl-SOAP-Lite/README
new file mode 100644
index 0000000000..ac8d71a89d
--- /dev/null
+++ b/perl/perl-SOAP-Lite/README
@@ -0,0 +1,7 @@
+SOAP::Lite is a collection of Perl modules which provides a simple
+and lightweight interface to the Simple Object Access Protocol (SOAP)
+both on client and server side.
+
+This requires perl-Task-Weaken, perl-Class-Inspector,
+libwww-perl, perl-MIME-Lite, perl-Data-Dumper.
+
diff --git a/perl/perl-SOAP-Lite/SOAP-Lite-0.710.08.patch b/perl/perl-SOAP-Lite/SOAP-Lite-0.710.08.patch
new file mode 100644
index 0000000000..0b1e6e8470
--- /dev/null
+++ b/perl/perl-SOAP-Lite/SOAP-Lite-0.710.08.patch
@@ -0,0 +1,12 @@
+diff -Nuar SOAP-Lite-0.710.08.orig/Makefile.PL SOAP-Lite-0.710.08/Makefile.PL
+--- SOAP-Lite-0.710.08.orig/Makefile.PL 2008-06-28 11:37:20.000000000 -0700
++++ SOAP-Lite-0.710.08/Makefile.PL 2008-12-07 23:42:03.341939336 -0800
+@@ -43,7 +43,7 @@
+ ["DIME messages","SOAP::Packager::DIME",{"IO::Scalar" => "2.105", "DIME::Tools" => 0.03, "Data::UUID" => "0.11"},0],
+ ["SSL Support for TCP Transport","SOAP::Transport::TCP",{"IO::Socket::SSL" => 0},0],
+ ["Compression support for HTTP","SOAP::Transport::HTTP",{"Compress::Zlib" => 0},0],
+- ["MIME interoperability w/ Axis","SOAP::Lite",{"MIME::Parser" => "6.106"},0],
++ ["MIME interoperability w/ Axis","SOAP::Lite",{"MIME::Parser" => "5.413"},0],
+ );
+
+ use Getopt::Long;
diff --git a/perl/perl-SOAP-Lite/SOAP-Lite-0.712_sysread.patch b/perl/perl-SOAP-Lite/SOAP-Lite-0.712_sysread.patch
new file mode 100644
index 0000000000..85289fcada
--- /dev/null
+++ b/perl/perl-SOAP-Lite/SOAP-Lite-0.712_sysread.patch
@@ -0,0 +1,38 @@
+From 8f49c0e970261f59bc043a8104a9a730ec69dcf4 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Wed, 23 Mar 2011 18:04:19 +0100
+Subject: [PATCH] Use read() instead of sysread() when using mod_perl
+
+https://rt.cpan.org/Public/Bug/Display.html?id=58538
+---
+ lib/SOAP/Transport/HTTP.pm | 14 +++++++++++---
+ 1 files changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/lib/SOAP/Transport/HTTP.pm b/lib/SOAP/Transport/HTTP.pm
+index f16b990..57ebbf3 100644
+--- a/lib/SOAP/Transport/HTTP.pm
++++ b/lib/SOAP/Transport/HTTP.pm
+@@ -566,9 +566,17 @@ sub handle {
+ if ( !$chunked ) {
+ my $buffer;
+ binmode(STDIN);
+- while ( sysread( STDIN, $buffer, $length ) ) {
+- $content .= $buffer;
+- last if ( length($content) >= $length );
++ if ( defined($ENV{"MOD_PERL"}) ) {
++ while ( read( STDIN, $buffer, $length ) ) {
++ $content .= $buffer;
++ last if ( length($content) >= $length );
++ }
++ }
++ else {
++ while ( sysread( STDIN, $buffer, $length ) ) {
++ $content .= $buffer;
++ last if ( length($content) >= $length );
++ }
+ }
+ }
+
+--
+1.7.3.4
+
diff --git a/perl/perl-SOAP-Lite/perl-SOAP-Lite.SlackBuild b/perl/perl-SOAP-Lite/perl-SOAP-Lite.SlackBuild
new file mode 100644
index 0000000000..13c7c513bf
--- /dev/null
+++ b/perl/perl-SOAP-Lite/perl-SOAP-Lite.SlackBuild
@@ -0,0 +1,113 @@
+#!/bin/sh
+
+# Slackware build script for perl-SOAP-Lite
+# Written by David Somero <dsomero@hotmail.com>
+# Derived from Slackware's Slackbuilds.
+#
+# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2011 David Somero (dsomero@hotmail.com) Athens, TN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=perl-SOAP-Lite
+VERSION=${VERSION:-0.712}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=SOAP-Lite
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# This patch alters the dependancy to the "real" stable version of MIME::Parser.
+patch -p1 < $CWD/SOAP-Lite-0.710.08.patch
+# https://rt.cpan.org/Public/Bug/Display.html?id=58538
+patch -p1 < $CWD/SOAP-Lite-0.712_sysread.patch
+
+perl Makefile.PL --noprompt \
+ PREFIX=/usr \
+ INSTALLDIRS=vendor \
+ INSTALLVENDORMAN1DIR=/usr/man/man1 \
+ INSTALLVENDORMAN3DIR=/usr/man/man3
+make
+# This module attempts to access an external website for validation
+# of the MIME::Parser.
+#make test
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ HACKING README *.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/perl/perl-SOAP-Lite/perl-SOAP-Lite.info b/perl/perl-SOAP-Lite/perl-SOAP-Lite.info
new file mode 100644
index 0000000000..a1f117b4fd
--- /dev/null
+++ b/perl/perl-SOAP-Lite/perl-SOAP-Lite.info
@@ -0,0 +1,10 @@
+PRGNAM="perl-SOAP-Lite"
+VERSION="0.712"
+HOMEPAGE="http://search.cpan.org/~mkutter/SOAP-Lite-0.712/"
+DOWNLOAD="http://search.cpan.org/CPAN/authors/id/M/MK/MKUTTER/SOAP-Lite-0.712.tar.gz"
+MD5SUM="fd71a0c0feff85f670ab4b2e571652a8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Somero"
+EMAIL="dsomero@hotmail.com"
+APPROVED="rworkman"
diff --git a/perl/perl-SOAP-Lite/slack-desc b/perl/perl-SOAP-Lite/slack-desc
new file mode 100644
index 0000000000..75c4c90136
--- /dev/null
+++ b/perl/perl-SOAP-Lite/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+perl-SOAP-Lite: perl-SOAP-Lite (lightweight interface to SOAP)
+perl-SOAP-Lite:
+perl-SOAP-Lite: SOAP::Lite is a collection of Perl modules which provides a simple
+perl-SOAP-Lite: and lightweight interface to the Simple Object Access Protocol (SOAP)
+perl-SOAP-Lite: both on client and server side.
+perl-SOAP-Lite:
+perl-SOAP-Lite: Homepage: http://search.cpan.org/~mkutter/SOAP-Lite-0.712/
+perl-SOAP-Lite:
+perl-SOAP-Lite:
+perl-SOAP-Lite:
+perl-SOAP-Lite: