summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2016-06-20 23:00:59 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-25 08:54:58 +0700
commit4b371a532fb7ecd264000cb250987e9ff0367c7b (patch)
tree940f95f5f789ef40ccf963662b5b3a9ecc823fc1
parent563a7a18b46c14601fc3eae00e93fd131279bacc (diff)
downloadslackbuilds-4b371a532fb7ecd264000cb250987e9ff0367c7b.tar.gz
slackbuilds-4b371a532fb7ecd264000cb250987e9ff0367c7b.tar.xz
python/munch: Added (Python dict with attribute-style access).
-rw-r--r--python/munch/README2
-rw-r--r--python/munch/munch.SlackBuild82
-rw-r--r--python/munch/munch.info10
-rw-r--r--python/munch/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/python/munch/README b/python/munch/README
new file mode 100644
index 0000000000..1d6a19c454
--- /dev/null
+++ b/python/munch/README
@@ -0,0 +1,2 @@
+Munch implements a Python dictionary that provides attribute-style access (a la
+JavaScript objects). Munch is a fork of David Schoonover's Bunch package.
diff --git a/python/munch/munch.SlackBuild b/python/munch/munch.SlackBuild
new file mode 100644
index 0000000000..7d13341a54
--- /dev/null
+++ b/python/munch/munch.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# Slackware build script for munch
+
+# Copyright 2016 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=munch
+VERSION=${VERSION:-2.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/munch/munch.info b/python/munch/munch.info
new file mode 100644
index 0000000000..c0449ef06c
--- /dev/null
+++ b/python/munch/munch.info
@@ -0,0 +1,10 @@
+PRGNAM="munch"
+VERSION="2.0.4"
+HOMEPAGE="https://github.com/Infinidat/munch"
+DOWNLOAD="https://github.com/Infinidat/munch/archive/2.0.4/munch-2.0.4.tar.gz"
+MD5SUM="ab2ac3be4189e1f54c268f9dbf3be743"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/munch/slack-desc b/python/munch/slack-desc
new file mode 100644
index 0000000000..868bbde712
--- /dev/null
+++ b/python/munch/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+munch: munch (Python dictionary with attribute-style access)
+munch:
+munch: Munch implements a Python dictionary that provides attribute-style
+munch: access (a la JavaScript objects).
+munch:
+munch:
+munch:
+munch:
+munch:
+munch:
+munch: