summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2018-03-18 23:24:30 +0000
committer David Spencer <idlemoor@slackbuilds.org>2018-03-18 23:24:30 +0000
commit62499a2187c05506e9ed628a6f25816dd12a5a08 (patch)
tree6fd1c2328998fdd41b8ea3fb78cf717299568be9
parentfd684dd68bc1e0c0af27ef365df4525c69f05878 (diff)
downloadslackbuilds-62499a2187c05506e9ed628a6f25816dd12a5a08.tar.gz
slackbuilds-62499a2187c05506e9ed628a6f25816dd12a5a08.tar.xz
python/stopit: Updated for version 1.1.2.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--python/stopit/README8
-rw-r--r--python/stopit/stopit.SlackBuild17
-rw-r--r--python/stopit/stopit.info8
3 files changed, 21 insertions, 12 deletions
diff --git a/python/stopit/README b/python/stopit/README
index 3057bee0be..ff486a06ed 100644
--- a/python/stopit/README
+++ b/python/stopit/README
@@ -1,2 +1,6 @@
-Raise asynchronous exceptions in other threads, control the timeout of
-blocks or callables with two context managers and two decorators.
+The stopit python module provides the user with a function that raises an
+exception in another thread, including the main thread. It also provides two
+context managers that may stop its inner block activity on timeout and two
+decorators that may stop its decorated callables on timeout.
+
+This SlackBuild will build with Python 3 support if it is installed.
diff --git a/python/stopit/stopit.SlackBuild b/python/stopit/stopit.SlackBuild
index e968160951..b29224c7b7 100644
--- a/python/stopit/stopit.SlackBuild
+++ b/python/stopit/stopit.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for stopit
-# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015, 2018 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=stopit
-VERSION=${VERSION:-1.1.1}
+VERSION=${VERSION:-1.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -71,11 +71,16 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES* README* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/stopit/stopit.info b/python/stopit/stopit.info
index 524df6cba8..586675675a 100644
--- a/python/stopit/stopit.info
+++ b/python/stopit/stopit.info
@@ -1,8 +1,8 @@
PRGNAM="stopit"
-VERSION="1.1.1"
-HOMEPAGE="https://pypi.python.org/pypi/stopit"
-DOWNLOAD="https://pypi.python.org/packages/source/s/stopit/stopit-1.1.1.tar.gz"
-MD5SUM="dec60dae41bec73233e83db003390bdc"
+VERSION="1.1.2"
+HOMEPAGE="https://github.com/glenfant/stopit"
+DOWNLOAD="https://github.com/glenfant/stopit/archive/1.1.2/stopit-1.1.2.tar.gz"
+MD5SUM="9849a16ffd377ade4ade2d0ba0978500"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""