summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Lindberg <hackedhead@gmail.com>2010-05-11 15:00:25 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 15:00:25 +0200
commit74fc0bef0c086e61274511bca87421a682a221d5 (patch)
tree608b184350deecaad3a42eadc3bc2c0459154256
parent6a380381802c8c9bc458ce04bb5670e0775e93c4 (diff)
downloadslackbuilds-74fc0bef0c086e61274511bca87421a682a221d5.tar.gz
slackbuilds-74fc0bef0c086e61274511bca87421a682a221d5.tar.xz
multimedia/eyeD3: Initial import
-rw-r--r--multimedia/eyeD3/README4
-rw-r--r--multimedia/eyeD3/eyeD3.SlackBuild73
-rw-r--r--multimedia/eyeD3/eyeD3.info8
-rw-r--r--multimedia/eyeD3/slack-desc11
4 files changed, 96 insertions, 0 deletions
diff --git a/multimedia/eyeD3/README b/multimedia/eyeD3/README
new file mode 100644
index 0000000000..a571241ab4
--- /dev/null
+++ b/multimedia/eyeD3/README
@@ -0,0 +1,4 @@
+eyeD3 is a Python module and program for processing ID3 tags.
+Information about mp3 files (i.e bit rate, sample frequency,
+play time, etc.) is also provided. The formats supported are
+ID3 v1.0/v1.1 and v2.3/v2.4.
diff --git a/multimedia/eyeD3/eyeD3.SlackBuild b/multimedia/eyeD3/eyeD3.SlackBuild
new file mode 100644
index 0000000000..f1b8790ab8
--- /dev/null
+++ b/multimedia/eyeD3/eyeD3.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for abiword
+
+# Copyright 2007 Andrew Lindberg <alindberg@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuilds.org project
+# No additional license terms added
+
+PRGNAM=eyeD3
+VERSION=0.6.14
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# eyeD3 neatly wraps the setup.py script in an automake system
+# --docdir is ignored by the build process, but we'll leave it here anyway
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ || exit 1
+
+make || exit 1
+make DESTDIR=$PKG install || exit 1
+
+# and the automake does everything neatly for docs and man pages, et al
+# just need the slack-specific files
+mv $PKG/usr/share/doc $PKG/usr
+rmdir $PKG/usr/share
+( cd $PKG/usr/doc/$PRGNAM-$VERSION
+ cat $CWD/$PRGNAM.SlackBuild > $PRGNAM.SlackBuild
+ gzip -d {COPYING.gz,ChangeLog.gz}
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/multimedia/eyeD3/eyeD3.info b/multimedia/eyeD3/eyeD3.info
new file mode 100644
index 0000000000..5791361751
--- /dev/null
+++ b/multimedia/eyeD3/eyeD3.info
@@ -0,0 +1,8 @@
+PRGNAM="eyeD3"
+VERSION="0.6.14"
+HOMEPAGE="http://eyed3.nicfit.net/"
+DOWNLOAD="http://eyed3.nicfit.net/releases/eyeD3-0.6.14.tar.gz"
+MD5SUM="c4f81b3cbb72993244f27ab740abbccc"
+MAINTAINER="Andrew Lindberg"
+EMAIL="hackedhead@gmail.com"
+APPROVED="rworkman"
diff --git a/multimedia/eyeD3/slack-desc b/multimedia/eyeD3/slack-desc
new file mode 100644
index 0000000000..dea70964eb
--- /dev/null
+++ b/multimedia/eyeD3/slack-desc
@@ -0,0 +1,11 @@
+eyeD3: eyeD3 is a Python module and program for processing ID3 tags
+eyeD3:
+eyeD3: eyeD3 is a Python module and program for processing ID3 tags.
+eyeD3: Information about mp3 files (i.e bit rate, sample frequency,
+eyeD3: play time, etc.) is also provided. The formats supported are
+eyeD3: ID3 v1.0/v1.1 and v2.3/v2.4.
+eyeD3:
+eyeD3: http://eyed3.nicfit.net/
+eyeD3:
+eyeD3:
+eyeD3: