summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2016-01-02 01:53:34 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-17 09:40:16 +0700
commit837bda4bd76add741771517c577a489b889ff150 (patch)
treeb150a80e5ce199ccd62469994d27c33aa0d60bce
parent1b1571627ed1746500747fce436e82db26d82680 (diff)
downloadslackbuilds-837bda4bd76add741771517c577a489b889ff150.tar.gz
slackbuilds-837bda4bd76add741771517c577a489b889ff150.tar.xz
development/scons: Removed (included in Slackware 14.2)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--development/scons/README5
-rw-r--r--development/scons/scons.SlackBuild76
-rw-r--r--development/scons/scons.info10
-rw-r--r--development/scons/slack-desc19
4 files changed, 0 insertions, 110 deletions
diff --git a/development/scons/README b/development/scons/README
deleted file mode 100644
index 3e749f8528..0000000000
--- a/development/scons/README
+++ /dev/null
@@ -1,5 +0,0 @@
-SCons is an Open Source software construction tool--that is, a next-generation
-build tool. Think of SCons as an improved, cross-platform substitute for the
-classic Make utility with integrated functionality similar to
-autoconf/automake and compiler caches such as ccache. In short, SCons is an
-easier, more reliable and faster way to build software.
diff --git a/development/scons/scons.SlackBuild b/development/scons/scons.SlackBuild
deleted file mode 100644
index 559c5c625c..0000000000
--- a/development/scons/scons.SlackBuild
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for scons
-
-# Written by Kyle Guinn <elyk03@gmail.com>
-# Updated by Andrzej Telszewski <atelszewski@gmail.com>
-
-# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
-
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version, with the following exception:
-# the text of the GPL license may be omitted.
-
-# This program is distributed in the hope that it will be useful, but
-# without any warranty; without even the implied warranty of
-# merchantability or fitness for a particular purpose. Compiling,
-# interpreting, executing or merely reading the text of the program
-# may result in lapses of consciousness and/or very being, up to and
-# including the end of all existence and the Universe as we know it.
-# See the GNU General Public License for more details.
-
-# You may have received a copy of the GNU General Public License along
-# with this program (most likely, a file named COPYING). If not, see
-# <https://www.gnu.org/licenses/>.
-
-PRGNAM=scons
-VERSION=${VERSION:-2.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM-$VERSION
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="CHANGES.txt LICENSE.txt README.txt RELEASE.txt"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python ./setup.py install --root=$PKG --symlink-scons
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/scons/scons.info b/development/scons/scons.info
deleted file mode 100644
index 13ac8383c6..0000000000
--- a/development/scons/scons.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="scons"
-VERSION="2.4.1"
-HOMEPAGE="http://www.scons.org/"
-DOWNLOAD="http://downloads.sourceforge.net/scons/scons-2.4.1.tar.gz"
-MD5SUM="9a0ddf33d9839f04380e0fae87cc4b40"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Ryan P.C. McQuen"
-EMAIL="ryan.q@linux.com"
diff --git a/development/scons/slack-desc b/development/scons/slack-desc
deleted file mode 100644
index 1a9894f461..0000000000
--- a/development/scons/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-scons: SCons (Open Source software construction tool)
-scons:
-scons: SCons is an Open Source software construction tool--that is,
-scons: a next-generation build tool. Think of SCons as an improved,
-scons: cross-platform substitute for the classic Make utility with
-scons: integrated functionality similar to autoconf/automake and
-scons: compiler caches such as ccache. In short, SCons is an easier,
-scons: more reliable and faster way to build software.
-scons:
-scons:
-scons: