summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author dsomero <xgizzmo@slackbuilds.org>2011-04-10 13:32:14 -0400
committer Robby Workman <rworkman@slackbuilds.org>2011-04-11 00:10:59 -0500
commit856da59fe8e70c616a38ec8b1b51930d966a5e17 (patch)
tree4840d1eefe1ddc008c1443d41ee608bfe6bc5e23
parenta43adc1a85044824bd0074167abc030812bde60a (diff)
downloadslackbuilds-856da59fe8e70c616a38ec8b1b51930d966a5e17.tar.gz
slackbuilds-856da59fe8e70c616a38ec8b1b51930d966a5e17.tar.xz
perl/perl-Tk-TableMatrix: Added (Tk::TableMatrix module)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--perl/perl-Tk-TableMatrix/README5
-rw-r--r--perl/perl-Tk-TableMatrix/pTk-1.22.patch18
-rw-r--r--perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.SlackBuild111
-rw-r--r--perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.info10
-rw-r--r--perl/perl-Tk-TableMatrix/slack-desc19
5 files changed, 163 insertions, 0 deletions
diff --git a/perl/perl-Tk-TableMatrix/README b/perl/perl-Tk-TableMatrix/README
new file mode 100644
index 0000000000..187fdabc04
--- /dev/null
+++ b/perl/perl-Tk-TableMatrix/README
@@ -0,0 +1,5 @@
+The TableMatrix command creates a 2-dimensional grid of cells. The
+table can use a Tcl array variable or Tcl command for data storage
+and retrieval.
+
+This requires perl-tk.
diff --git a/perl/perl-Tk-TableMatrix/pTk-1.22.patch b/perl/perl-Tk-TableMatrix/pTk-1.22.patch
new file mode 100644
index 0000000000..ff9938535b
--- /dev/null
+++ b/perl/perl-Tk-TableMatrix/pTk-1.22.patch
@@ -0,0 +1,18 @@
+--- pTk/Makefile.PL.old 2006-05-01 18:09:31.000000000 -0400
++++ pTk/Makefile.PL 2006-05-01 18:10:05.000000000 -0400
+@@ -234,11 +234,11 @@ sub MY::postamble {
+ my $self = shift;
+ my $dep = $self->Tk::MMutil::mTk_postamble;
+
+-$dep .= $self->dir_target(@{$self->{'dir_targets'}});
+-
+-$dep .= "config :: " . join(" \\\n\t",map($self->catfile($_,".exists"),@{$self->{'dir_targets'}})) .
+- "\n\t".$self->{NOECHO}."\$(NOOP)\n";
+
++if ($Tk::MMutil::IsWin32 or ($win_arch eq 'MSWin32' and $^O eq 'cygwin'))
++ {
++ my $cc = $Config{'cc'};
++ }
+
+ $dep . '
+
diff --git a/perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.SlackBuild b/perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.SlackBuild
new file mode 100644
index 0000000000..ab1dc6559f
--- /dev/null
+++ b/perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.SlackBuild
@@ -0,0 +1,111 @@
+#!/bin/sh
+
+# Slackware build script for perl-Tk-TableMatrix
+# Written by David Somero <dsomero@hotmail.com>
+# Derived from Slackware's Slackbuilds.
+#
+# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2011 David Somero (dsomero@hotmail.com) Athens, TN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=perl-Tk-TableMatrix
+VERSION=${VERSION:-1.23}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=Tk-TableMatrix
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch -p0 < $CWD/pTk-1.22.patch
+
+perl Makefile.PL \
+ PREFIX=/usr \
+ INSTALLDIRS=vendor \
+ INSTALLVENDORMAN1DIR=/usr/man/man1 \
+ INSTALLVENDORMAN3DIR=/usr/man/man3
+make
+make test
+make install DESTDIR=$PKG
+
+# This file is part of perl-tk so nuke it.
+rm $PKG/usr/lib$LIBDIRSUFFIX/perl5/vendor_perl/5.12.3/$ARCH-linux-thread-multi/auto/Tk/pTk/extralibs.ld
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING ChangeLog README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.info b/perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.info
new file mode 100644
index 0000000000..7c90137fcc
--- /dev/null
+++ b/perl/perl-Tk-TableMatrix/perl-Tk-TableMatrix.info
@@ -0,0 +1,10 @@
+PRGNAM="perl-Tk-TableMatrix"
+VERSION="1.23"
+HOMEPAGE="http://search.cpan.org/~cerney/Tk-TableMatrix-1.23/"
+DOWNLOAD="http://search.cpan.org/CPAN/authors/id/C/CE/CERNEY/Tk-TableMatrix-1.23.tar.gz"
+MD5SUM="6b7653d129bf1a8327054a88b58d6364"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Somero"
+EMAIL="dsomero@hotmail.com"
+APPROVED="rworkman"
diff --git a/perl/perl-Tk-TableMatrix/slack-desc b/perl/perl-Tk-TableMatrix/slack-desc
new file mode 100644
index 0000000000..553d120a7e
--- /dev/null
+++ b/perl/perl-Tk-TableMatrix/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+perl-Tk-TableMatrix: perl-Tk-TableMatrix (Create and manipulate tables)
+perl-Tk-TableMatrix:
+perl-Tk-TableMatrix: The TableMatrix command creates a 2-dimensional grid of cells. The
+perl-Tk-TableMatrix: table can use a Tcl array variable or Tcl command for data storage
+perl-Tk-TableMatrix: and retrieval.
+perl-Tk-TableMatrix:
+perl-Tk-TableMatrix: Homepage: http://search.cpan.org/~cerney/Tk-TableMatrix-1.23/
+perl-Tk-TableMatrix:
+perl-Tk-TableMatrix:
+perl-Tk-TableMatrix:
+perl-Tk-TableMatrix: