summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:11 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:23 +0700
commit9747a79c32e5da245fc0e7a6fb89d5f504af658f (patch)
tree3afb767e7330822d01e7e97ec0cba5d380df5fa3
parentd2791345ae867a37f9ef06c6aa62be4247056d11 (diff)
downloadslackbuilds-9747a79c32e5da245fc0e7a6fb89d5f504af658f.tar.gz
slackbuilds-9747a79c32e5da245fc0e7a6fb89d5f504af658f.tar.xz
python/celery: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/celery/README17
-rw-r--r--python/celery/celery.SlackBuild6
2 files changed, 11 insertions, 12 deletions
diff --git a/python/celery/README b/python/celery/README
index afa76c63db..6bc0f28112 100644
--- a/python/celery/README
+++ b/python/celery/README
@@ -1,13 +1,14 @@
Distributed Task Queue
-Task queues are used as a mechanism to distribute work across threads or machines.
+Task queues are used as a mechanism to distribute work across threads or
+machines.
-A task queue's input is a unit of work, called a task, dedicated worker processes
-then constantly monitor the queue for new work to perform.
+A task queue's input is a unit of work, called a task, dedicated worker
+processes then constantly monitor the queue for new work to perform.
-Celery communicates via messages, usually using a broker to mediate between clients
-and workers. To initiate a task a client puts a message on the queue, the broker
-then delivers the message to a worker.
+Celery communicates via messages, usually using a broker to mediate
+between clients and workers. To initiate a task a client puts a message
+on the queue, the broker then delivers the message to a worker.
-A Celery system can consist of multiple workers and brokers, giving way to high
-availability and horizontal scaling.
+A Celery system can consist of multiple workers and brokers, giving way
+to high availability and horizontal scaling.
diff --git a/python/celery/celery.SlackBuild b/python/celery/celery.SlackBuild
index be24cc427a..48f979a937 100644
--- a/python/celery/celery.SlackBuild
+++ b/python/celery/celery.SlackBuild
@@ -53,10 +53,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION