summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2018-04-27 23:33:38 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-28 06:40:14 +0700
commit9945b06141f98ea555ee8c91adbfbb49142865b9 (patch)
tree5cab821429e76d1664fff6ca2b6165c0daaa5cdd
parent5fe16980b677edcaf6a6d8c1c6a0b97bd1c96db6 (diff)
downloadslackbuilds-9945b06141f98ea555ee8c91adbfbb49142865b9.tar.gz
slackbuilds-9945b06141f98ea555ee8c91adbfbb49142865b9.tar.xz
gis/OTB: Added (image processing library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--gis/OTB/OTB.SlackBuild125
-rw-r--r--gis/OTB/OTB.info10
-rw-r--r--gis/OTB/README12
-rw-r--r--gis/OTB/doinst.sh13
-rw-r--r--gis/OTB/slack-desc19
5 files changed, 179 insertions, 0 deletions
diff --git a/gis/OTB/OTB.SlackBuild b/gis/OTB/OTB.SlackBuild
new file mode 100644
index 0000000000..ced7f29cbc
--- /dev/null
+++ b/gis/OTB/OTB.SlackBuild
@@ -0,0 +1,125 @@
+#!/bin/sh
+
+# SlackBuild script for OTB
+
+# Copyright 2014-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=OTB
+VERSION=${VERSION:-6.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s/lib\b/lib${LIBDIRSUFFIX}/" \
+ CMakeLists.txt \
+ CMake/OTBModuleExternal.cmake \
+ CMake/OTBStandaloneModuleMacros.cmake \
+ CMake/OTBApplicationMacros.cmake \
+ CMake/CPackFunctions.cmake
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_APPLICATIONS=ON \
+ -DBUILD_EXAMPLES=OFF \
+ -DBUILD_TESTING=OFF \
+ -DOTB_USE_CURL=ON \
+ -DOTB_USE_QT4=ON \
+ -DOTB_USE_QWT=ON \
+ -DOTB_USE_GLEW=ON \
+ -DOTB_USE_LIBKML=OFF \
+ -DOTB_USE_MUPARSER=ON \
+ -DOTB_USE_OPENCV=${OPENCV:-OFF} \
+ -DOTB_USE_OPENGL=ON \
+ -DOTB_USE_OPENMP=ON \
+ -DOTB_USE_SHARK=ON \
+ -DOTB_WRAP_PYTHON=ON \
+ -DOTB_INSTALL_PYTHON_DIR=$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())") \
+ -DOTB_WRAP_PYTHON3=ON \
+ -DOTB_INSTALL_PYTHON3_DIR=$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())") \
+ -DOTB_INSTALL_DOC_DIR=doc/$PRGNAM-$VERSION \
+ ..
+
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md RELEASE_NOTES.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/OTB/OTB.info b/gis/OTB/OTB.info
new file mode 100644
index 0000000000..7a292f6a98
--- /dev/null
+++ b/gis/OTB/OTB.info
@@ -0,0 +1,10 @@
+PRGNAM="OTB"
+VERSION="6.4.0"
+HOMEPAGE="http://orfeo-toolbox.org/otb/"
+DOWNLOAD="https://github.com/orfeotoolbox/OTB/archive/6.4.0/OTB-6.4.0.tar.gz"
+MD5SUM="21b425dc0b8884bf2441f372ed041d8e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gdal ITK OpenSceneGraph muParser python3 ossim qwt Shark tinyxml"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/OTB/README b/gis/OTB/README
new file mode 100644
index 0000000000..706771a02e
--- /dev/null
+++ b/gis/OTB/README
@@ -0,0 +1,12 @@
+ORFEO Toolbox (OTB) is an open source library of image processing algorithms.
+OTB is based on the medical image processing library ITK and offers particular
+functionalities for remote sensing image processing in general and for high
+spatial resolution images in particular. Targeted algorithms for high
+resolution optical images (Pleiades, SPOT, QuickBird, WorldView, Landsat,
+Ikonos), hyperspectral sensors (Hyperion) or SAR (TerraSarX, ERS, Palsar) are
+available.
+
+Monteverdi, a satellite image viewer with access to OTB processing, will also
+be built as part of this script.
+
+OTB may use the following optional dependencies: opencv (use OPENCV=ON).
diff --git a/gis/OTB/doinst.sh b/gis/OTB/doinst.sh
new file mode 100644
index 0000000000..19ad22754d
--- /dev/null
+++ b/gis/OTB/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/gis/OTB/slack-desc b/gis/OTB/slack-desc
new file mode 100644
index 0000000000..6a7c504733
--- /dev/null
+++ b/gis/OTB/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+OTB: OTB (image processing library)
+OTB:
+OTB: OTB, the ORFEO Toolbox, is a library of image processing algorithms
+OTB: that offers particular functionalities for remote sensing
+OTB: in general and for high spatial resolution images in particular.
+OTB:
+OTB:
+OTB:
+OTB:
+OTB:
+OTB: