summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2012-09-21 06:33:51 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-22 11:39:46 -0500
commit994e72589bfe86fda005430e9373494495f4c82a (patch)
tree6d7e1d8ea78c3d599d49b7164a7b65244673b3ad
parent3a951292ce2b2431f37b525caf5384f4c2370beb (diff)
downloadslackbuilds-994e72589bfe86fda005430e9373494495f4c82a.tar.gz
slackbuilds-994e72589bfe86fda005430e9373494495f4c82a.tar.xz
audio/transcribe: Updated for version 8.21.1.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--audio/transcribe/README2
-rw-r--r--audio/transcribe/transcribe.SlackBuild60
-rw-r--r--audio/transcribe/transcribe.info10
3 files changed, 43 insertions, 29 deletions
diff --git a/audio/transcribe/README b/audio/transcribe/README
index f1ec96d87d..0ecb5d597c 100644
--- a/audio/transcribe/README
+++ b/audio/transcribe/README
@@ -10,5 +10,3 @@ be fully functional for a 30-day evaluation period. To buy the software,
use the site at http://www.seventhstring.com/xscribe/buy.html. The
Slackware package doesn't need to be changed or updated (just enter the
license key).
-
-(Note: The "Buy" button in the app doesn't work, use the URL above instead)
diff --git a/audio/transcribe/transcribe.SlackBuild b/audio/transcribe/transcribe.SlackBuild
index 241deeec12..1eb0b630c8 100644
--- a/audio/transcribe/transcribe.SlackBuild
+++ b/audio/transcribe/transcribe.SlackBuild
@@ -6,48 +6,60 @@
# Notes:
-# Closed-source software, precompiled binary for x86, deps are
-# all included in Slackware.
+# Closed-source software, precompiled binaries for x86 and x86_64,
+# deps are all included in Slackware.
# Originally ported from Windows, so it expects to be run from its
-# own directory. We install to /usr/lib/transcribe, and a wrapper
+# own directory. We install to /usr/lib(64)?/transcribe, and a wrapper
# script /usr/bin/transcribe that cd's to the install dir and runs
# the app from there (this allows the app's help system to work).
-# ARCH is hard-coded to i486 because the bin is 32-bit x86. If you're
-# on Slackware64, try alienBOB's -compat32 (multilib) packages. The
-# author of this script was able to get the app to work that way.
-
# Upgrading from the 30-day eval to the registered version is just
# a matter of entering the license key (no change to the package
# needed).
-# Annoyingly, the in-app "Buy" button doesn't work. It's supposed to
-# open a browser & display the order form on their site.. It's looking for
-# something in /usr/share/applnk (I suppose to tell it which browser
-# to use), but this dir is empty on modern Slackware.
-
# The version number doesn't appear in the tarball filename or the URL,
# so be careful that $VERSION matches the actual version number (found
# in Help/About)
+# If you run transcribe from a terminal, you'll see:
+# sh: lsb_release: command not found
+# These errors don't seem to actually cause any harm (app runs fine), but
+# I don't want to try to suppress them in the wrapper script either.
+
PRGNAM=transcribe
-VERSION=${VERSION:-8.10.0}
+VERSION=${VERSION:-8.21.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-ARCH=i486
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ echo "Unsupported ARCH '$ARCH', this package probably won't work"
+ sleep 5
+ LIBDIRSUFFIX=""
+fi
+
# The dist tarball's filename has no connection whatsoever to
# the actual name of the program...
-TARNAME=xscsetup.tar.gz
-
-# No LIBDIRSUFFIX stuff here, it's a 32-bit-only app. Also, the
-# binary is already stripped.
+TARNAME=xsc${LIBDIRSUFFIX}setup.tar.gz
set -e
@@ -58,18 +70,22 @@ rm -rf $PRGNAM
tar xvf $CWD/$TARNAME
cd $PRGNAM
-mkdir -p $PKG/usr/lib/$PRGNAM \
+sed "s,/usr/lib,/usr/lib$LIBDIRSUFFIX,g" \
+ < $CWD/$PRGNAM.sh \
+ > $PRGNAM.sh
+
+mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM \
$PKG/usr/doc/$PRGNAM-$VERSION \
$PKG/usr/bin \
$PKG/install \
$PKG/usr/share/applications \
$PKG/usr/share/pixmaps
-install -oroot -groot -m0755 $PRGNAM $PKG/usr/lib/$PRGNAM/
-install -oroot -groot -m0644 xschelp.htb $PKG/usr/lib/$PRGNAM/
+install -oroot -groot -m0755 $PRGNAM $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM/
+install -oroot -groot -m0644 xschelp.htb $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM/
install -oroot -groot -m0644 readme_gtk.html $PKG/usr/doc/$PRGNAM-$VERSION/
install -oroot -groot -m0644 gtkicons/xsc128x128.png $PKG/usr/share/pixmaps/
-install -oroot -groot -m0755 $CWD/$PRGNAM.sh $PKG/usr/bin/$PRGNAM
+install -oroot -groot -m0755 $PRGNAM.sh $PKG/usr/bin/$PRGNAM
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
diff --git a/audio/transcribe/transcribe.info b/audio/transcribe/transcribe.info
index 3c2b723355..95ff024ad3 100644
--- a/audio/transcribe/transcribe.info
+++ b/audio/transcribe/transcribe.info
@@ -1,10 +1,10 @@
PRGNAM="transcribe"
-VERSION="8.10.0"
+VERSION="8.21.1"
HOMEPAGE="http://www.seventhstring.com/"
-DOWNLOAD="http://www.seventhstring.com/xscribe/xscsetup.tar.gz"
-MD5SUM="ce8a9bdbb88351b4be78f3972837a781"
-DOWNLOAD_x86_64="UNSUPPORTED"
-MD5SUM_x86_64=""
+DOWNLOAD="http://www.seventhstring.com/xscribe/downlinux/xscsetup.tar.gz"
+MD5SUM="ee7570b3c220c55400ffa5d7e4a9804b"
+DOWNLOAD_x86_64="http://www.seventhstring.com/xscribe/downlinux64/xsc64setup.tar.gz"
+MD5SUM_x86_64="d9aaa4d0655eb2b5086689af52cc7739"
REQUIRES=""
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"