summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2013-11-06 19:47:38 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-11-07 11:28:17 -0600
commitb310c821ee784a31cdbaaba248121b55129a4f42 (patch)
treef3eed055f20f9b8288fcab326d57b46f430e0b92
parentb79d0baa2e7ec7be724a0fbb2f4b1f76ebaa57e2 (diff)
downloadslackbuilds-b310c821ee784a31cdbaaba248121b55129a4f42.tar.gz
slackbuilds-b310c821ee784a31cdbaaba248121b55129a4f42.tar.xz
graphics/photoqt: Renamed from photo, updated for version 1.0.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--graphics/photo/README4
-rw-r--r--graphics/photo/photo.info10
-rw-r--r--graphics/photo/slack-desc19
-rw-r--r--graphics/photoqt/README8
-rw-r--r--graphics/photoqt/doinst.sh (renamed from graphics/photo/doinst.sh)0
-rw-r--r--graphics/photoqt/photoqt.SlackBuild (renamed from graphics/photo/photo.SlackBuild)18
-rw-r--r--graphics/photoqt/photoqt.info10
-rw-r--r--graphics/photoqt/slack-desc19
8 files changed, 48 insertions, 40 deletions
diff --git a/graphics/photo/README b/graphics/photo/README
deleted file mode 100644
index 8f564c5afc..0000000000
--- a/graphics/photo/README
+++ /dev/null
@@ -1,4 +0,0 @@
-photo (Qt image viewer)
-
-Photo is a fast, simple, good looking, yet powerful and highly
-configurable image viewer.
diff --git a/graphics/photo/photo.info b/graphics/photo/photo.info
deleted file mode 100644
index 75abd0ec01..0000000000
--- a/graphics/photo/photo.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="photo"
-VERSION="0.9.1"
-HOMEPAGE="http://photoqt.org"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/photo-0.9.1.tar.gz"
-MD5SUM="1317a9243b9e7aa89b2554bcb0af9093"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"
diff --git a/graphics/photo/slack-desc b/graphics/photo/slack-desc
deleted file mode 100644
index 255243c766..0000000000
--- a/graphics/photo/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-photo: photo (Qt image viewer)
-photo:
-photo: Photo is a fast, simple, good looking, yet powerful and highly
-photo: configurable image viewer.
-photo:
-photo: homepage: http://photoqt.org
-photo:
-photo:
-photo:
-photo:
-photo:
diff --git a/graphics/photoqt/README b/graphics/photoqt/README
new file mode 100644
index 0000000000..9467216b37
--- /dev/null
+++ b/graphics/photoqt/README
@@ -0,0 +1,8 @@
+Photoqt is a fast, simple, good looking, yet powerful and highly
+configurable image viewer.
+
+Support for external software is configured by default with the
+following switches:
+EXIV2=ON (needs exiv2, by default in Slackware)
+PHONON=OFF (needs phonon, by default in Slackware)
+GM=OFF (needs GraphicsMagick, optional dependency)
diff --git a/graphics/photo/doinst.sh b/graphics/photoqt/doinst.sh
index 9424ce43ff..9424ce43ff 100644
--- a/graphics/photo/doinst.sh
+++ b/graphics/photoqt/doinst.sh
diff --git a/graphics/photo/photo.SlackBuild b/graphics/photoqt/photoqt.SlackBuild
index a60991c089..f6a1d53945 100644
--- a/graphics/photo/photo.SlackBuild
+++ b/graphics/photoqt/photoqt.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
-# Slackware build script for photo
-# Copyright by Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy 2012
+# Slackware build script for photoqt
+# Copyright 2013 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,8 +21,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=photo
-VERSION=${VERSION:-0.9.1}
+PRGNAM=photoqt
+VERSION=${VERSION:-1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,6 +53,10 @@ else
LIBDIRSUFFIX=""
fi
+EXIV2=${EXIV2:-ON}
+GM=${GM:-OFF}
+PHONON=${PHONON:-OFF}
+
set -e
rm -rf $PKG
@@ -68,15 +72,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Explicitly link to phonon too
-sed -i "s|exiv2|exiv2 phonon|" CMakeLists.txt
-
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DEXIV2=$EXIV2 \
+ -DGM=$GM \
+ -DPHONON=$PHONON \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
diff --git a/graphics/photoqt/photoqt.info b/graphics/photoqt/photoqt.info
new file mode 100644
index 0000000000..1aa01bdec8
--- /dev/null
+++ b/graphics/photoqt/photoqt.info
@@ -0,0 +1,10 @@
+PRGNAM="photoqt"
+VERSION="1.0"
+HOMEPAGE="http://photoqt.org"
+DOWNLOAD="http://photoqt.org/pkgs/photoqt-1.0.tar.gz"
+MD5SUM="b54dc4de8c7561551f47e47738633002"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/graphics/photoqt/slack-desc b/graphics/photoqt/slack-desc
new file mode 100644
index 0000000000..4c7692533d
--- /dev/null
+++ b/graphics/photoqt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+photoqt: photoqt (Qt image viewer)
+photoqt:
+photoqt: Photoqt is a fast, simple, good looking, yet powerful and highly
+photoqt: configurable image viewer.
+photoqt:
+photoqt: homepage: http://photoqt.org
+photoqt:
+photoqt:
+photoqt:
+photoqt:
+photoqt: