summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Petar Petrov <ppetrov@paju.oulu.fi>2011-12-11 09:36:51 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-11 14:18:29 -0200
commitb87cd0a81e5d70569a04188efd24655994915317 (patch)
treebe49647f5697b50000628ab3460a1eb84226a9c3
parent8747c09c6e013b9f9c36379e44c00537be0c340b (diff)
downloadslackbuilds-b87cd0a81e5d70569a04188efd24655994915317.tar.gz
slackbuilds-b87cd0a81e5d70569a04188efd24655994915317.tar.xz
libraries/alglib: Clarify license
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/alglib/alglib.SlackBuild30
1 files changed, 22 insertions, 8 deletions
diff --git a/libraries/alglib/alglib.SlackBuild b/libraries/alglib/alglib.SlackBuild
index b20d528438..8a6a8d419c 100644
--- a/libraries/alglib/alglib.SlackBuild
+++ b/libraries/alglib/alglib.SlackBuild
@@ -1,17 +1,31 @@
#!/bin/sh
# Slackware build script for alglib
-# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
-# hereby submitted to the public domain
-# Based on the alglib PKGBUILD from Archlinux AUR:
+# Copyright 2011 Petar Petrov, ppetrov@paju.oulu.fi
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# With help from the alglib PKGBUILD from Archlinux AUR:
# http://aur.archlinux.org/packages/al/alglib/PKGBUILD
# PKGBUILD contributor is Carlo Casta. Thank you!
-# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
-# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
-# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
-
PRGNAM=alglib
VERSION=${VERSION:-2.6.0}
BUILD=${BUILD:-1}
@@ -98,4 +112,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz} \ No newline at end of file
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}