summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Petar Petrov <slackalaxy@gmail.com>2017-05-02 21:57:28 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-05-02 21:57:28 +0700
commitb8c2c78891dfd2ca46f93d7ce00cf2681d34d4bc (patch)
treeb445ea86018073a8e103b24b4cabe13d2bfbf1a0
parent4ee259a3bc486f4902426d87d918cbf4666a1971 (diff)
downloadslackbuilds-b8c2c78891dfd2ca46f93d7ce00cf2681d34d4bc.tar.gz
slackbuilds-b8c2c78891dfd2ca46f93d7ce00cf2681d34d4bc.tar.xz
academic/bpp-phyl: Added (Bio++ Phylogenetic Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--academic/bpp-phyl/README8
-rw-r--r--academic/bpp-phyl/bpp-phyl.SlackBuild98
-rw-r--r--academic/bpp-phyl/bpp-phyl.info10
-rw-r--r--academic/bpp-phyl/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/academic/bpp-phyl/README b/academic/bpp-phyl/README
new file mode 100644
index 0000000000..658bbc2751
--- /dev/null
+++ b/academic/bpp-phyl/README
@@ -0,0 +1,8 @@
+Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+analysis, phylogenetics, molecular evolution and population genetics.
+Bio++ is Object Oriented and is designed to be both easy to use and
+computer efficient. Bio++ intends to help programmers to write
+computer expensive programs, by providing them a set of re-usable
+tools.
+
+This contains the Bio++ Phylogenetic Library.
diff --git a/academic/bpp-phyl/bpp-phyl.SlackBuild b/academic/bpp-phyl/bpp-phyl.SlackBuild
new file mode 100644
index 0000000000..28bc2b5c52
--- /dev/null
+++ b/academic/bpp-phyl/bpp-phyl.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for bpp-phyl
+
+# Copyright 2017 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=bpp-phyl
+VERSION=${VERSION:-git_bf2e0d6}
+COMMIT=bf2e0d6528eacfaec2de740383c6b34311c9d9fa
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s|cmake-package-location lib/cmake|cmake-package-location lib${LIBDIRSUFFIX}/cmake|" CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.txt ChangeLog COPYING.txt INSTALL.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/bpp-phyl/bpp-phyl.info b/academic/bpp-phyl/bpp-phyl.info
new file mode 100644
index 0000000000..96ee3d8f9a
--- /dev/null
+++ b/academic/bpp-phyl/bpp-phyl.info
@@ -0,0 +1,10 @@
+PRGNAM="bpp-phyl"
+VERSION="git_bf2e0d6"
+HOMEPAGE="http://biopp.univ-montp2.fr/"
+DOWNLOAD="https://github.com/BioPP/bpp-phyl/archive/bf2e0d6/bpp-phyl-bf2e0d6528eacfaec2de740383c6b34311c9d9fa.tar.gz"
+MD5SUM="e0be5820c1462ed7c98b9bb55a0fd21c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="bpp-seq"
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"
diff --git a/academic/bpp-phyl/slack-desc b/academic/bpp-phyl/slack-desc
new file mode 100644
index 0000000000..591618ed14
--- /dev/null
+++ b/academic/bpp-phyl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bpp-phyl: bpp-phyl (Bio++ Phylogenetic Library)
+bpp-phyl:
+bpp-phyl: Contains the Bio++ Phylogenetic Library.
+bpp-phyl:
+bpp-phyl: Git: https://github.com/BioPP/bpp-phyl
+bpp-phyl:
+bpp-phyl:
+bpp-phyl:
+bpp-phyl:
+bpp-phyl:
+bpp-phyl: