summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author hollywoodb <hollywoodb@fastmail.fm>2010-05-11 14:05:50 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 14:05:50 +0200
commitbb53bb5f097ff03a22e133d0ca1967d225ca8732 (patch)
treee2c55d9cb27afb5184139c1840a1e2ce8164d727
parent186450ac4d82e4d499adbca7ed3f716afbb522d0 (diff)
downloadslackbuilds-bb53bb5f097ff03a22e133d0ca1967d225ca8732.tar.gz
slackbuilds-bb53bb5f097ff03a22e133d0ca1967d225ca8732.tar.xz
development/PyOpenGL: Initial import
-rw-r--r--development/PyOpenGL/PyOpenGL.SlackBuild52
-rw-r--r--development/PyOpenGL/PyOpenGL.info8
-rw-r--r--development/PyOpenGL/README13
-rw-r--r--development/PyOpenGL/slack-desc11
4 files changed, 84 insertions, 0 deletions
diff --git a/development/PyOpenGL/PyOpenGL.SlackBuild b/development/PyOpenGL/PyOpenGL.SlackBuild
new file mode 100644
index 0000000000..88f4c88fa5
--- /dev/null
+++ b/development/PyOpenGL/PyOpenGL.SlackBuild
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+
+## Feel free to use, modify, redistribute this script.
+## If you make changes please modify the "Written by"
+## so that I don't recieve emails about a script I
+## did not write. Thanks.
+
+# Modified slightly by the SlackBuilds.org project
+
+if [ "$(id -u)" != "0" ]; then
+ echo "This script must be run as root!"
+ exit
+fi
+
+NAME=PyOpenGL
+VERSION=3.0.0a5
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$NAME}
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $NAME-$VERSION
+tar -zxvf $CWD/$NAME-$VERSION.tar.gz || exit 1
+cd $NAME-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py bdist || exit 1
+tar -C $PKG -zxvf $TMP/$NAME-$VERSION/dist/$NAME-$VERSION.linux-i686.tar.gz
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+install -m 0644 PKG-INFO documentation/{development,using}.html \
+ $PKG/usr/doc/$NAME-$VERSION
+
+cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/PyOpenGL/PyOpenGL.info b/development/PyOpenGL/PyOpenGL.info
new file mode 100644
index 0000000000..2fdb74ffc6
--- /dev/null
+++ b/development/PyOpenGL/PyOpenGL.info
@@ -0,0 +1,8 @@
+PRGNAM="PyOpenGL"
+VERSION="3.0.0a5"
+HOMEPAGE="http://pyopengl.sourceforge.net/"
+DOWNLOAD="http://dl.sourceforge.net/pyopengl/PyOpenGL-3.0.0a5.tar.gz"
+MD5SUM="943c4d7d3d1d97cc7592e61d28918fd2"
+MAINTAINER="hollywoodb"
+EMAIL="hollywoodb@fastmail.fm"
+APPROVED="robw810"
diff --git a/development/PyOpenGL/README b/development/PyOpenGL/README
new file mode 100644
index 0000000000..fefb631013
--- /dev/null
+++ b/development/PyOpenGL/README
@@ -0,0 +1,13 @@
+PyOpenGL is the cross platform Python binding to OpenGL and related APIs.
+The binding is created using the SWIG wrapper generator, and is provided
+under an extremely liberal BSD-style Open-Source license.
+
+PyOpenGL includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3, WGL 4,
+and Togl (Tk OpenGL widget) 1.6. It also includes support for dozens of
+extensions (where supported in the underlying implementation).
+
+PyOpenGL is interoperable with a large number of external GUI libraries
+for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
+
+Requirements: >=pysetuptool-0.6 (setuptools) -- build requirement only
+
diff --git a/development/PyOpenGL/slack-desc b/development/PyOpenGL/slack-desc
new file mode 100644
index 0000000000..713b1c4ebf
--- /dev/null
+++ b/development/PyOpenGL/slack-desc
@@ -0,0 +1,11 @@
+PyOpenGL: PyOpenGL (cross-platform Python<->OpenGL bindings)
+PyOpenGL:
+PyOpenGL: PyOpenGL is the cross platform Python binding to OpenGL and related
+PyOpenGL: APIs. The binding is created using the SWIG wrapper generator, and is
+PyOpenGL: provided under an extremely liberal BSD-style Open-Source license.
+PyOpenGL: PyOpenGL includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3,
+PyOpenGL: WGL 4, and Togl (Tk OpenGL widget) 1.6. It also includes support for
+PyOpenGL: dozens of extensions (where supported in the underlying implementation).
+PyOpenGL:
+PyOpenGL:
+PyOpenGL: