summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2013-11-13 19:40:52 +0700
committer Robby Workman <rworkman@slackbuilds.org>2013-11-13 11:19:03 -0600
commitd53c6a4a61ae498b11c4985911adde81287a4f9f (patch)
treec2ec13eae74b3e4acd129c06a25666d57c87e0b9
parentafc907a2413be78254f3589dc77ed353d3e2dad7 (diff)
downloadslackbuilds-d53c6a4a61ae498b11c4985911adde81287a4f9f.tar.gz
slackbuilds-d53c6a4a61ae498b11c4985911adde81287a4f9f.tar.xz
python/pyxdg: Updated for version 0.25
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pyxdg/pyxdg.SlackBuild14
-rw-r--r--python/pyxdg/pyxdg.info6
2 files changed, 9 insertions, 11 deletions
diff --git a/python/pyxdg/pyxdg.SlackBuild b/python/pyxdg/pyxdg.SlackBuild
index 07d51b256b..a1e16ec70d 100644
--- a/python/pyxdg/pyxdg.SlackBuild
+++ b/python/pyxdg/pyxdg.SlackBuild
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyxdg
-VERSION=${VERSION:-0.18}
+VERSION=${VERSION:-0.25}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -65,11 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root $PKG
diff --git a/python/pyxdg/pyxdg.info b/python/pyxdg/pyxdg.info
index 23ab5bad34..a1797df98f 100644
--- a/python/pyxdg/pyxdg.info
+++ b/python/pyxdg/pyxdg.info
@@ -1,8 +1,8 @@
PRGNAM="pyxdg"
-VERSION="0.18"
+VERSION="0.25"
HOMEPAGE="http://freedesktop.org/wiki/Software/pyxdg"
-DOWNLOAD="http://www.freedesktop.org/~lanius/pyxdg-0.18.tar.gz"
-MD5SUM="076b57722e91dab8ab83028c6ef9dcea"
+DOWNLOAD="http://people.freedesktop.org/~takluyver/pyxdg-0.25.tar.gz"
+MD5SUM="bedcdb3a0ed85986d40044c87f23477c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""