summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Christoph Willing <chris.willing@linux.com>2019-08-10 06:45:25 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-08-10 06:45:25 +0700
commitd8d06f26f863f26356b5d1148343b48a20fe7d04 (patch)
tree52515ea8bcf111bacdd72ddc7398cd870be51a5e
parent44809a826c4a3e2a784183ad12648b85c22a3c78 (diff)
downloadslackbuilds-d8d06f26f863f26356b5d1148343b48a20fe7d04.tar.gz
slackbuilds-d8d06f26f863f26356b5d1148343b48a20fe7d04.tar.xz
python/pybind11: Added (Python bindings for C++11).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pybind11/README7
-rw-r--r--python/pybind11/pybind11.SlackBuild93
-rw-r--r--python/pybind11/pybind11.info10
-rw-r--r--python/pybind11/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/python/pybind11/README b/python/pybind11/README
new file mode 100644
index 0000000000..3805c59fc3
--- /dev/null
+++ b/python/pybind11/README
@@ -0,0 +1,7 @@
+pybind11 is a lightweight header-only library that exposes C++ types in Python
+and vice versa, mainly to create Python bindings of existing C++ code.
+Its goals and syntax are similar to the excellent Boost.Python library by
+David Abrahams: to minimize boilerplate code in traditional extension modules
+by inferring type information using compile-time introspection.
+
+This SlackBuild supports both python2 and python3.
diff --git a/python/pybind11/pybind11.SlackBuild b/python/pybind11/pybind11.SlackBuild
new file mode 100644
index 0000000000..a37e197212
--- /dev/null
+++ b/python/pybind11/pybind11.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for pybind11
+
+# Copyright 2019 Christoph Willing, Brisbane, Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=pybind11
+VERSION=${VERSION:-2.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CONTRIBUTING.md LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pybind11/pybind11.info b/python/pybind11/pybind11.info
new file mode 100644
index 0000000000..e083f488ca
--- /dev/null
+++ b/python/pybind11/pybind11.info
@@ -0,0 +1,10 @@
+PRGNAM="pybind11"
+VERSION="2.3.0"
+HOMEPAGE="https://github.com/pybind/pybind11"
+DOWNLOAD="https://github.com/pybind/pybind11/archive/v2.3.0/pybind11-2.3.0.tar.gz"
+MD5SUM="e2120c5b0e3c20a93f2dfcdc55026ba8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@linux.com"
diff --git a/python/pybind11/slack-desc b/python/pybind11/slack-desc
new file mode 100644
index 0000000000..5c6a6d338d
--- /dev/null
+++ b/python/pybind11/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pybind11: pybind11 (Python bindings for C++11)
+pybind11:
+pybind11: pybind11 is a lightweight header-only library that exposes C++ types
+pybind11: in Python and vice versa, mainly to create Python bindings of
+pybind11: existing C++ code.
+pybind11:
+pybind11:
+pybind11:
+pybind11:
+pybind11:
+pybind11: