summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author João Felipe Santos <joao.eel@gmail.com>2010-05-29 02:02:16 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-29 02:02:16 -0500
commite32ff21dde3f9af7fb50087b3768cb02c526020f (patch)
tree43d54262f7353d30ac54d4bf05a624173c5c76e6
parent3d26ebd3ffb78b70e5875cb18092cb0835c94b2a (diff)
downloadslackbuilds-e32ff21dde3f9af7fb50087b3768cb02c526020f.tar.gz
slackbuilds-e32ff21dde3f9af7fb50087b3768cb02c526020f.tar.xz
libraries/matplotlib: Re-added and updated to 0.99.1.2.
-rw-r--r--libraries/matplotlib/README7
-rw-r--r--libraries/matplotlib/libpng-1.4.patch12
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild63
-rw-r--r--libraries/matplotlib/matplotlib.info10
-rw-r--r--libraries/matplotlib/slack-desc19
5 files changed, 111 insertions, 0 deletions
diff --git a/libraries/matplotlib/README b/libraries/matplotlib/README
new file mode 100644
index 0000000000..71f7c7f974
--- /dev/null
+++ b/libraries/matplotlib/README
@@ -0,0 +1,7 @@
+Matplotlib strives to produce publication quality 2D graphics for
+interactive graphing, scientific publishing, user interface
+development and web application servers targeting multiple user
+interfaces and hardcopy output formats. There is a 'pylab' mode which
+emulates matlab graphics
+
+This requires numpy.
diff --git a/libraries/matplotlib/libpng-1.4.patch b/libraries/matplotlib/libpng-1.4.patch
new file mode 100644
index 0000000000..8fe04de8af
--- /dev/null
+++ b/libraries/matplotlib/libpng-1.4.patch
@@ -0,0 +1,12 @@
+diff -Naur matplotlib-0.99.1.1-orig/src/_png.cpp matplotlib-0.99.1.1/src/_png.cpp
+--- matplotlib-0.99.1.1-orig/src/_png.cpp 2010-01-25 01:42:32.000000000 -0500
++++ matplotlib-0.99.1.1/src/_png.cpp 2010-01-25 01:43:17.000000000 -0500
+@@ -290,7 +290,7 @@
+
+ //free the png memory
+ png_read_end(png_ptr, info_ptr);
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ fclose(fp);
+ for (row = 0; row < height; row++)
+ delete [] row_pointers[row];
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
new file mode 100644
index 0000000000..36fe64f31f
--- /dev/null
+++ b/libraries/matplotlib/matplotlib.SlackBuild
@@ -0,0 +1,63 @@
+#!/bin/sh
+
+# Slackware build script for matplotlib
+
+# Written by Aleksandar Samardzic <asamardzic@gmail.com>
+# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
+# Patch for libpng borrowed from Arch Linux
+
+PRGNAM=matplotlib
+VERSION=${VERSION:-0.99.1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+TARBALL_VERSION=0.99.1.1 # Tarball dir has wrong version number
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$TARBALL_VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$TARBALL_VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch -p1 < $CWD/libpng-1.4.patch
+
+python setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m 0644 \
+ CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS README.txt TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/matplotlib/matplotlib.info b/libraries/matplotlib/matplotlib.info
new file mode 100644
index 0000000000..52c6dbec9c
--- /dev/null
+++ b/libraries/matplotlib/matplotlib.info
@@ -0,0 +1,10 @@
+PRGNAM="matplotlib"
+VERSION="0.99.1.2"
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/matplotlib/matplotlib-0.99.1.2.tar.gz"
+MD5SUM="952e2c992e4a762b8538171f51c9140a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="João Felipe Santos"
+EMAIL="joao.eel@gmail.com"
+APPROVED="rworkman"
diff --git a/libraries/matplotlib/slack-desc b/libraries/matplotlib/slack-desc
new file mode 100644
index 0000000000..c7a91e2ea1
--- /dev/null
+++ b/libraries/matplotlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------|
+matplotlib: matplotlib (a Python 2D plotting library)
+matplotlib:
+matplotlib: Matplotlib is a plotting library for Python which uses
+matplotlib: syntax similar to MATLAB. Matplotlib produces publication
+matplotlib: quality figures in a variety of hardcopy formats and
+matplotlib: interactive environments across platforms.
+matplotlib:
+matplotlib: Homepage: http://matplotlib.sourceforge.net/
+matplotlib:
+matplotlib:
+matplotlib: