summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 18:29:20 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:58 +0700
commite4f2227dc4d8f6ead9bc9df1a72f5044a8e09317 (patch)
tree9360ad599f9dfe22be55a215bbbca72002fc902f
parent074260c359d57e8630e9395b0bdaaa127c629035 (diff)
downloadslackbuilds-e4f2227dc4d8f6ead9bc9df1a72f5044a8e09317.tar.gz
slackbuilds-e4f2227dc4d8f6ead9bc9df1a72f5044a8e09317.tar.xz
python/testtools: Fix REQUIRES for python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/testtools/README13
-rw-r--r--python/testtools/testtools.SlackBuild2
-rw-r--r--python/testtools/testtools.info2
3 files changed, 9 insertions, 8 deletions
diff --git a/python/testtools/README b/python/testtools/README
index 9411dcbbb6..071bf96c3a 100644
--- a/python/testtools/README
+++ b/python/testtools/README
@@ -1,9 +1,10 @@
Extensions to the Python standard library unit testing framework
-testtools is a set of extensions to the Python standard library’s unit
-testing framework. These extensions have been derived from many years of
-experience with unit testing in Python and come from many different sources.
+testtools is a set of extensions to the Python standard library’s unit
+testing framework. These extensions have been derived from many years of
+experience with unit testing in Python and come from many different
+sources.
-Note:
-There is a cyclic dependency between fixtures package and testtools package.
-Since these are python libraries, one has to just install both of them.
+Note: There is a cyclic dependency between fixtures package and
+testtools package. Since these are python libraries, one has to just
+install both of them.
diff --git a/python/testtools/testtools.SlackBuild b/python/testtools/testtools.SlackBuild
index 54e4b13877..f7f29a4c31 100644
--- a/python/testtools/testtools.SlackBuild
+++ b/python/testtools/testtools.SlackBuild
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/testtools/testtools.info b/python/testtools/testtools.info
index cb80c32ebd..988b734042 100644
--- a/python/testtools/testtools.info
+++ b/python/testtools/testtools.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://pypi.python.org/packages/0d/72/3212c1723d49f5b58fca736dabdd2e7
MD5SUM="adef817b07ba24fd6d807fd41a4f1ef4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pbr extras python-mimeparse traceback2"
+REQUIRES="pbr extras python2-mimeparse traceback2"
MAINTAINER="Nikos Giotis"
EMAIL="nikos.giotis@gmail.com"