summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-05-09 00:14:01 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-05-13 06:59:16 +0700
commitf8df5024a62324161f5e8d6fc5cb6074dee392ef (patch)
tree7bc1efbb3e6f896ded25967bdef8e7279a90eb54
parent2417c71e207512dff2035f1c3e2fb81bea3856ac (diff)
downloadslackbuilds-f8df5024a62324161f5e8d6fc5cb6074dee392ef.tar.gz
slackbuilds-f8df5024a62324161f5e8d6fc5cb6074dee392ef.tar.xz
development/Cython-Kivy: Removed (per maintainer's request).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/Cython-Kivy/Cython-Kivy.SlackBuild91
-rw-r--r--development/Cython-Kivy/Cython-Kivy.info10
-rw-r--r--development/Cython-Kivy/README8
-rw-r--r--development/Cython-Kivy/slack-desc19
4 files changed, 0 insertions, 128 deletions
diff --git a/development/Cython-Kivy/Cython-Kivy.SlackBuild b/development/Cython-Kivy/Cython-Kivy.SlackBuild
deleted file mode 100644
index 9d4a29ac00..0000000000
--- a/development/Cython-Kivy/Cython-Kivy.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Cython-Kivy
-
-# Copyright 2015-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM="Cython-Kivy"
-SRCNAM=$(echo $PRGNAM | cut -c1-6)
-VERSION=${VERSION:-0.21.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-python setup.py install --root=$PKG --prefix=/usr
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt Doc $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Fix a broken link in one of the html files
-sed -i 's|~greg/python/Cython|greg.ewing/python/Pyrex|' \
- $PKG/usr/doc/$PRGNAM-$VERSION/Doc/index.html
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/Cython-Kivy/Cython-Kivy.info b/development/Cython-Kivy/Cython-Kivy.info
deleted file mode 100644
index 44896079c6..0000000000
--- a/development/Cython-Kivy/Cython-Kivy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Cython-Kivy"
-VERSION="0.21.2"
-HOMEPAGE="http://www.cython.org/"
-DOWNLOAD="https://pypi.python.org/packages/69/18/2b6455b765f06cb4ec392774871d799a3cdc4967869e66f199954ef42ba2/Cython-0.21.2.tar.gz"
-MD5SUM="d21adb870c75680dc857cd05d41046a4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/development/Cython-Kivy/README b/development/Cython-Kivy/README
deleted file mode 100644
index 6b3aea20b8..0000000000
--- a/development/Cython-Kivy/README
+++ /dev/null
@@ -1,8 +0,0 @@
-Cython version to support Kivy
-
-Cython is a language that makes writing C extensions for the Python
-language as easy as Python itself. Cython is based on the well-known
-Pyrex, but supports more cutting edge functionality and optimizations.
-
-NOTE: This package conflicts with Slackware's Cython and thus is
-intended to replace it. Both should not be installed at the same time.
diff --git a/development/Cython-Kivy/slack-desc b/development/Cython-Kivy/slack-desc
deleted file mode 100644
index 7a679f3909..0000000000
--- a/development/Cython-Kivy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Cython-Kivy: Cython-Kivy (C bindings for Python)
-Cython-Kivy:
-Cython-Kivy: Cython is a language that makes writing C extensions for the Python
-Cython-Kivy: language as easy as Python itself. Cython is based on the well-known
-Cython-Kivy: Pyrex, but supports more cutting edge functionality and
-Cython-Kivy: optimizations.
-Cython-Kivy:
-Cython-Kivy: Homepage: http://www.cython.org/
-Cython-Kivy:
-Cython-Kivy:
-Cython-Kivy: