summaryrefslogtreecommitdiffstats
path: root/academic/Kst
diff options
context:
space:
mode:
author Fellype do Nascimento <fellype@gmail.com>2014-12-12 07:46:29 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-12-12 14:19:06 +0700
commit04b677c3427a09ed9c579c87fccd46f5aa76bebe (patch)
tree7677a91e64cb4c676df270d8d18c568d3c5cd7f0 /academic/Kst
parent2df3e4fe8fb8a35e4da7f445180060310db3052c (diff)
downloadslackbuilds-04b677c3427a09ed9c579c87fccd46f5aa76bebe.tar.gz
slackbuilds-04b677c3427a09ed9c579c87fccd46f5aa76bebe.tar.xz
academic/Kst: Added (KDE4 Plotting Tool).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/Kst')
-rw-r--r--academic/Kst/Kst.SlackBuild83
-rw-r--r--academic/Kst/Kst.info10
-rw-r--r--academic/Kst/README15
-rw-r--r--academic/Kst/doinst.sh13
-rw-r--r--academic/Kst/slack-desc19
5 files changed, 140 insertions, 0 deletions
diff --git a/academic/Kst/Kst.SlackBuild b/academic/Kst/Kst.SlackBuild
new file mode 100644
index 0000000000..0ab614f03d
--- /dev/null
+++ b/academic/Kst/Kst.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/sh
+# Slackware build script for Kst
+# Based on Slackware 14.1 SlackBuild and AUR PKGBUILD for Kst
+# Written by Fellype do Nascimento <fellype(at)gmail.com>
+# last modification of this build script: 2014/12/10
+
+PRGNAM=Kst
+VERSION=${VERSION:-2.0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i686 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"; SLKLDFLAGS=""; LIBDIRSUFFIX=""; CHOST=i486
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"; SLKLDFLAGS=""; LIBDIRSUFFIX=""; CHOST=i486
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"; SLKLDFLAGS="-L/usr/lib64"; LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -zxvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s/find_package\(PythonLibs REQUIRED\)/SET \(PythonLibs \"\/usr\/lib${LIBDIRSUFFIX}\/libpython2.7.so\"\)/" \
+./cmake/pyKst/CMakeLists.txt
+sed -i "s/\${NUMPY_VERSION_PATCH}/0/" ./cmake/modules/FindNumPy.cmake
+cp -r ./cmake/pyKst/* ./pyKst/
+cmake ./ \
+-Dkst_release=1 \
+-Dkst_version_string=1 \
+-Dkst_svnversion=0 \
+-Dkst_python=1 \
+-DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
+-Dkst_python_prefix=/usr/lib$LIBDIRSUFFIX/python2.7 \
+-Dkst_install_prefix=/usr/ \
+-Dkst_install_libdir=/usr/lib$LIBDIRSUFFIX
+make install DESTDIR=$PKG
+
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs -r strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs -r strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs -r strip --strip-unneeded 2> /dev/null || true
+)
+
+mv $PKG/usr/share/man $PKG/usr/
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING* ChangeLog* INSTALL README* RELEASE.NOTES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/Kst/Kst.info b/academic/Kst/Kst.info
new file mode 100644
index 0000000000..8912bc7380
--- /dev/null
+++ b/academic/Kst/Kst.info
@@ -0,0 +1,10 @@
+PRGNAM="Kst"
+VERSION="2.0.8"
+HOMEPAGE="https://kst-plot.kde.org/"
+DOWNLOAD="http://netcologne.dl.sourceforge.net/project/kst/Kst%202.0.8/Kst-2.0.8.tar.gz"
+MD5SUM="6f52c16edb63e8980520bfdaebed3eae"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="scipy"
+MAINTAINER="Fellype do Nascimento"
+EMAIL="fellype(at)gmail.com"
diff --git a/academic/Kst/README b/academic/Kst/README
new file mode 100644
index 0000000000..19f88a1c90
--- /dev/null
+++ b/academic/Kst/README
@@ -0,0 +1,15 @@
+Kst (KDE4 Plotting Tool)
+
+Kst is the fastest real-time large-dataset viewing and plotting tool available and has built-in data analysis functionality.
+Kst is very user-friendly (both the community and the program itself!).
+Kst contains many powerful built-in features and is expandable with plugins and extensions.
+Kst is licensed under the GPL, and is as such freely available for anyone.
+Note that KDE libraries are an optional dependency (i.e. you can run Kst without KDE,
+but you get additional features when running on a platform with KDE).
+
+Optional dependencies are:
+- gsl (a lot of very useful data analysis plugins are based) - RECOMMENDED
+- netcdf (which provides support for files in the netCDF format)
+- muParser (which is used in the general non-linear fitting plugin)
+- GetData (which provides support for files in the Dirfile format)
+- matio (which is used to read Matlab binary files)
diff --git a/academic/Kst/doinst.sh b/academic/Kst/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/academic/Kst/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/academic/Kst/slack-desc b/academic/Kst/slack-desc
new file mode 100644
index 0000000000..49dc349bbe
--- /dev/null
+++ b/academic/Kst/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler----------------------------------------------------|
+Kst: Kst (KDE4 Plotting Tool)
+Kst:
+Kst: Kst is the fastest real-time large-dataset viewing and plotting
+Kst: tool available (You may be interested in some benchmarks)
+Kst: and has built-in data analysis functionality.
+Kst:
+Kst:
+Kst:
+Kst:
+Kst:
+Kst: