summaryrefslogtreecommitdiffstats
path: root/academic/kiwisolver
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-01-29 12:31:29 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-30 15:26:57 +0700
commitc6d53e8ff5f1f8eb19f915059d81c3e00d6a45ae (patch)
tree1668860f0ef71cb1d70796fadf66d9cafae8925b /academic/kiwisolver
parentb51a6404b64c86ab6e03659d123724c423e72dc4 (diff)
downloadslackbuilds-c6d53e8ff5f1f8eb19f915059d81c3e00d6a45ae.tar.gz
slackbuilds-c6d53e8ff5f1f8eb19f915059d81c3e00d6a45ae.tar.xz
academic/kiwisolver: Remove kiwisolver
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/kiwisolver')
-rw-r--r--academic/kiwisolver/README7
-rw-r--r--academic/kiwisolver/kiwisolver.SlackBuild82
-rw-r--r--academic/kiwisolver/kiwisolver.info10
-rw-r--r--academic/kiwisolver/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/academic/kiwisolver/README b/academic/kiwisolver/README
deleted file mode 100644
index 96743769c0..0000000000
--- a/academic/kiwisolver/README
+++ /dev/null
@@ -1,7 +0,0 @@
-This is an efficient C++ implementation of the Cassowary constraint
-solving algorithm. Kiwi(solver) is an implementation of the algorithm
-based on the seminal Cassowary paper. It is not a refactoring of the
-original C++ solver. Kiwi(solver) has been designed from the ground
-up to be lightweight and fast. It ranges from 10x to 500x faster than
-the original Cassowary solver with typical use cases gaining a 40x
-improvement. Memory savings are consistently > 5x.
diff --git a/academic/kiwisolver/kiwisolver.SlackBuild b/academic/kiwisolver/kiwisolver.SlackBuild
deleted file mode 100644
index a8642e3de6..0000000000
--- a/academic/kiwisolver/kiwisolver.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for kiwisolver
-
-# Copyright 2018 Serban Udrea <s.udrea@gsi.de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification,
-# is permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
-# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
-# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=kiwisolver
-VERSION=${VERSION:-1.0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING.txt PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/kiwisolver/kiwisolver.info b/academic/kiwisolver/kiwisolver.info
deleted file mode 100644
index 41a6cb3771..0000000000
--- a/academic/kiwisolver/kiwisolver.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="kiwisolver"
-VERSION="1.0.1"
-HOMEPAGE="https://pypi.org/project/kiwisolver"
-DOWNLOAD="https://files.pythonhosted.org/packages/31/60/494fcce70d60a598c32ee00e71542e52e27c978e5f8219fae0d4ac6e2864/kiwisolver-1.0.1.tar.gz"
-MD5SUM="e2a1718b837e2cd001f7c06934616fcd"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Serban Udrea"
-EMAIL="S.Udrea@gsi.de"
diff --git a/academic/kiwisolver/slack-desc b/academic/kiwisolver/slack-desc
deleted file mode 100644
index ccdb0a1776..0000000000
--- a/academic/kiwisolver/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-kiwisolver: kiwisolver (an implementation of the Cassowary algorithm)
-kiwisolver:
-kiwisolver: This is an efficient C++ implementation of the Cassowary constraint
-kiwisolver: solving algorithm. Kiwi(solver) is an implementation of the algorithm
-kiwisolver: based on the seminal Cassowary paper. It is not a refactoring of the
-kiwisolver: original C++ solver. Kiwi(solver) has been designed from the ground
-kiwisolver: up to be lightweight and fast.
-kiwisolver:
-kiwisolver: Homepage: https://pypi.org/project/kiwisolver
-kiwisolver:
-kiwisolver: