summaryrefslogtreecommitdiffstats
path: root/academic/octave/patches
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2014-01-12 01:41:59 -0600
committer Robby Workman <rworkman@slackbuilds.org>2014-01-31 00:54:26 -0600
commitc0538d8c0870848d589fb99f12e29dc50be2937e (patch)
tree75963f4225a58cebf4a8c3c51833197a6d1e0c14 /academic/octave/patches
parent773aa2de139f2f1ee8b12f2e5836a39d63e5392e (diff)
downloadslackbuilds-c0538d8c0870848d589fb99f12e29dc50be2937e.tar.gz
slackbuilds-c0538d8c0870848d589fb99f12e29dc50be2937e.tar.xz
academic/octave: Updated for version 3.8.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic/octave/patches')
-rw-r--r--academic/octave/patches/compressed-info.diff13
-rw-r--r--academic/octave/patches/umfpack-cppflags.diff31
2 files changed, 44 insertions, 0 deletions
diff --git a/academic/octave/patches/compressed-info.diff b/academic/octave/patches/compressed-info.diff
new file mode 100644
index 0000000000..48178d773f
--- /dev/null
+++ b/academic/octave/patches/compressed-info.diff
@@ -0,0 +1,13 @@
+diff --git a/scripts/help/doc.m b/scripts/help/doc.m
+--- a/scripts/help/doc.m
++++ b/scripts/help/doc.m
+@@ -80,7 +80,8 @@
+ if (err < 0)
+ info_file_name = info_file ();
+
+- if (! exist (info_file_name, "file"))
++ if (! exist (info_file_name, "file")
++ && ! exist ([info_file_name ".gz"], "file"))
+ __gripe_missing_component__ ("doc", "info-file");
+ endif
+ endif
diff --git a/academic/octave/patches/umfpack-cppflags.diff b/academic/octave/patches/umfpack-cppflags.diff
new file mode 100644
index 0000000000..d56ba1f8eb
--- /dev/null
+++ b/academic/octave/patches/umfpack-cppflags.diff
@@ -0,0 +1,31 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1512,7 +1512,9 @@
+
+ if test -n "$UMFPACK_LIBS"; then
+ ## SuiteSparse >= 4.0 needs additional link library for SuiteSparse_time()
++ save_CPPFLAGS="$CPPFLAGS"
+ save_LIBS="$LIBS";
++ CPPFLAGS="$UMFPACK_CPPFLAGS $AMD_CPPFLAGS $CPPFLAGS"
+ LIBS="$UMFPACK_LIBS $AMD_LDFLAGS $AMD_LIBS $BLAS_LIBS $FLIBS $LIBS"
+ xtra_libs=
+ OCTAVE_UMFPACK_NEED_SUITESPARSE_TIME
+@@ -1535,13 +1537,17 @@
+ esac
+ fi
+ LIBS="$save_LIBS"
++ CPPFLAGS="$save_CPPFLAGS"
+
+ ## Check for UMFPACK separately split complex matrix and RHS.
+ if test -n "$UMFPACK_LIBS"; then
++ save_CPPFLAGS="$CPPFLAGS"
+ save_LIBS="$LIBS";
++ CPPFLAGS="$UMFPACK_CPPFLAGS $AMD_CPPFLAGS $CPPFLAGS"
+ LIBS="$UMFPACK_LIBS $CHOLMOD_LDFLAGS $CHOLMOD_LIBS $AMD_LDFLAGS $AMD_LIBS $COLAMD_LDFLAGS $COLAMD_LIBS $LAPACK_LIBS $BLAS_LIBS $FLIBS $LIBS $xtra_libs"
+ OCTAVE_UMFPACK_SEPARATE_SPLIT
+ LIBS="$save_LIBS"
++ CPPFLAGS="$save_CPPFLAGS"
+ fi
+ fi
+