summaryrefslogtreecommitdiffstats
path: root/academic/octave
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2012-09-21 21:38:54 -0500
committer Robby Workman <rworkman@slackbuilds.org>2012-09-22 11:40:56 -0500
commitd5057e019c9717927281780d12e242d70990b39e (patch)
tree2ab687b56a2bbe0d405c46a5518924c969497d1e /academic/octave
parenta40a7a637b6423732d80f62221261d802f448c52 (diff)
downloadslackbuilds-d5057e019c9717927281780d12e242d70990b39e.tar.gz
slackbuilds-d5057e019c9717927281780d12e242d70990b39e.tar.xz
academic/octave: Revert deletion of configure.ac fixes
These are still needed to find SuiteSparse dependencies. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic/octave')
-rw-r--r--academic/octave/octave.SlackBuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/academic/octave/octave.SlackBuild b/academic/octave/octave.SlackBuild
index f0fb5d5440..6190b5d2d6 100644
--- a/academic/octave/octave.SlackBuild
+++ b/academic/octave/octave.SlackBuild
@@ -55,6 +55,20 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-st .
+# Several configure checks look for headers in the 'amd' directory
+# instead of 'cxsparse', 'camd', 'colamd', and 'ccolamd' directories
+# as liboctave/oct-sparse.h expects. Fix the typos and reconfigure.
+# Note that camd.h doesn't appear to be included anywhere, but is used
+# to determine if the CAMD library is present.
+sed -i -e 's| amd/cs\.h| cxsparse/cs.h|' \
+ -e 's| amd/camd\.h| camd/camd.h|' \
+ -e 's| amd/colamd\.h| colamd/colamd.h|' \
+ -e 's| amd/ccolamd\.h| ccolamd/ccolamd.h|' configure.ac
+autoreconf -vif
+# If you have amd.h in some non-default location (e.g. /usr/include/amd/amd.h)
+# now the check for umfpack.h will fail because umfpack.h includes "amd.h"
+# instead of "amd/amd.h". The --with-amd-includedir option below fixes this.
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
FFLAGS="$SLKCFLAGS" \
@@ -73,8 +87,8 @@ FFLAGS="$SLKCFLAGS" \
--with-amd-includedir=/usr/include/amd \
--build=$ARCH-slackware-linux
-LANG=C make
-make DESTDIR=$PKG install
+make
+make install-strip DESTDIR=$PKG
find $PKG/usr/man -type f -exec gzip -9 {} \;