summaryrefslogtreecommitdiffstats
path: root/academic/scipy
diff options
context:
space:
mode:
author Eugene Suter <easuter@gmail.com>2010-05-12 23:27:41 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 23:27:41 +0200
commit98f676a3ddaaeaa03558086338929218c3aabcdd (patch)
tree578176ce32f08170451d066f56aac89e3e0dde58 /academic/scipy
parent62ef8dd6f6ba4b91bf067b20aa347351eb990635 (diff)
downloadslackbuilds-98f676a3ddaaeaa03558086338929218c3aabcdd.tar.gz
slackbuilds-98f676a3ddaaeaa03558086338929218c3aabcdd.tar.xz
academic/scipy: Added to 12.2 repository
Diffstat (limited to 'academic/scipy')
-rw-r--r--academic/scipy/README10
-rw-r--r--academic/scipy/scipy.SlackBuild52
-rw-r--r--academic/scipy/scipy.info8
-rw-r--r--academic/scipy/slack-desc19
4 files changed, 89 insertions, 0 deletions
diff --git a/academic/scipy/README b/academic/scipy/README
new file mode 100644
index 0000000000..4c2d9604f2
--- /dev/null
+++ b/academic/scipy/README
@@ -0,0 +1,10 @@
+SciPy (pronounced "Sigh Pie") is open-source software for mathematics,
+science, and engineering.
+The SciPy library is built to work with NumPy arrays, and provides many
+user-friendly and efficient numerical routines such as routines for numerical
+integration and optimization. Together, they run on all popular operating
+systems, are quick to install, and are free of charge. NumPy and SciPy are
+easy to use, but powerful enough to be depended upon by some of the world's
+leading scientists and engineers.
+
+This package requires NumPy, Matplotlib, iPython, BLAS, LAPACK, and FFTW.
diff --git a/academic/scipy/scipy.SlackBuild b/academic/scipy/scipy.SlackBuild
new file mode 100644
index 0000000000..daaf0fb008
--- /dev/null
+++ b/academic/scipy/scipy.SlackBuild
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+# Build script for the Python SciPy package
+
+# Written by Eugene Suter <easuter@gmail.com>
+
+PRGNAM=scipy
+VERSION=${VERSION:-0.7.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt README.txt THANKS.txt TOCHANGE.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/academic/scipy/scipy.info b/academic/scipy/scipy.info
new file mode 100644
index 0000000000..7bb13033bd
--- /dev/null
+++ b/academic/scipy/scipy.info
@@ -0,0 +1,8 @@
+PRGNAM="scipy"
+VERSION="0.7.0"
+HOMEPAGE="www.scipy.org"
+DOWNLOAD="http://downloads.sourceforge.net/scipy/scipy-0.7.0.tar.gz"
+MD5SUM="80078ed5f47a48aec2cde3769ba39972"
+MAINTAINER="Eugene Suter"
+EMAIL="easuter@gmail.com"
+APPROVED="rworkman"
diff --git a/academic/scipy/slack-desc b/academic/scipy/slack-desc
new file mode 100644
index 0000000000..b6bb92468b
--- /dev/null
+++ b/academic/scipy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------------|
+scipy: SciPy (python library for math, science, and engineering)
+scipy:
+scipy: The SciPy library is built to work with NumPy arrays, and provides many
+scipy: user-friendly and efficient numerical routines such as routines for numerical
+scipy: integration and optimization. Together, they run on all popular operating
+scipy: systems, are quick to install, and are free of charge. NumPy and SciPy are
+scipy: easy to use, but powerful enough to be depended upon by some of the world's
+scipy: leading scientists and engineers.
+scipy:
+scipy: http://www.scipy.org/
+scipy: