summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2014-03-28 12:27:59 -0500
committer Erik Hanson <erik@slackbuilds.org>2014-04-12 13:59:47 -0500
commita4817c984eb33b8ad06ace78e79c8e54159ac261 (patch)
tree1ae093bcdae4e3fa08b2f079138867d470e71b98 /academic
parente7695c5163dc2e7abd8e1b8e49a0e47604ca3958 (diff)
downloadslackbuilds-a4817c984eb33b8ad06ace78e79c8e54159ac261.tar.gz
slackbuilds-a4817c984eb33b8ad06ace78e79c8e54159ac261.tar.xz
academic/octave: Updated for version 3.8.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/octave/octave.SlackBuild29
-rw-r--r--academic/octave/octave.info8
-rw-r--r--academic/octave/patches/compressed-info.diff13
-rw-r--r--academic/octave/patches/no-qt5.diff2
-rw-r--r--academic/octave/patches/umfpack-cppflags.diff31
5 files changed, 19 insertions, 64 deletions
diff --git a/academic/octave/octave.SlackBuild b/academic/octave/octave.SlackBuild
index 275582c965..9ba829b157 100644
--- a/academic/octave/octave.SlackBuild
+++ b/academic/octave/octave.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=octave
-VERSION=${VERSION:-3.8.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.8.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,25 +72,24 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Allow Octave to find compressed info files.
-# https://savannah.gnu.org/bugs/?41054
-patch -p1 < $CWD/patches/compressed-info.diff
+chmod -R u+w,go-w,a+rX-st .
# Don't try to detect Qt5. It's not supported yet.
# https://savannah.gnu.org/bugs/?40252
patch -p1 < $CWD/patches/no-qt5.diff
-
-# Fix several configure checks due to the above umfpack.h -> amd.h issue.
-# https://savannah.gnu.org/bugs/?41209
-patch -p1 < $CWD/patches/umfpack-cppflags.diff
autoreconf -vif
+# Avoid rebuilding the documentation by making stamp-vti newer than its
+# dependencies (in particular ./configure, which we just modified above).
+# If you live far enough east or west that the date contained in version.texi
+# does not match that file's timestamp when printed accounting for your
+# timezone, then the docs get rebuilt with your local date.
+#
+# The TeX environment in Slackware 14.1 fails to build the DVI and PDF
+# targets in Octave 3.8.1. Maybe it works with a recent version of TeXLive?
+touch doc/liboctave/stamp-vti
+touch doc/interpreter/stamp-vti
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
FFLAGS="$SLKCFLAGS" \
diff --git a/academic/octave/octave.info b/academic/octave/octave.info
index 38427ac2a7..f96eeb875b 100644
--- a/academic/octave/octave.info
+++ b/academic/octave/octave.info
@@ -1,10 +1,10 @@
PRGNAM="octave"
-VERSION="3.8.0"
+VERSION="3.8.1"
HOMEPAGE="https://www.gnu.org/software/octave/"
-DOWNLOAD="ftp://ftp.gnu.org/gnu/octave/octave-3.8.0.tar.bz2"
-MD5SUM="442fe5205ba6322f7a69145b79fca85e"
+DOWNLOAD="ftp://ftp.gnu.org/gnu/octave/octave-3.8.1.tar.bz2"
+MD5SUM="4c5b9bd6b82b7fa3191af9706e7204f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="%README% blas lapack"
+REQUIRES="%README% lapack"
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"
diff --git a/academic/octave/patches/compressed-info.diff b/academic/octave/patches/compressed-info.diff
deleted file mode 100644
index 48178d773f..0000000000
--- a/academic/octave/patches/compressed-info.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/scripts/help/doc.m b/scripts/help/doc.m
---- a/scripts/help/doc.m
-+++ b/scripts/help/doc.m
-@@ -80,7 +80,8 @@
- if (err < 0)
- info_file_name = info_file ();
-
-- if (! exist (info_file_name, "file"))
-+ if (! exist (info_file_name, "file")
-+ && ! exist ([info_file_name ".gz"], "file"))
- __gripe_missing_component__ ("doc", "info-file");
- endif
- endif
diff --git a/academic/octave/patches/no-qt5.diff b/academic/octave/patches/no-qt5.diff
index 48044ef831..8da1234a9a 100644
--- a/academic/octave/patches/no-qt5.diff
+++ b/academic/octave/patches/no-qt5.diff
@@ -1,7 +1,7 @@
diff --git a/configure.ac b/configure.ac
--- a/configure.ac
+++ b/configure.ac
-@@ -2707,10 +2707,10 @@
+@@ -2745,10 +2745,10 @@
fi
if test $build_gui = yes; then
diff --git a/academic/octave/patches/umfpack-cppflags.diff b/academic/octave/patches/umfpack-cppflags.diff
deleted file mode 100644
index d56ba1f8eb..0000000000
--- a/academic/octave/patches/umfpack-cppflags.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/configure.ac b/configure.ac
---- a/configure.ac
-+++ b/configure.ac
-@@ -1512,7 +1512,9 @@
-
- if test -n "$UMFPACK_LIBS"; then
- ## SuiteSparse >= 4.0 needs additional link library for SuiteSparse_time()
-+ save_CPPFLAGS="$CPPFLAGS"
- save_LIBS="$LIBS";
-+ CPPFLAGS="$UMFPACK_CPPFLAGS $AMD_CPPFLAGS $CPPFLAGS"
- LIBS="$UMFPACK_LIBS $AMD_LDFLAGS $AMD_LIBS $BLAS_LIBS $FLIBS $LIBS"
- xtra_libs=
- OCTAVE_UMFPACK_NEED_SUITESPARSE_TIME
-@@ -1535,13 +1537,17 @@
- esac
- fi
- LIBS="$save_LIBS"
-+ CPPFLAGS="$save_CPPFLAGS"
-
- ## Check for UMFPACK separately split complex matrix and RHS.
- if test -n "$UMFPACK_LIBS"; then
-+ save_CPPFLAGS="$CPPFLAGS"
- save_LIBS="$LIBS";
-+ CPPFLAGS="$UMFPACK_CPPFLAGS $AMD_CPPFLAGS $CPPFLAGS"
- LIBS="$UMFPACK_LIBS $CHOLMOD_LDFLAGS $CHOLMOD_LIBS $AMD_LDFLAGS $AMD_LIBS $COLAMD_LDFLAGS $COLAMD_LIBS $LAPACK_LIBS $BLAS_LIBS $FLIBS $LIBS $xtra_libs"
- OCTAVE_UMFPACK_SEPARATE_SPLIT
- LIBS="$save_LIBS"
-+ CPPFLAGS="$save_CPPFLAGS"
- fi
- fi
-