summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov <ppetrov@paju.oulu.fi>2011-10-20 00:02:09 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2011-10-21 15:59:18 -0200
commit56863f1f4ffcd12a918904d4faaa63271c1b4a8f (patch)
treeb3c9ddeabd27a1840a8f5e3a0a417d74c1c8b7f3 /academic
parent5327d32896781d21b2bfcafd262edf3378e54554 (diff)
downloadslackbuilds-56863f1f4ffcd12a918904d4faaa63271c1b4a8f.tar.gz
slackbuilds-56863f1f4ffcd12a918904d4faaa63271c1b4a8f.tar.xz
academic/QtiPlot: Added (Data Analysis and Visualisation)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/QtiPlot/QtiPlot.SlackBuild137
-rw-r--r--academic/QtiPlot/QtiPlot.info12
-rw-r--r--academic/QtiPlot/README33
-rw-r--r--academic/QtiPlot/build.conf.slack73
-rw-r--r--academic/QtiPlot/doinst.sh7
-rw-r--r--academic/QtiPlot/qtiplot.desktop9
-rw-r--r--academic/QtiPlot/qtiplot.pngbin0 -> 14008 bytes
-rw-r--r--academic/QtiPlot/qtiplot.xml17
-rw-r--r--academic/QtiPlot/slack-desc19
9 files changed, 307 insertions, 0 deletions
diff --git a/academic/QtiPlot/QtiPlot.SlackBuild b/academic/QtiPlot/QtiPlot.SlackBuild
new file mode 100644
index 0000000000..77ea874e3d
--- /dev/null
+++ b/academic/QtiPlot/QtiPlot.SlackBuild
@@ -0,0 +1,137 @@
+#!/bin/sh
+
+# Slackware build script for QtiPlot
+# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
+# hereby submitted to the public domain
+
+# Based on the QtiPlot package PKGBUILD from Arch Extra.
+# Maintainer and packager is Ronald van Haren. Thank you!
+# http://www.archlinux.org/packages/extra/i686/qtiplot
+
+# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
+# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
+# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
+
+PRGNAM=QtiPlot
+VERSION=${VERSION:-0.9.8.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
+cd $TMP/$SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Build QtiPlot's qwt
+cd $TMP/$SRCNAM-$VERSION/3rdparty/qwt
+qmake
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+
+# Build QtiPlot's qwtplot3d
+cd $TMP/$SRCNAM-$VERSION/3rdparty/qwtplot3d
+qmake
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+
+# Build QTeXEngine
+cd $TMP/$SRCNAM-$VERSION/3rdparty
+unzip $CWD/QTeXEngine-0.3-opensource.zip
+cd QTeXEngine
+qmake
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+
+# Use the custom build.conf
+cd $TMP/$SRCNAM-$VERSION
+cp $CWD/build.conf.slack build.conf
+
+# A few path fixes to qtiplot.pro
+sed -i "s:/usr/local:/usr/share:" qtiplot/qtiplot.pro
+sed -i "s:/share/man:/man:" qtiplot/qtiplot.pro
+sed -i "s:/share/doc/qtiplot:/doc/$PRGNAM-$VERSION:" qtiplot/qtiplot.pro
+
+# Point to the right places of qt-assistant-compat, libreoffice
+# (when installed), latex, java and python configuration files.
+sed -i "s:<QAssistantClient>:<QtAssistant/qassistantclient.h>:" qtiplot/src/core/ApplicationWindow.cpp
+sed -i "s:/usr/bin/soffice:/usr/bin/libreoffice:" qtiplot/src/core/ApplicationWindow.cpp
+sed -i "s:/usr/bin/latex:/usr/share/texmf/bin/latex:" qtiplot/src/core/ApplicationWindow.cpp
+sed -i "s:/usr/bin/java:/usr/lib${LIBDIRSUFFIX}/java/bin/java:" qtiplot/src/core/ApplicationWindow.cpp
+sed -i 's#d_python_config_folder + "#"/usr/share/qtiplot#' qtiplot/src/core/ApplicationWindow.cpp
+
+# Build QtiPlot
+cd $TMP/$SRCNAM-$VERSION/qtiplot
+qmake qtiplot.pro
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+make install INSTALL_ROOT=$PKG
+cd -
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# Menu item, icon and mime types
+mkdir -p $PKG/usr/share/{pixmaps,applications,mime/packages}
+cp $CWD/qtiplot.png $PKG/usr/share/pixmaps
+cp $CWD/qtiplot.desktop $PKG/usr/share/applications
+cp $CWD/qtiplot.xml $PKG/usr/share/mime/packages
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.html gpl_licence.txt qtiplot.css qtiplot_logo.png \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/build.conf.slack > $PKG/usr/doc/$PRGNAM-$VERSION/build.conf.slack
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/QtiPlot/QtiPlot.info b/academic/QtiPlot/QtiPlot.info
new file mode 100644
index 0000000000..e3b245be5a
--- /dev/null
+++ b/academic/QtiPlot/QtiPlot.info
@@ -0,0 +1,12 @@
+PRGNAM="QtiPlot"
+VERSION="0.9.8.8"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+DOWNLOAD="http://download.berlios.de/qtiplot/qtiplot-0.9.8.8.tar.bz2 \
+ http://download.berlios.de/qtiplot/QTeXEngine-0.3-opensource.zip"
+MD5SUM="f14cd1af9087696ff1c8a48c3677f4dc \
+ d1b234623770ec6209b14d1b5137f2f1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Petar Petrov"
+EMAIL="ppetrov@paju.oulu.fi"
+APPROVED="Niels Horn"
diff --git a/academic/QtiPlot/README b/academic/QtiPlot/README
new file mode 100644
index 0000000000..f9aaa8daab
--- /dev/null
+++ b/academic/QtiPlot/README
@@ -0,0 +1,33 @@
+QtiPlot is a program for two- and three-dimensional graphical
+presentation of data sets and for data analysis. Plots can be produced
+from data sets stored in tables or from analytical functions. QtiPlot
+offers a complete alternative solution to software like Origin,
+SigmaPlot, SPSS, Regressi or Igor Pro. QtiPlot is used for teaching as
+well as for complex data analysis and visualisation in companies, high
+schools, universities and reseach institutes all over the world.
+
+Features:
+
+- Fully Python scriptable
+- OpenGL based 3D plotting
+- Publication quality plots and easy export to various image formats
+ (EMF, EPS, PS, PDF, SVG, BMP, JPG, PNG, TIFF, etc ...)
+- Easy integration with LaTeX typesetting system
+- Powerful and versatile spreadsheets with column-logic calculations
+ and easy import/export of multiple files
+- One-click access to extensive built-in data analysis routines
+- Advanced statistical analysis: Student's t-Test, ANOVA, chi-square
+ test for variance, normality test (Shapiro-Wilk)
+- Linear and nonlinear curve fitting with weighting and estimation of
+ statistical errors of the fit-parameters
+- Multi-peak fitting
+- Image analysis tools
+- Templates support: all settings for plots, tables and matrices can
+ be saved and restored later on for a fast editing process
+- Project files based on folders, a powerful project explorer with
+ built-in drag and drop and searching facilities
+
+This requires gsl, muParser, qt-assistant-compat, tamu_anova and
+(optionally) liborigin. All of these are available at SlackBuilds.org.
+In addition, QtiPlot comes with QTeXEngine built in and its own,
+slightly modified versions of qwt and qwtplot3d.
diff --git a/academic/QtiPlot/build.conf.slack b/academic/QtiPlot/build.conf.slack
new file mode 100644
index 0000000000..4c42efcc8c
--- /dev/null
+++ b/academic/QtiPlot/build.conf.slack
@@ -0,0 +1,73 @@
+isEmpty( QTI_ROOT ) {
+ message( "each file including this config needs to set QTI_ROOT to the dir containing this file!" )
+}
+
+# System specific configuration
+SYS_INCLUDEPATH = /usr/include
+SYS_LIBS = -L/usr/lib${LIBDIRSUFFIX}
+
+# zlib (http://www.zlib.net/)
+ZLIB_INCLUDEPATH =
+
+# muParser (http://muparser.sourceforge.net/)
+MUPARSER_INCLUDEPATH =
+MUPARSER_LIBS = -lmuparser
+
+# GNU Sientific Library (http://www.gnu.org/software/gsl/)
+GSL_INCLUDEPATH =
+GSL_LIBS = -lgsl -lgslcblas
+
+# QWT - use local copy till upstream catches up
+# (http://qwt.sourceforge.net/index.html)
+QWT_INCLUDEPATH = $$QTI_ROOT/3rdparty/qwt/src
+QWT_LIBS = $$QTI_ROOT/3rdparty/qwt/lib/libqwt.a
+
+# QwtPlot3D - use local copy till upstream catches up
+# (http://qwtplot3d.sourceforge.net/)
+QWT3D_INCLUDEPATH = $$QTI_ROOT/3rdparty/qwtplot3d/include
+QWT3D_LIBS = $$QTI_ROOT/3rdparty/qwtplot3d/lib/libqwtplot3d.a
+
+# libpng
+LIBPNG_LIBS = -lpng
+
+# Liborigin (http://sourceforge.net/projects/liborigin/)
+LIB_ORIGIN_INCLUDEPATH = /usr/include/liborigin
+LIB_ORIGIN_LIBS = -lorigin
+
+# QTeXEngine (http://soft.proindependent.com/qtexengine/)
+TEX_ENGINE_INCLUDEPATH = $$QTI_ROOT/3rdparty/QTeXEngine/src
+TEX_ENGINE_LIBS = $$QTI_ROOT/3rdparty/QTeXEngine/libQTeXEngine.a
+
+# TAMUANOVA (http://www.stat.tamu.edu/~aredd/tamuanova/)
+TAMUANOVA_INCLUDEPATH = /usr/include/tamu_anova
+TAMUANOVA_LIBS = -ltamuanova
+
+# the python interpreter to use
+PYTHON = python
+
+# Qt tools - allows to use specific versions
+LUPDATE = lupdate
+LRELEASE = lrelease
+
+# Target specific configuration: configure Qtiplot itself
+contains( TARGET, qtiplot ) {
+# building without muParser doesn't work yet
+SCRIPTING_LANGS += muParser
+SCRIPTING_LANGS += Python
+
+# a console displaying output of scripts
+DEFINES += SCRIPTING_CONSOLE
+
+# Uncomment the following line if you want to perform a custom
+# installation using the *.path variables defined in ./qtiplot.pro.
+CONFIG += CustomInstall
+
+# Uncomment the following line if you want to build QtiPlot as a browser plugin (not working on Internet Explorer).
+#CONFIG += BrowserPlugin
+
+#CONFIG += release
+#CONFIG += debug
+
+# Uncomment the following line if you want to link statically against Qt.
+#CONFIG += StaticBuild
+}
diff --git a/academic/QtiPlot/doinst.sh b/academic/QtiPlot/doinst.sh
new file mode 100644
index 0000000000..9a8ded3c60
--- /dev/null
+++ b/academic/QtiPlot/doinst.sh
@@ -0,0 +1,7 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
diff --git a/academic/QtiPlot/qtiplot.desktop b/academic/QtiPlot/qtiplot.desktop
new file mode 100644
index 0000000000..249ef846d9
--- /dev/null
+++ b/academic/QtiPlot/qtiplot.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Exec=qtiplot
+Terminal=false
+Name=QtiPlot
+Protocols=file
+Icon=qtiplot.png
+Categories=Office;
diff --git a/academic/QtiPlot/qtiplot.png b/academic/QtiPlot/qtiplot.png
new file mode 100644
index 0000000000..d83a2eb18a
--- /dev/null
+++ b/academic/QtiPlot/qtiplot.png
Binary files differ
diff --git a/academic/QtiPlot/qtiplot.xml b/academic/QtiPlot/qtiplot.xml
new file mode 100644
index 0000000000..7ad4c4aa02
--- /dev/null
+++ b/academic/QtiPlot/qtiplot.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-qtiplot-project">
+ <sub-class-of type="text/plain"/>
+ <comment>QtiPlot project file</comment>
+ <glob pattern="*.qti" />
+ </mime-type>
+ <mime-type type="application/x-qtiplot-project-compressed">
+ <comment>Compressed QtiPlot project file</comment>
+ <glob pattern="*.qti.gz" />
+ </mime-type>
+ <mime-type type="application/x-qtiplot-project-backup">
+ <sub-class-of type="text/plain"/>
+ <comment>QtiPlot project file backup</comment>
+ <glob pattern="*.qti~" />
+ </mime-type>
+</mime-info>
diff --git a/academic/QtiPlot/slack-desc b/academic/QtiPlot/slack-desc
new file mode 100644
index 0000000000..9a2b18f091
--- /dev/null
+++ b/academic/QtiPlot/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+QtiPlot: QtiPlot (Data Analysis and Visualisation)
+QtiPlot:
+QtiPlot: QtiPlot is a program for two- and three-dimensional graphical
+QtiPlot: presentation of data sets and for data analysis. Plots can be
+QtiPlot: produced from data sets stored in tables or from analytical
+QtiPlot: functions.
+QtiPlot:
+QtiPlot:
+QtiPlot:
+QtiPlot:
+QtiPlot: Home: http://soft.proindependent.com/qtiplot.html