summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov <slackalaxy@gmail.com>2019-08-02 00:18:53 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-08-02 00:18:53 +0700
commitdfabfe148d723f7bd607a826ccd09b0396e090e7 (patch)
treefa3986bb10fa1a4a3945531c1605ec068e4cda13 /academic
parent7b880fcc19ba090f63481f2016f2e21b767c549a (diff)
downloadslackbuilds-dfabfe148d723f7bd607a826ccd09b0396e090e7.tar.gz
slackbuilds-dfabfe148d723f7bd607a826ccd09b0396e090e7.tar.xz
academic/DendroPy: Added (A Phylogenetic Computing Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/DendroPy/DendroPy.SlackBuild86
-rw-r--r--academic/DendroPy/DendroPy.info10
-rw-r--r--academic/DendroPy/README18
-rw-r--r--academic/DendroPy/References9
-rw-r--r--academic/DendroPy/slack-desc19
5 files changed, 142 insertions, 0 deletions
diff --git a/academic/DendroPy/DendroPy.SlackBuild b/academic/DendroPy/DendroPy.SlackBuild
new file mode 100644
index 0000000000..83d5387ca2
--- /dev/null
+++ b/academic/DendroPy/DendroPy.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for DendroPy
+
+# Copyright 2019 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=DendroPy
+VERSION=${VERSION:-4.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/DendroPy/DendroPy.info b/academic/DendroPy/DendroPy.info
new file mode 100644
index 0000000000..9fd1030ffa
--- /dev/null
+++ b/academic/DendroPy/DendroPy.info
@@ -0,0 +1,10 @@
+PRGNAM="DendroPy"
+VERSION="4.4.0"
+HOMEPAGE="https://dendropy.org/"
+DOWNLOAD="https://github.com/jeetsukumaran/DendroPy/archive/v4.4.0/DendroPy-4.4.0.tar.gz"
+MD5SUM="171d9f435bc990778a0460a8224b3d76"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"
diff --git a/academic/DendroPy/README b/academic/DendroPy/README
new file mode 100644
index 0000000000..c4f5fc4dce
--- /dev/null
+++ b/academic/DendroPy/README
@@ -0,0 +1,18 @@
+DendroPy Phylogenetic Computing Library
+
+DendroPy is a Python library for phylogenetic computing. It provides
+classes and functions for the simulation, processing, and manipulation
+of phylogenetic trees and character matrices, and supports the reading
+and writing of phylogenetic data in a range of formats, such as NEXUS,
+NEWICK, NeXML, Phylip, FASTA, etc. Application scripts for performing
+some useful phylogenetic operations, such as data conversion and tree
+posterior distribution summarization, are also distributed and installed
+as part of the libary. DendroPy can thus function as a stand-alone
+library for phylogenetics, a component of more complex multi-library
+phyloinformatic pipelines, or as a scripting "glue" that assembles and
+drives such pipelines.
+
+If you use this library either in whole or in part in your analysis,
+or use any code derived from it, please cite it as:
+Sukumaran, J. and Mark T. Holder. 2010. DendroPy: A Python library for
+phylogenetic computing. Bioinformatics 26: 1569-1571.
diff --git a/academic/DendroPy/References b/academic/DendroPy/References
new file mode 100644
index 0000000000..755cb8d31f
--- /dev/null
+++ b/academic/DendroPy/References
@@ -0,0 +1,9 @@
+Citation
+If you use this library either in whole or in part in your analysis, or use any code derived from it, please cite it as:
+
+Sukumaran, J. and Mark T. Holder. 2010. DendroPy: A Python library for phylogenetic computing. Bioinformatics 26: 1569-1571.
+Note that, in the interests of scientific reproducibility, in addition to noting the primary citation for DendroPy as given above in the reference section, you should note in the text of your publications (e.g., in the “Methods” section, or, at the very least, in the “Supplemental Materials” section) the specific version of DendroPy that you used (e.g., “DendroPy version 4.0.0, revision 78e6a63”). You can get useful information about your DendroPy installation by typing “python -m dendropy”.
+
+If you use or reference any part of this documentation, you can cite it as:
+
+Sukumaran, J. and Mark T. Holder. The DendroPy Phylogenetic Computing Library Documentation. Retrieved March 04, 2019, from http://dendropy.org/. \ No newline at end of file
diff --git a/academic/DendroPy/slack-desc b/academic/DendroPy/slack-desc
new file mode 100644
index 0000000000..dca4b30208
--- /dev/null
+++ b/academic/DendroPy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+DendroPy: DendroPy (A Phylogenetic Computing Library)
+DendroPy:
+DendroPy: DendroPy is a Python library for phylogenetic computing. It
+DendroPy: provides classes and functions for the simulation, processing,
+DendroPy: and manipulation of phylogenetic trees and character matrices,
+DendroPy: and supports the reading and writing of phylogenetic data in a
+DendroPy: range of formats, such as NEXUS, NEWICK, NeXML, Phylip, FASTA,
+DendroPy: etc.
+DendroPy:
+DendroPy: https://dendropy.org/
+DendroPy: