summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Rob van Nues <sborg63@disroot.org>2020-03-14 06:27:44 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-03-14 06:27:44 +0700
commit89c7353cd308029dfcc2f1539485bd8cb6980b26 (patch)
tree816e0f27c3b0ce971988e506bf91e3ee9606d516 /academic
parentc7e81261bb561fa9194a2efd6740e0b6b58e4043 (diff)
downloadslackbuilds-89c7353cd308029dfcc2f1539485bd8cb6980b26.tar.gz
slackbuilds-89c7353cd308029dfcc2f1539485bd8cb6980b26.tar.xz
academic/pysam: Fix permission.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/pysam/pysam.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/academic/pysam/pysam.SlackBuild b/academic/pysam/pysam.SlackBuild
index 91c17b0e1a..1145e63733 100644
--- a/academic/pysam/pysam.SlackBuild
+++ b/academic/pysam/pysam.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=pysam
VERSION=${VERSION:-0.15.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
#set which python version to install it for
@@ -68,8 +68,9 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
+
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ \( -perm 777 -o -perm 775 -o -perm 751 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
@@ -79,6 +80,10 @@ find -L . \
#export HTSLIB_LIBRARY_DIR=/usr/lib$LIBDIRSUFFIX
#export HTSLIB_INCLUDE_DIR=/usr/include
+#the source does not allow 'read' to 'other', which could cause a problem on reloading a Jupyter-notebook
+chmod 644 pysam.egg-info/*
+
+
if $PYTHON2; then
python setup.py install --root=$PKG
fi
@@ -95,6 +100,7 @@ cp -a \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc