summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2014-02-02 06:38:16 +0700
committer Robby Workman <rworkman@slackbuilds.org>2014-02-02 02:09:47 -0600
commitfe0752ce19910951f0d11500f65762eef1a756e9 (patch)
tree24cd2bcdd4bfe75671dff0d3c3373f9bee3cd7c9 /academic
parentcea9c5812a286a23e1a2c6c641e37945fb09120c (diff)
downloadslackbuilds-fe0752ce19910951f0d11500f65762eef1a756e9.tar.gz
slackbuilds-fe0752ce19910951f0d11500f65762eef1a756e9.tar.xz
gis/horao: Moved from Academic category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/horao/README1
-rw-r--r--academic/horao/horao.SlackBuild120
-rw-r--r--academic/horao/horao.info10
-rw-r--r--academic/horao/slack-desc19
4 files changed, 0 insertions, 150 deletions
diff --git a/academic/horao/README b/academic/horao/README
deleted file mode 100644
index d4e906b25a..0000000000
--- a/academic/horao/README
+++ /dev/null
@@ -1 +0,0 @@
-Horao is Oslandia's visualisation tool for 3D GIS data.
diff --git a/academic/horao/horao.SlackBuild b/academic/horao/horao.SlackBuild
deleted file mode 100644
index 438040bf7a..0000000000
--- a/academic/horao/horao.SlackBuild
+++ /dev/null
@@ -1,120 +0,0 @@
-#!/bin/sh
-
-# SlackBuild script for horao
-
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=horao
-VERSION=${VERSION:-1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-# keep QGIS plugin disabled/undocumented since it only works with a dev branch of QGIS
-QGIS=${QGIS:-no}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-rm -rf $TMP/$PRGNAM-$VERSION
-cd $TMP
-if [ -e $CWD/v$VERSION.tar.gz ]; then
- tar xvf $CWD/v$VERSION.tar.gz
-else
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-fi
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# header files are not in gdal subdirectory
-sed -i "s/gdal\///" src/osgGIS/ReaderWriter*
-
-# QGIS plugin expects debug not release binary
-sed -i "s/horaoViewerd/horaoViewer/" qgis_plugin/canvas3d.py
-
-# respect LIBDIRSUFFIX
-sed -i "s|\ DESTINATION\ lib| DESTINATION lib$LIBDIRSUFFIX|" src/*/CMakeLists.txt
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DPostgreSQL_INCLUDE_DIR=/usr/include/postgresql/server \
- -DCMAKE_BUILD_TYPE=Release \
- ..
-
- make VERBOSE=1
- make install VERBOSE=1 DESTDIR=$PKG
-cd ..
-
-if [ "$QGIS" = "yes" ] ; then
- mkdir -p $PKG/usr/share/qgis/python/plugins/
- cp -r qgis_plugin $PKG/usr/share/qgis/python/plugins/horao
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/horao/horao.info b/academic/horao/horao.info
deleted file mode 100644
index 8ff99934bb..0000000000
--- a/academic/horao/horao.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="horao"
-VERSION="1.0"
-HOMEPAGE="http://oslandia.github.io/horao"
-DOWNLOAD="https://github.com/Oslandia/horao/archive/v1.0.tar.gz"
-MD5SUM="dda4d5569c8903a518c0725f4728edfd"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="OpenSceneGraph postgis"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/academic/horao/slack-desc b/academic/horao/slack-desc
deleted file mode 100644
index 62ddbfa7f6..0000000000
--- a/academic/horao/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-horao: horao (visualisation tool for 3D GIS data)
-horao:
-horao: Horao is a visualisation tool for 3D GIS data.
-horao:
-horao: The Horao viewer is a simple application designed to listen
-horao: to commands on its standard input.
-horao:
-horao: homepage: http://oslandia.github.io/horao
-horao:
-horao:
-horao: