summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Serban Udrea <S.Udrea@gsi.de>2018-11-02 21:44:19 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:45:00 +0700
commit28d2bec084aef0c50c53d2d795370868df960821 (patch)
tree90b0256c21f1698477c1b2eb55584109aba800d6 /academic
parent08bf0d7c3d1a667b24f9eb911053c9c50601e473 (diff)
downloadslackbuilds-28d2bec084aef0c50c53d2d795370868df960821.tar.gz
slackbuilds-28d2bec084aef0c50c53d2d795370868df960821.tar.xz
academic/kiwisolver: Added (Cassowary algorithm).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/kiwisolver/README7
-rw-r--r--academic/kiwisolver/kiwisolver.SlackBuild72
-rw-r--r--academic/kiwisolver/kiwisolver.info10
-rw-r--r--academic/kiwisolver/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/academic/kiwisolver/README b/academic/kiwisolver/README
new file mode 100644
index 0000000000..7773aa35ea
--- /dev/null
+++ b/academic/kiwisolver/README
@@ -0,0 +1,7 @@
+This is an efficient C++ implementation of the Cassowary constraint solving
+algorithm. Kiwi(solver) is an implementation of the algorithm based on the
+seminal Cassowary paper. It is not a refactoring of the original C++ solver.
+Kiwi(solver) has been designed from the ground up to be lightweight and fast.
+It ranges from 10x to 500x faster than the original Cassowary solver with
+typical use cases gaining a 40x improvement. Memory savings are consistently
+> 5x.
diff --git a/academic/kiwisolver/kiwisolver.SlackBuild b/academic/kiwisolver/kiwisolver.SlackBuild
new file mode 100644
index 0000000000..06b213b486
--- /dev/null
+++ b/academic/kiwisolver/kiwisolver.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for kiwisolver
+
+# Copyright 2018 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=kiwisolver
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING.txt PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/kiwisolver/kiwisolver.info b/academic/kiwisolver/kiwisolver.info
new file mode 100644
index 0000000000..41a6cb3771
--- /dev/null
+++ b/academic/kiwisolver/kiwisolver.info
@@ -0,0 +1,10 @@
+PRGNAM="kiwisolver"
+VERSION="1.0.1"
+HOMEPAGE="https://pypi.org/project/kiwisolver"
+DOWNLOAD="https://files.pythonhosted.org/packages/31/60/494fcce70d60a598c32ee00e71542e52e27c978e5f8219fae0d4ac6e2864/kiwisolver-1.0.1.tar.gz"
+MD5SUM="e2a1718b837e2cd001f7c06934616fcd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/academic/kiwisolver/slack-desc b/academic/kiwisolver/slack-desc
new file mode 100644
index 0000000000..ccdb0a1776
--- /dev/null
+++ b/academic/kiwisolver/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+kiwisolver: kiwisolver (an implementation of the Cassowary algorithm)
+kiwisolver:
+kiwisolver: This is an efficient C++ implementation of the Cassowary constraint
+kiwisolver: solving algorithm. Kiwi(solver) is an implementation of the algorithm
+kiwisolver: based on the seminal Cassowary paper. It is not a refactoring of the
+kiwisolver: original C++ solver. Kiwi(solver) has been designed from the ground
+kiwisolver: up to be lightweight and fast.
+kiwisolver:
+kiwisolver: Homepage: https://pypi.org/project/kiwisolver
+kiwisolver:
+kiwisolver: