summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2013-12-01 02:33:48 -0600
committer Robby Workman <rworkman@slackbuilds.org>2013-12-02 00:58:18 -0600
commit8f4c03c7d6b0e0244b983c12f3f8e9a5724a7196 (patch)
tree3f2759cb37efffe85bbb26292059a73cdbfc936f /academic
parentf9fd8d61952a7b23bfa97303e5232fc55fddbb21 (diff)
downloadslackbuilds-8f4c03c7d6b0e0244b983c12f3f8e9a5724a7196.tar.gz
slackbuilds-8f4c03c7d6b0e0244b983c12f3f8e9a5724a7196.tar.xz
academic/Shapely: Added (geometric objects, predicates, and operations in Python)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/Shapely/README5
-rw-r--r--academic/Shapely/Shapely.SlackBuild85
-rw-r--r--academic/Shapely/Shapely.info10
-rw-r--r--academic/Shapely/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/academic/Shapely/README b/academic/Shapely/README
new file mode 100644
index 0000000000..99de18871f
--- /dev/null
+++ b/academic/Shapely/README
@@ -0,0 +1,5 @@
+Shapely is a BSD-licensed Python package for manipulation and analysis
+of planar geometric objects. It is based on the widely deployed GEOS
+(the engine of PostGIS) and JTS (from which GEOS is ported) libraries.
+Shapely is not concerned with data formats or coordinate systems, but
+can be readily integrated with packages that are.
diff --git a/academic/Shapely/Shapely.SlackBuild b/academic/Shapely/Shapely.SlackBuild
new file mode 100644
index 0000000000..0c1c935844
--- /dev/null
+++ b/academic/Shapely/Shapely.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for Shapely
+
+# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Shapely
+VERSION=${VERSION:-1.2.18}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO CHANGES.txt CREDITS.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/Shapely/Shapely.info b/academic/Shapely/Shapely.info
new file mode 100644
index 0000000000..68e042e4a5
--- /dev/null
+++ b/academic/Shapely/Shapely.info
@@ -0,0 +1,10 @@
+PRGNAM="Shapely"
+VERSION="1.2.18"
+HOMEPAGE="http://pypi.python.org/pypi/Shapely/"
+DOWNLOAD="https://pypi.python.org/packages/source/S/Shapely/Shapely-1.2.18.tar.gz"
+MD5SUM="53ad33214886e729b2d0de488eb9f115"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="geos pysetuptools"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/academic/Shapely/slack-desc b/academic/Shapely/slack-desc
new file mode 100644
index 0000000000..04c91b0fa0
--- /dev/null
+++ b/academic/Shapely/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Shapely: Shapely (geometric objects, predicates, and operations in Python)
+Shapely:
+Shapely: Shapely is a BSD-licensed Python package for manipulation and analysis
+Shapely: of planar geometric objects. It is based on the widely deployed GEOS
+Shapely: (the engine of PostGIS) and JTS (from which GEOS is ported) libraries.
+Shapely: Shapely is not concerned with data formats or coordinate systems, but
+Shapely: can be readily integrated with packages that are.
+Shapely:
+Shapely: Homepage: https://pypi.python.org/pypi/Shapely/
+Shapely:
+Shapely: