summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Fellype do Nascimento <fellypao@yahoo.com.br>2021-12-30 09:42:35 -0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-12-31 08:27:04 +0700
commitef32447ddb0406f0795430ac4ff2d7b1f16c74cf (patch)
tree63d144d9a4a85771c00bd9847b6a21d723bdf47e /academic
parent2d9af791f7f52a8950158a0942201e88a4b9b663 (diff)
downloadslackbuilds-ef32447ddb0406f0795430ac4ff2d7b1f16c74cf.tar.gz
slackbuilds-ef32447ddb0406f0795430ac4ff2d7b1f16c74cf.tar.xz
academic/labplot2: Updated for version 2.8.2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/labplot2/README3
-rw-r--r--academic/labplot2/labplot2.SlackBuild17
-rw-r--r--academic/labplot2/labplot2.info8
3 files changed, 16 insertions, 12 deletions
diff --git a/academic/labplot2/README b/academic/labplot2/README
index ae07007ac1..d34496e452 100644
--- a/academic/labplot2/README
+++ b/academic/labplot2/README
@@ -15,5 +15,8 @@ are several new features that were not available in LabPlot1.
optional dependencies:
+- LaTeX (to enable LaTeX typesetting in LabPlot)
+- fftw
- hdf5
- netcdf
+- cfitsio
diff --git a/academic/labplot2/labplot2.SlackBuild b/academic/labplot2/labplot2.SlackBuild
index c1da77ddf7..90b9c916fc 100644
--- a/academic/labplot2/labplot2.SlackBuild
+++ b/academic/labplot2/labplot2.SlackBuild
@@ -1,8 +1,10 @@
#!/bin/bash
#
# Slackware build script for LabPlot
-# Based on the Slackware 14.1 SlackBuild and AUR PKGBUILD for labplot
-# Written by Fellype do Nascimento <fellype(at)gmail.com>
+# Based on the Slackware 15.0 SlackBuild and AUR PKGBUILD for labplot
+#
+# Copyright 2014-2022, Fellype do Nascimento, Guaratingueta - Brazil
+# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -25,7 +27,7 @@ NAME=labplot
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=labplot2
-VERSION=${VERSION:-2.4.0}
+VERSION=${VERSION:-2.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -87,18 +89,17 @@ find -L . | xargs -O file | grep "shared object" | grep ELF | cut -f 1 -d : | xa
find -L . | xargs -O file | grep "current ar archive" | cut -f 1 -d : | xargs strip -g 2> /dev/null || true
)
+find $PKG/usr/share/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/share/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL README \
+cp -a AUTHORS ChangeLog COPYING INSTALL README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-if [ -e /usr/bin/requiredbuilder ]; then
- requiredbuilder -v -y -s $CWD $PKG
-fi
-
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/labplot2/labplot2.info b/academic/labplot2/labplot2.info
index cf80183dd6..7e146ae6f5 100644
--- a/academic/labplot2/labplot2.info
+++ b/academic/labplot2/labplot2.info
@@ -1,10 +1,10 @@
PRGNAM="labplot2"
-VERSION="2.4.0"
+VERSION="2.8.2"
HOMEPAGE="https://labplot.kde.org/"
-DOWNLOAD="http://kde.c3sl.ufpr.br/stable/labplot/2.4.0/labplot-2.4.0.tar.xz"
-MD5SUM="ee59c0095190bb3dc100e29e1a00c654"
+DOWNLOAD="https://download.kde.org/stable/labplot/2.8.2/labplot-2.8.2.tar.xz"
+MD5SUM="0d95441aa1b07898ed5811ff2dc485b7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Fellype do Nascimento"
-EMAIL="fellype(at)gmail.com"
+EMAIL="fellype (at) gmail (dot) com"