summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2017-07-04 16:09:31 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-08 07:11:37 +0700
commitf7a230b7fa81e6e69e50ee78e7e9c55fc656e026 (patch)
treed95de9c9b72949a53f5d7585034bd57c07943cbf /academic
parent791c6a8c344ada57c8a24ed99161d6279ac3b546 (diff)
downloadslackbuilds-f7a230b7fa81e6e69e50ee78e7e9c55fc656e026.tar.gz
slackbuilds-f7a230b7fa81e6e69e50ee78e7e9c55fc656e026.tar.xz
academic/spqr: Updated for version 2.0.8.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'academic')
-rw-r--r--academic/spqr/patches/autoconfiscate.diff (renamed from academic/spqr/patches/autotoolize.diff)591
-rw-r--r--academic/spqr/spqr.SlackBuild14
-rw-r--r--academic/spqr/spqr.info6
3 files changed, 488 insertions, 123 deletions
diff --git a/academic/spqr/patches/autotoolize.diff b/academic/spqr/patches/autoconfiscate.diff
index 86bc23333a..fbf3dce1db 100644
--- a/academic/spqr/patches/autotoolize.diff
+++ b/academic/spqr/patches/autoconfiscate.diff
@@ -2,9 +2,8 @@ diff --git a/Demo/Makefile.am b/Demo/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Demo/Makefile.am
-@@ -0,0 +1,111 @@
+@@ -0,0 +1,115 @@
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(CHOLMOD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
-+LDADD = $(top_builddir)/Source/libspqr.la
+
+EXTRA_DIST = \
+ README.txt \
@@ -18,11 +17,16 @@ new file mode 100644
+ qrdemoc
+
+qrsimple_SOURCES = qrsimple.cpp
++qrsimple_LDADD = $(top_builddir)/Source/libspqr.la $(CHOLMOD_LIBS)
++
+qrsimplec_SOURCES = qrsimplec.c
-+qrsimplec_CFLAGS = $(AM_CFLAGS) -ansi
++qrsimplec_LDADD = $(top_builddir)/Source/libspqr.la $(CHOLMOD_LIBS)
++
+qrdemo_SOURCES = qrdemo.cpp
++qrdemo_LDADD = $(top_builddir)/Source/libspqr.la $(CHOLMOD_LIBS)
++
+qrdemoc_SOURCES = qrdemoc.c
-+qrdemoc_CFLAGS = $(AM_CFLAGS) -ansi
++qrdemoc_LDADD = $(top_builddir)/Source/libspqr.la $(CHOLMOD_LIBS)
+
+MATRICES = \
+ $(top_srcdir)/Matrix/GD01_b.mtx \
@@ -162,11 +166,16 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
-@@ -0,0 +1,4 @@
-+SUBDIRS = Include Source Matrix Demo Doc
+@@ -0,0 +1,9 @@
++ACLOCAL_AMFLAGS = -I m4
++
++SUBDIRS = Include Source Matrix Demo Tcov Doc
+EXTRA_DIST = README.txt
+
+pkgconfig_DATA = spqr.pc
++
++CODE_COVERAGE_BRANCH_COVERAGE = 1
++@CODE_COVERAGE_RULES@
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
new file mode 100644
--- /dev/null
@@ -212,7 +221,7 @@ diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
-@@ -0,0 +1,54 @@
+@@ -0,0 +1,56 @@
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(TBB_CFLAGS) $(CHOLMOD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
+if !EXPERT
+AM_CPPFLAGS += -DNEXPERT
@@ -265,15 +274,198 @@ new file mode 100644
+ spqr_trapezoidal.cpp \
+ spqr_type.cpp
+
-+libspqr_la_LIBADD = $(TBB_LIBS) $(CHOLMOD_LIBS) $(SUITESPARSECONFIG_LIBS) $(LAPACK_LIBS) $(BLAS_LIBS) -lm
++libspqr_la_LIBADD = $(TBB_LIBS) $(CHOLMOD_LIBS) $(SUITESPARSECONFIG_LIBS) $(LAPACK_LIBS) $(BLAS_LIBS) -lm $(CODE_COVERAGE_LIBS)
++libspqr_la_CPPFLAGS = $(AM_CPPFLAGS) $(CODE_COVERAGE_CPPFLAGS)
++libspqr_la_CXXFLAGS = $(AM_CXXFLAGS) $(CODE_COVERAGE_CXXFLAGS)
+libspqr_la_LDFLAGS = -no-undefined -release $(PACKAGE_VERSION)
-diff --git a/ax_blas.m4 b/ax_blas.m4
+diff --git a/Tcov/Makefile.am b/Tcov/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Tcov/Makefile.am
+@@ -0,0 +1,52 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(CHOLMOD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
++
++EXTRA_DIST = \
++ README.txt
++
++dist_noinst_DATA = \
++ matrix1.txt \
++ matrixlist.txt
++
++if CODE_COVERAGE_ENABLED
++check_PROGRAMS = \
++ qrtest
++
++qrtest_SOURCES = qrtestc.c qrtest.cpp
++qrtest_LDADD = $(top_builddir)/Source/libspqr.la $(CHOLMOD_LIBS) $(SUITESPARSECONFIG_LIBS)
++
++MATRICES = \
++ $(srcdir)/matrix1.txt \
++ $(srcdir)/matrixlist.txt \
++ $(top_srcdir)/Matrix/GD01_b.mtx \
++ $(top_srcdir)/Matrix/GD06_theory.mtx \
++ $(top_srcdir)/Matrix/GD98_a.mtx \
++ $(top_srcdir)/Matrix/LFAT5.mtx \
++ $(top_srcdir)/Matrix/Ragusa16.mtx \
++ $(top_srcdir)/Matrix/Tina_AskCal.mtx \
++ $(top_srcdir)/Matrix/Tina_AskCal_perm.mtx \
++ $(top_srcdir)/Matrix/a0.mtx \
++ $(top_srcdir)/Matrix/a04.mtx \
++ $(top_srcdir)/Matrix/a1.mtx \
++ $(top_srcdir)/Matrix/a2.mtx \
++ $(top_srcdir)/Matrix/a4.mtx \
++ $(top_srcdir)/Matrix/arrow.mtx \
++ $(top_srcdir)/Matrix/ash219.mtx \
++ $(top_srcdir)/Matrix/b1_ss.mtx \
++ $(top_srcdir)/Matrix/bcspwr01.mtx \
++ $(top_srcdir)/Matrix/bfwa62.mtx \
++ $(top_srcdir)/Matrix/c2.mtx \
++ $(top_srcdir)/Matrix/c32.mtx \
++ $(top_srcdir)/Matrix/lfat5b.mtx \
++ $(top_srcdir)/Matrix/lp_share1b.mtx \
++ $(top_srcdir)/Matrix/lpi_galenet.mtx \
++ $(top_srcdir)/Matrix/lpi_itest6.mtx \
++ $(top_srcdir)/Matrix/r2.mtx \
++ $(top_srcdir)/Matrix/s32.mtx \
++ $(top_srcdir)/Matrix/west0067.mtx
++
++check-local: $(check_PROGRAMS) $(MATRICES)
++ ./qrtest $(srcdir)/matrixlist.txt > qrtest_out.txt
++ ./qrtest $(srcdir)/matrix1.txt > qrtest_out1.txt
++endif
++
++CLEANFILES = qrtest_out.txt qrtest_out1.txt
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,119 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([SPQR],[2.0.8],[DrTimothyAldenDavis@gmail.com],[spqr],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([Source/spqr_kernel.cpp])
++AC_CONFIG_AUX_DIR([build-aux])
++AC_CONFIG_MACRO_DIR([m4])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++AM_SILENT_RULES([yes])
++LT_INIT([disable-static])
++
++# Checks for programs.
++PKG_PROG_PKG_CONFIG
++AC_PROG_INSTALL
++AC_PROG_F77
++AC_PROG_CC
++AC_PROG_CXX
++AC_LANG([C++])
++AX_CODE_COVERAGE
++
++AC_ARG_ENABLE([expert],
++ [AS_HELP_STRING(
++ [--disable-expert],
++ [compile without the min 2-norm solution option])],
++ [],
++ [AS_VAR_SET([enable_expert], [yes])])
++
++AC_ARG_WITH([tbb],
++ [AS_HELP_STRING(
++ [--without-tbb],
++ [do not use Intel Threading Building Blocks for multithreading])],
++ [],
++ [AS_VAR_SET([with_tbb], [yes])])
++
++AS_VAR_SET([LIBS_SAVED], [$LIBS])
++
++# Checks for libraries.
++AC_CHECK_LIB([m], [sqrt])
++
++AX_BLAS(
++ [],
++ [AC_MSG_ERROR([cannot find BLAS])])
++
++AX_LAPACK(
++ [],
++ [AC_MSG_ERROR([cannot find LAPACK])])
++
++PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
++PKG_CHECK_MODULES([CHOLMOD], [cholmod])
++
++# Checks for header files.
++AC_CHECK_HEADERS([float.h stdlib.h])
++
++AS_IF([test "x$with_tbb" = "xyes"], [
++ AC_CHECK_HEADERS([tbb/task_scheduler_init.h tbb/task.h])
++])
++
++# Checks for typedefs, structures, and compiler characteristics.
++AC_TYPE_SIZE_T
++
++# Checks for library functions.
++AC_CHECK_FUNCS([sqrt])
++
++AS_VAR_SET([LIBS], [$LIBS_SAVED])
++
++AS_IF([test "x$with_tbb" = "xyes"], [
++ AC_SUBST([TBB_CFLAGS], [""])
++ AC_SUBST([TBB_LIBS], ["-ltbb"])
++])
++
++AC_MSG_CHECKING([whether to use expert routines])
++AC_MSG_RESULT([$enable_expert])
++AM_CONDITIONAL([EXPERT], [test "x$enable_expert" = "xyes"])
++
++AC_MSG_CHECKING([whether to use Intel Threading Building Blocks])
++AC_MSG_RESULT([$with_tbb])
++AM_CONDITIONAL([TBB], [test "x$with_tbb" = "xyes"])
++
++PKG_INSTALLDIR
++AC_CONFIG_FILES([
++ spqr.pc
++ Makefile
++ Demo/Makefile
++ Doc/Makefile
++ Include/Makefile
++ Matrix/Makefile
++ Source/Makefile
++ Tcov/Makefile
++])
++#AC_CONFIG_LINKS([Matrix:Matrix]) # Can't link an entire directory?
++AC_CONFIG_LINKS([Matrix/GD01_b.mtx:Matrix/GD01_b.mtx])
++AC_CONFIG_LINKS([Matrix/GD06_theory.mtx:Matrix/GD06_theory.mtx])
++AC_CONFIG_LINKS([Matrix/GD98_a.mtx:Matrix/GD98_a.mtx])
++AC_CONFIG_LINKS([Matrix/LFAT5.mtx:Matrix/LFAT5.mtx])
++AC_CONFIG_LINKS([Matrix/Ragusa16.mtx:Matrix/Ragusa16.mtx])
++AC_CONFIG_LINKS([Matrix/Tina_AskCal.mtx:Matrix/Tina_AskCal.mtx])
++AC_CONFIG_LINKS([Matrix/Tina_AskCal_perm.mtx:Matrix/Tina_AskCal_perm.mtx])
++AC_CONFIG_LINKS([Matrix/a0.mtx:Matrix/a0.mtx])
++AC_CONFIG_LINKS([Matrix/a04.mtx:Matrix/a04.mtx])
++AC_CONFIG_LINKS([Matrix/a1.mtx:Matrix/a1.mtx])
++AC_CONFIG_LINKS([Matrix/a2.mtx:Matrix/a2.mtx])
++AC_CONFIG_LINKS([Matrix/a4.mtx:Matrix/a4.mtx])
++AC_CONFIG_LINKS([Matrix/arrow.mtx:Matrix/arrow.mtx])
++AC_CONFIG_LINKS([Matrix/ash219.mtx:Matrix/ash219.mtx])
++AC_CONFIG_LINKS([Matrix/b1_ss.mtx:Matrix/b1_ss.mtx])
++AC_CONFIG_LINKS([Matrix/bcspwr01.mtx:Matrix/bcspwr01.mtx])
++AC_CONFIG_LINKS([Matrix/bfwa62.mtx:Matrix/bfwa62.mtx])
++AC_CONFIG_LINKS([Matrix/c2.mtx:Matrix/c2.mtx])
++AC_CONFIG_LINKS([Matrix/c32.mtx:Matrix/c32.mtx])
++AC_CONFIG_LINKS([Matrix/lfat5b.mtx:Matrix/lfat5b.mtx])
++AC_CONFIG_LINKS([Matrix/lp_share1b.mtx:Matrix/lp_share1b.mtx])
++AC_CONFIG_LINKS([Matrix/lpi_galenet.mtx:Matrix/lpi_galenet.mtx])
++AC_CONFIG_LINKS([Matrix/lpi_itest6.mtx:Matrix/lpi_itest6.mtx])
++AC_CONFIG_LINKS([Matrix/r2.mtx:Matrix/r2.mtx])
++AC_CONFIG_LINKS([Matrix/s32.mtx:Matrix/s32.mtx])
++AC_CONFIG_LINKS([Matrix/west0067.mtx:Matrix/west0067.mtx])
++AC_OUTPUT
+diff --git a/m4/ax_blas.m4 b/m4/ax_blas.m4
new file mode 100644
--- /dev/null
-+++ b/ax_blas.m4
++++ b/m4/ax_blas.m4
@@ -0,0 +1,238 @@
+# ===========================================================================
-+# http://www.gnu.org/software/autoconf-archive/ax_blas.html
++# https://www.gnu.org/software/autoconf-archive/ax_blas.html
+# ===========================================================================
+#
+# SYNOPSIS
@@ -322,7 +514,7 @@ new file mode 100644
+# Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
-+# with this program. If not, see <http://www.gnu.org/licenses/>.
++# with this program. If not, see <https://www.gnu.org/licenses/>.
+#
+# As a special exception, the respective Autoconf Macro's copyright owner
+# gives unlimited permission to copy, distribute and modify the configure
@@ -337,7 +529,7 @@ new file mode 100644
+# modified version of the Autoconf Macro, you may extend this special
+# exception to the GPL to apply to your modified version as well.
+
-+#serial 14
++#serial 15
+
+AU_ALIAS([ACX_BLAS], [AX_BLAS])
+AC_DEFUN([AX_BLAS], [
@@ -510,13 +702,282 @@ new file mode 100644
+ $2
+fi
+])dnl AX_BLAS
-diff --git a/ax_lapack.m4 b/ax_lapack.m4
+diff --git a/m4/ax_code_coverage.m4 b/m4/ax_code_coverage.m4
+new file mode 100644
+--- /dev/null
++++ b/m4/ax_code_coverage.m4
+@@ -0,0 +1,264 @@
++# ===========================================================================
++# https://www.gnu.org/software/autoconf-archive/ax_code_coverage.html
++# ===========================================================================
++#
++# SYNOPSIS
++#
++# AX_CODE_COVERAGE()
++#
++# DESCRIPTION
++#
++# Defines CODE_COVERAGE_CPPFLAGS, CODE_COVERAGE_CFLAGS,
++# CODE_COVERAGE_CXXFLAGS and CODE_COVERAGE_LIBS which should be included
++# in the CPPFLAGS, CFLAGS CXXFLAGS and LIBS/LIBADD variables of every
++# build target (program or library) which should be built with code
++# coverage support. Also defines CODE_COVERAGE_RULES which should be
++# substituted in your Makefile; and $enable_code_coverage which can be
++# used in subsequent configure output. CODE_COVERAGE_ENABLED is defined
++# and substituted, and corresponds to the value of the
++# --enable-code-coverage option, which defaults to being disabled.
++#
++# Test also for gcov program and create GCOV variable that could be
++# substituted.
++#
++# Note that all optimization flags in CFLAGS must be disabled when code
++# coverage is enabled.
++#
++# Usage example:
++#
++# configure.ac:
++#
++# AX_CODE_COVERAGE
++#
++# Makefile.am:
++#
++# @CODE_COVERAGE_RULES@
++# my_program_LIBS = ... $(CODE_COVERAGE_LIBS) ...
++# my_program_CPPFLAGS = ... $(CODE_COVERAGE_CPPFLAGS) ...
++# my_program_CFLAGS = ... $(CODE_COVERAGE_CFLAGS) ...
++# my_program_CXXFLAGS = ... $(CODE_COVERAGE_CXXFLAGS) ...
++#
++# This results in a "check-code-coverage" rule being added to any
++# Makefile.am which includes "@CODE_COVERAGE_RULES@" (assuming the module
++# has been configured with --enable-code-coverage). Running `make
++# check-code-coverage` in that directory will run the module's test suite
++# (`make check`) and build a code coverage report detailing the code which
++# was touched, then print the URI for the report.
++#
++# In earlier versions of this macro, CODE_COVERAGE_LDFLAGS was defined
++# instead of CODE_COVERAGE_LIBS. They are both still defined, but use of
++# CODE_COVERAGE_LIBS is preferred for clarity; CODE_COVERAGE_LDFLAGS is
++# deprecated. They have the same value.
++#
++# This code was derived from Makefile.decl in GLib, originally licenced
++# under LGPLv2.1+.
++#
++# LICENSE
++#
++# Copyright (c) 2012, 2016 Philip Withnall
++# Copyright (c) 2012 Xan Lopez
++# Copyright (c) 2012 Christian Persch
++# Copyright (c) 2012 Paolo Borelli
++# Copyright (c) 2012 Dan Winship
++# Copyright (c) 2015 Bastien ROUCARIES
++#
++# This library is free software; you can redistribute it and/or modify it
++# under the terms of the GNU Lesser General Public License as published by
++# the Free Software Foundation; either version 2.1 of the License, or (at
++# your option) any later version.
++#
++# This library is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
++# General Public License for more details.
++#
++# You should have received a copy of the GNU Lesser General Public License
++# along with this program. If not, see <https://www.gnu.org/licenses/>.
++
++#serial 24
++
++AC_DEFUN([AX_CODE_COVERAGE],[
++ dnl Check for --enable-code-coverage
++ AC_REQUIRE([AC_PROG_SED])
++
++ # allow to override gcov location
++ AC_ARG_WITH([gcov],
++ [AS_HELP_STRING([--with-gcov[=GCOV]], [use given GCOV for coverage (GCOV=gcov).])],
++ [_AX_CODE_COVERAGE_GCOV_PROG_WITH=$with_gcov],
++ [_AX_CODE_COVERAGE_GCOV_PROG_WITH=gcov])
++
++ AC_MSG_CHECKING([whether to build with code coverage support])
++ AC_ARG_ENABLE([code-coverage],
++ AS_HELP_STRING([--enable-code-coverage],
++ [Whether to enable code coverage support]),,
++ enable_code_coverage=no)
++
++ AM_CONDITIONAL([CODE_COVERAGE_ENABLED], [test x$enable_code_coverage = xyes])
++ AC_SUBST([CODE_COVERAGE_ENABLED], [$enable_code_coverage])
++ AC_MSG_RESULT($enable_code_coverage)
++
++ AS_IF([ test "$enable_code_coverage" = "yes" ], [
++ # check for gcov
++ AC_CHECK_TOOL([GCOV],
++ [$_AX_CODE_COVERAGE_GCOV_PROG_WITH],
++ [:])
++ AS_IF([test "X$GCOV" = "X:"],
++ [AC_MSG_ERROR([gcov is needed to do coverage])])
++ AC_SUBST([GCOV])
++
++ dnl Check if gcc is being used
++ AS_IF([ test "$GCC" = "no" ], [
++ AC_MSG_ERROR([not compiling with gcc, which is required for gcov code coverage])
++ ])
++
++ AC_CHECK_PROG([LCOV], [lcov], [lcov])
++ AC_CHECK_PROG([GENHTML], [genhtml], [genhtml])
++
++ AS_IF([ test -z "$LCOV" ], [
++ AC_MSG_ERROR([To enable code coverage reporting you must have lcov installed])
++ ])
++
++ AS_IF([ test -z "$GENHTML" ], [
++ AC_MSG_ERROR([Could not find genhtml from the lcov package])
++ ])
++
++ dnl Build the code coverage flags
++ dnl Define CODE_COVERAGE_LDFLAGS for backwards compatibility
++ CODE_COVERAGE_CPPFLAGS="-DNDEBUG"
++ CODE_COVERAGE_CFLAGS="-O0 -g -fprofile-arcs -ftest-coverage"
++ CODE_COVERAGE_CXXFLAGS="-O0 -g -fprofile-arcs -ftest-coverage"
++ CODE_COVERAGE_LIBS="-lgcov"
++ CODE_COVERAGE_LDFLAGS="$CODE_COVERAGE_LIBS"
++
++ AC_SUBST([CODE_COVERAGE_CPPFLAGS])
++ AC_SUBST([CODE_COVERAGE_CFLAGS])
++ AC_SUBST([CODE_COVERAGE_CXXFLAGS])
++ AC_SUBST([CODE_COVERAGE_LIBS])
++ AC_SUBST([CODE_COVERAGE_LDFLAGS])
++
++ [CODE_COVERAGE_RULES_CHECK='
++ -$(A''M_V_at)$(MAKE) $(AM_MAKEFLAGS) -k check
++ $(A''M_V_at)$(MAKE) $(AM_MAKEFLAGS) code-coverage-capture
++']
++ [CODE_COVERAGE_RULES_CAPTURE='
++ $(code_coverage_v_lcov_cap)$(LCOV) $(code_coverage_quiet) $(addprefix --directory ,$(CODE_COVERAGE_DIRECTORY)) --capture --output-file "$(CODE_COVERAGE_OUTPUT_FILE).tmp" --test-name "$(call code_coverage_sanitize,$(PACKAGE_NAME)-$(PACKAGE_VERSION))" --no-checksum --compat-libtool $(CODE_COVERAGE_LCOV_SHOPTS) $(CODE_COVERAGE_LCOV_OPTIONS)
++ $(code_coverage_v_lcov_ign)$(LCOV) $(code_coverage_quiet) $(addprefix --directory ,$(CODE_COVERAGE_DIRECTORY)) --remove "$(CODE_COVERAGE_OUTPUT_FILE).tmp" "/tmp/*" $(CODE_COVERAGE_IGNORE_PATTERN) --output-file "$(CODE_COVERAGE_OUTPUT_FILE)" $(CODE_COVERAGE_LCOV_SHOPTS) $(CODE_COVERAGE_LCOV_RMOPTS)
++ -@rm -f $(CODE_COVERAGE_OUTPUT_FILE).tmp
++ $(code_coverage_v_genhtml)LANG=C $(GENHTML) $(code_coverage_quiet) $(addprefix --prefix ,$(CODE_COVERAGE_DIRECTORY)) --output-directory "$(CODE_COVERAGE_OUTPUT_DIRECTORY)" --title "$(PACKAGE_NAME)-$(PACKAGE_VERSION) Code Coverage" --legend --show-details "$(CODE_COVERAGE_OUTPUT_FILE)" $(CODE_COVERAGE_GENHTML_OPTIONS)
++ @echo "file://$(abs_builddir)/$(CODE_COVERAGE_OUTPUT_DIRECTORY)/index.html"
++']
++ [CODE_COVERAGE_RULES_CLEAN='
++clean: code-coverage-clean
++distclean: code-coverage-clean
++code-coverage-clean:
++ -$(LCOV) --directory $(top_builddir) -z
++ -rm -rf $(CODE_COVERAGE_OUTPUT_FILE) $(CODE_COVERAGE_OUTPUT_FILE).tmp $(CODE_COVERAGE_OUTPUT_DIRECTORY)
++ -find . \( -name "*.gcda" -o -name "*.gcno" -o -name "*.gcov" \) -delete
++']
++ ], [
++ [CODE_COVERAGE_RULES_CHECK='
++ @echo "Need to reconfigure with --enable-code-coverage"
++']
++ CODE_COVERAGE_RULES_CAPTURE="$CODE_COVERAGE_RULES_CHECK"
++ CODE_COVERAGE_RULES_CLEAN=''
++ ])
++
++[CODE_COVERAGE_RULES='
++# Code coverage
++#
++# Optional:
++# - CODE_COVERAGE_DIRECTORY: Top-level directory for code coverage reporting.
++# Multiple directories may be specified, separated by whitespace.
++# (Default: $(top_builddir))
++# - CODE_COVERAGE_OUTPUT_FILE: Filename and path for the .info file generated
++# by lcov for code coverage. (Default:
++# $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage.info)
++# - CODE_COVERAGE_OUTPUT_DIRECTORY: Directory for generated code coverage
++# reports to be created. (Default:
++# $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage)
++# - CODE_COVERAGE_BRANCH_COVERAGE: Set to 1 to enforce branch coverage,
++# set to 0 to disable it and leave empty to stay with the default.
++# (Default: empty)
++# - CODE_COVERAGE_LCOV_SHOPTS_DEFAULT: Extra options shared between both lcov
++# instances. (Default: based on $CODE_COVERAGE_BRANCH_COVERAGE)
++# - CODE_COVERAGE_LCOV_SHOPTS: Extra options to shared between both lcov
++# instances. (Default: $CODE_COVERAGE_LCOV_SHOPTS_DEFAULT)
++# - CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH: --gcov-tool pathtogcov
++# - CODE_COVERAGE_LCOV_OPTIONS_DEFAULT: Extra options to pass to the
++# collecting lcov instance. (Default: $CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH)
++# - CODE_COVERAGE_LCOV_OPTIONS: Extra options to pass to the collecting lcov
++# instance. (Default: $CODE_COVERAGE_LCOV_OPTIONS_DEFAULT)
++# - CODE_COVERAGE_LCOV_RMOPTS_DEFAULT: Extra options to pass to the filtering
++# lcov instance. (Default: empty)
++# - CODE_COVERAGE_LCOV_RMOPTS: Extra options to pass to the filtering lcov
++# instance. (Default: $CODE_COVERAGE_LCOV_RMOPTS_DEFAULT)
++# - CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT: Extra options to pass to the
++# genhtml instance. (Default: based on $CODE_COVERAGE_BRANCH_COVERAGE)
++# - CODE_COVERAGE_GENHTML_OPTIONS: Extra options to pass to the genhtml
++# instance. (Default: $CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT)
++# - CODE_COVERAGE_IGNORE_PATTERN: Extra glob pattern of files to ignore
++#
++# The generated report will be titled using the $(PACKAGE_NAME) and
++# $(PACKAGE_VERSION). In order to add the current git hash to the title,
++# use the git-version-gen script, available online.
++
++# Optional variables
++CODE_COVERAGE_DIRECTORY ?= $(top_builddir)
++CODE_COVERAGE_OUTPUT_FILE ?= $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage.info
++CODE_COVERAGE_OUTPUT_DIRECTORY ?= $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage
++CODE_COVERAGE_BRANCH_COVERAGE ?=
++CODE_COVERAGE_LCOV_SHOPTS_DEFAULT ?= $(if $(CODE_COVERAGE_BRANCH_COVERAGE),\
++--rc lcov_branch_coverage=$(CODE_COVERAGE_BRANCH_COVERAGE))
++CODE_COVERAGE_LCOV_SHOPTS ?= $(CODE_COVERAGE_LCOV_SHOPTS_DEFAULT)
++CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH ?= --gcov-tool "$(GCOV)"
++CODE_COVERAGE_LCOV_OPTIONS_DEFAULT ?= $(CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH)
++CODE_COVERAGE_LCOV_OPTIONS ?= $(CODE_COVERAGE_LCOV_OPTIONS_DEFAULT)
++CODE_COVERAGE_LCOV_RMOPTS_DEFAULT ?=
++CODE_COVERAGE_LCOV_RMOPTS ?= $(CODE_COVERAGE_LCOV_RMOPTS_DEFAULT)
++CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT ?=\
++$(if $(CODE_COVERAGE_BRANCH_COVERAGE),\
++--rc genhtml_branch_coverage=$(CODE_COVERAGE_BRANCH_COVERAGE))
++CODE_COVERAGE_GENHTML_OPTIONS ?= $(CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT)
++CODE_COVERAGE_IGNORE_PATTERN ?=
++
++code_coverage_v_lcov_cap = $(code_coverage_v_lcov_cap_$(V))
++code_coverage_v_lcov_cap_ = $(code_coverage_v_lcov_cap_$(AM_DEFAULT_VERBOSITY))
++code_coverage_v_lcov_cap_0 = @echo " LCOV --capture"\
++ $(CODE_COVERAGE_OUTPUT_FILE);
++code_coverage_v_lcov_ign = $(code_coverage_v_lcov_ign_$(V))
++code_coverage_v_lcov_ign_ = $(code_coverage_v_lcov_ign_$(AM_DEFAULT_VERBOSITY))
++code_coverage_v_lcov_ign_0 = @echo " LCOV --remove /tmp/*"\
++ $(CODE_COVERAGE_IGNORE_PATTERN);
++code_coverage_v_genhtml = $(code_coverage_v_genhtml_$(V))
++code_coverage_v_genhtml_ = $(code_coverage_v_genhtml_$(AM_DEFAULT_VERBOSITY))
++code_coverage_v_genhtml_0 = @echo " GEN " $(CODE_COVERAGE_OUTPUT_DIRECTORY);
++code_coverage_quiet = $(code_coverage_quiet_$(V))
++code_coverage_quiet_ = $(code_coverage_quiet_$(AM_DEFAULT_VERBOSITY))
++code_coverage_quiet_0 = --quiet
++
++# sanitizes the test-name: replaces with underscores: dashes and dots
++code_coverage_sanitize = $(subst -,_,$(subst .,_,$(1)))
++
++# Use recursive makes in order to ignore errors during check
++check-code-coverage:'"$CODE_COVERAGE_RULES_CHECK"'
++
++# Capture code coverage data
++code-coverage-capture: code-coverage-capture-hook'"$CODE_COVERAGE_RULES_CAPTURE"'
++
++# Hook rule executed before code-coverage-capture, overridable by the user
++code-coverage-capture-hook:
++
++'"$CODE_COVERAGE_RULES_CLEAN"'
++
++GITIGNOREFILES ?=
++GITIGNOREFILES += $(CODE_COVERAGE_OUTPUT_FILE) $(CODE_COVERAGE_OUTPUT_DIRECTORY)
++
++A''M_DISTCHECK_CONFIGURE_FLAGS ?=
++A''M_DISTCHECK_CONFIGURE_FLAGS += --disable-code-coverage
++
++.PHONY: check-code-coverage code-coverage-capture code-coverage-capture-hook code-coverage-clean
++']
++
++ AC_SUBST([CODE_COVERAGE_RULES])
++ m4_ifdef([_AM_SUBST_NOTMAKE], [_AM_SUBST_NOTMAKE([CODE_COVERAGE_RULES])])
++])
+diff --git a/m4/ax_lapack.m4 b/m4/ax_lapack.m4
new file mode 100644
--- /dev/null
-+++ b/ax_lapack.m4
++++ b/m4/ax_lapack.m4
@@ -0,0 +1,131 @@
+# ===========================================================================
-+# http://www.gnu.org/software/autoconf-archive/ax_lapack.html
++# https://www.gnu.org/software/autoconf-archive/ax_lapack.html
+# ===========================================================================
+#
+# SYNOPSIS
@@ -566,7 +1027,7 @@ new file mode 100644
+# Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
-+# with this program. If not, see <http://www.gnu.org/licenses/>.
++# with this program. If not, see <https://www.gnu.org/licenses/>.
+#
+# As a special exception, the respective Autoconf Macro's copyright owner
+# gives unlimited permission to copy, distribute and modify the configure
@@ -581,7 +1042,7 @@ new file mode 100644
+# modified version of the Autoconf Macro, you may extend this special
+# exception to the GPL to apply to your modified version as well.
+
-+#serial 7
++#serial 8
+
+AU_ALIAS([ACX_LAPACK], [AX_LAPACK])
+AC_DEFUN([AX_LAPACK], [
@@ -646,100 +1107,6 @@ new file mode 100644
+ $2
+fi
+])dnl AX_LAPACK
-diff --git a/configure.ac b/configure.ac
-new file mode 100644
---- /dev/null
-+++ b/configure.ac
-@@ -0,0 +1,89 @@
-+# -*- Autoconf -*-
-+# Process this file with autoconf to produce a configure script.
-+
-+AC_PREREQ([2.69])
-+AC_INIT([SPQR],[2.0.7],[DrTimothyAldenDavis@gmail.com],[spqr],[http://www.suitesparse.com/])
-+AC_CONFIG_SRCDIR([Source/spqr_kernel.cpp])
-+AC_CONFIG_HEADERS([config.h])
-+AM_INIT_AUTOMAKE([foreign])
-+LT_INIT
-+
-+# Checks for programs.
-+PKG_PROG_PKG_CONFIG
-+AC_PROG_INSTALL
-+AC_PROG_F77
-+AC_PROG_CC
-+AC_PROG_CXX
-+AC_LANG([C++])
-+
-+AC_ARG_ENABLE([expert],
-+ [AS_HELP_STRING(
-+ [--disable-expert],
-+ [compile without the min 2-norm solution option])],
-+ [],
-+ [AS_VAR_SET([enable_expert], [yes])])
-+
-+AC_ARG_WITH([tbb],
-+ [AS_HELP_STRING(
-+ [--without-tbb],
-+ [do not use Intel Threading Building Blocks for multithreading])],
-+ [],
-+ [AS_VAR_SET([with_tbb], [yes])])
-+
-+AS_VAR_SET([LIBS_SAVED], [$LIBS])
-+
-+# Checks for libraries.
-+AC_CHECK_LIB([m], [sqrt])
-+
-+sinclude([ax_blas.m4])
-+AX_BLAS(
-+ [],
-+ [AC_MSG_ERROR([cannot find BLAS])])
-+
-+sinclude([ax_lapack.m4])
-+AX_LAPACK(
-+ [],
-+ [AC_MSG_ERROR([cannot find LAPACK])])
-+
-+PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
-+PKG_CHECK_MODULES([CHOLMOD], [cholmod])
-+
-+# Checks for header files.
-+AC_CHECK_HEADERS([float.h stdlib.h])
-+
-+AS_IF([test "x$with_tbb" = "xyes"], [
-+ AC_CHECK_HEADERS([tbb/task_scheduler_init.h tbb/task.h])
-+])
-+
-+# Checks for typedefs, structures, and compiler characteristics.
-+AC_TYPE_SIZE_T
-+
-+# Checks for library functions.
-+AC_CHECK_FUNCS([sqrt])
-+
-+AS_VAR_SET([LIBS], [$LIBS_SAVED])
-+
-+AS_IF([test "x$with_tbb" = "xyes"], [
-+ AC_SUBST([TBB_CFLAGS], [""])
-+ AC_SUBST([TBB_LIBS], ["-ltbb"])
-+])
-+
-+AC_MSG_CHECKING([whether to use expert routines])
-+AC_MSG_RESULT([$enable_expert])
-+AM_CONDITIONAL([EXPERT], [test "x$enable_expert" = "xyes"])
-+
-+AC_MSG_CHECKING([whether to use Intel Threading Building Blocks])
-+AC_MSG_RESULT([$with_tbb])
-+AM_CONDITIONAL([TBB], [test "x$with_tbb" = "xyes"])
-+
-+PKG_INSTALLDIR
-+AC_CONFIG_FILES([
-+ spqr.pc
-+ Makefile
-+ Demo/Makefile
-+ Doc/Makefile
-+ Include/Makefile
-+ Matrix/Makefile
-+ Source/Makefile
-+])
-+AC_OUTPUT
diff --git a/spqr.pc.in b/spqr.pc.in
new file mode 100644
--- /dev/null
diff --git a/academic/spqr/spqr.SlackBuild b/academic/spqr/spqr.SlackBuild
index aa9380fc4b..4fb6a77e9b 100644
--- a/academic/spqr/spqr.SlackBuild
+++ b/academic/spqr/spqr.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for SPQR
-# Copyright 2013-2016 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2013-2017 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
PRGNAM=spqr
SRCNAM=SuiteSparse
SUBDIR=SPQR
-VERSION=${VERSION:-2.0.7}
-SRCVER=${SRCVER:-4.5.3}
+VERSION=${VERSION:-2.0.8}
+SRCVER=${SRCVER:-4.5.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,7 +40,7 @@ fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
+PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
DOCS="README.txt Doc/ChangeLog Doc/License.txt Doc/gpl.txt"
@@ -76,8 +76,8 @@ cd $SRCNAM/$SUBDIR
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-patch -p1 < $CWD/patches/autotoolize.diff
-patch -p2 < $CWD/patches/atlas-lib-rename.diff
+patch -p1 < $CWD/patches/autoconfiscate.diff
+patch -p1 < $CWD/patches/atlas-lib-rename.diff
autoreconf -vif
# Avoid rebuilding the docs.
@@ -91,8 +91,6 @@ touch Doc/spqr_user_guide.pdf
--mandir=/usr/man \
--infodir=/usr/info \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-shared \
- --disable-static \
--disable-dependency-tracking \
--build=$ARCH-slackware-linux \
CFLAGS="$SLKCFLAGS" \
diff --git a/academic/spqr/spqr.info b/academic/spqr/spqr.info
index cf8bd8799b..424db31cd7 100644
--- a/academic/spqr/spqr.info
+++ b/academic/spqr/spqr.info
@@ -1,8 +1,8 @@
PRGNAM="spqr"
-VERSION="2.0.7"
+VERSION="2.0.8"
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
-DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.3.tar.gz"
-MD5SUM="8ec57324585df3c6483ad7f556afccbd"
+DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.5.tar.gz"
+MD5SUM="0a5b38af0016f009409a9606d2f1b555"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="blas lapack suitesparseconfig cholmod tbb"