summaryrefslogtreecommitdiffstats
path: root/accessibility
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2015-06-24 16:35:11 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-06-28 11:49:20 +0700
commit27bebf536e4e907583b49ab2122df8ea49314d8a (patch)
tree1ca19b6f9a2894143c5b0b8e01c08f64e0fe83d4 /accessibility
parentdfec940e0028db00f9fdf059c7d2c208d908b541 (diff)
downloadslackbuilds-27bebf536e4e907583b49ab2122df8ea49314d8a.tar.gz
slackbuilds-27bebf536e4e907583b49ab2122df8ea49314d8a.tar.xz
accessibility/flite: Fix doc build issue.
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/flite/README5
-rw-r--r--accessibility/flite/flite.SlackBuild62
2 files changed, 44 insertions, 23 deletions
diff --git a/accessibility/flite/README b/accessibility/flite/README
index 646bc48203..8e44fa95c9 100644
--- a/accessibility/flite/README
+++ b/accessibility/flite/README
@@ -10,3 +10,8 @@ loadable voices in the package, download the ones you want from
http://festvox.org/flite/packed/flite-2.0/voices/ and place them
in the same directory as the SlackBuild. They will be installed in
/usr/share/flite/, and can be used with the flite's -voice option.
+
+To skip building the HTML and GNU Info API documentation, set DOCS=no
+in the environment. The man page will still be included. This option is
+mainly provided in case a future version of texi2html has issues with
+the texi2html options used by flite's doc/Makefile.
diff --git a/accessibility/flite/flite.SlackBuild b/accessibility/flite/flite.SlackBuild
index e45fe7fbb5..c937d4761b 100644
--- a/accessibility/flite/flite.SlackBuild
+++ b/accessibility/flite/flite.SlackBuild
@@ -4,6 +4,12 @@
# Originally written by Martin Lefebvre (dadexter@sekurity.com)
# Now maintained by B. Watson (yalhcru@gmail.com), original author is MIA.
+# 20150623 bkw:
+# - fix doc build failure with standalone SBo texi2html, thanks
+# to John Vogel for investigating this
+# - add DOCS=no option, in case a future texi2html has more
+# issues
+
# 20150509 bkw:
# - update for 2.0.0
# - add HTML and .info docs
@@ -78,6 +84,12 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-static \
--build=$ARCH-slackware-linux
+# Fix builds with SBo standalone texi2html. The -number option works
+# with Slackware's ancient texi2html (from t/tetex), but would have to
+# be --number-sections in the newer SBo texi2html. It turns out section
+# numbering is enabled by default in both versions, so get rid of it...
+sed -i '/texi2html/s,-number,,' doc/Makefile
+
make
make install prefix=$PKG/usr INSTALLLIBDIR=$PKG/usr/lib${LIBDIRSUFFIX}
@@ -97,31 +109,35 @@ done
# build the docs. NB don't replace subshells with "cd dir" and
# "cd -", as they don't nest.
-( cd doc
- # build the HTML docs.
- make $PRGNAM.html
- ( cd html
-
- # Upstream hardlinks index.html, use a symlink instead.
- rm -f index.html
- ln -s ${PRGNAM}_toc.html index.html
-
- # Also, we don't ship the PDF doc, so link to upstream's.
- # Fix link to source package.
- sed -i \
- -e 's,HREF="flite.pdf",HREF="http://www.festvox.org/flite/doc/flite.pdf",' \
- -e 's,\.tar\.gz,.tar.bz2,g' \
- ${PRGNAM}_toc.html
+HTMLDOC=""
+if [ "${DOCS:-yes}" = "yes" ]; then
+ HTMLDOC="doc/html"
+ ( cd doc
+ # build the HTML docs.
+ make $PRGNAM.html
+ ( cd html
+
+ # Upstream hardlinks index.html, use a symlink instead.
+ rm -f index.html
+ ln -s ${PRGNAM}_toc.html index.html
+
+ # Also, we don't ship the PDF doc, so link to upstream's.
+ # Fix link to source package.
+ sed -i \
+ -e 's,HREF="flite.pdf",HREF="http://www.festvox.org/flite/doc/flite.pdf",' \
+ -e 's,\.tar\.gz,.tar.bz2,g' \
+ ${PRGNAM}_toc.html
+ )
+
+ # build the GNU info docs
+ makeinfo $PRGNAM.texi
+ mkdir -p $PKG/usr/info
+ gzip -9c < $PRGNAM.info > $PKG/usr/info/$PRGNAM.info.gz
)
-
- # build the GNU info docs
- makeinfo $PRGNAM.texi
- mkdir -p $PKG/usr/info
- gzip -9c < $PRGNAM.info > $PKG/usr/info/$PRGNAM.info.gz
-)
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKNOWLEDGEMENTS COPYING README doc/html doc/*.txt doc/alice \
+cp -a ACKNOWLEDGEMENTS COPYING README $HTMLDOC doc/*.txt doc/alice \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -140,7 +156,7 @@ else
fi
# doinst.sh needed because we append to /usr/info/dir.
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
+[ "${DOCS:-yes}" = "yes" ] && cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}