summaryrefslogtreecommitdiffstats
path: root/audio/eyeD3/eyeD3.SlackBuild
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:30:45 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:30:45 +0200
commitaadf21dd321cf07a976a284ef1ffbad01f512056 (patch)
tree455cc248b34ece04be0e0e77dd345b15b6bb954f /audio/eyeD3/eyeD3.SlackBuild
parent72128f7e66b181d0a596c7702af008bd891527a9 (diff)
downloadslackbuilds-aadf21dd321cf07a976a284ef1ffbad01f512056.tar.gz
slackbuilds-aadf21dd321cf07a976a284ef1ffbad01f512056.tar.xz
audio/eyeD3: Moved from multimedia
Diffstat (limited to 'audio/eyeD3/eyeD3.SlackBuild')
-rw-r--r--audio/eyeD3/eyeD3.SlackBuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/audio/eyeD3/eyeD3.SlackBuild b/audio/eyeD3/eyeD3.SlackBuild
new file mode 100644
index 0000000000..f1b8790ab8
--- /dev/null
+++ b/audio/eyeD3/eyeD3.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for abiword
+
+# Copyright 2007 Andrew Lindberg <alindberg@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuilds.org project
+# No additional license terms added
+
+PRGNAM=eyeD3
+VERSION=0.6.14
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# eyeD3 neatly wraps the setup.py script in an automake system
+# --docdir is ignored by the build process, but we'll leave it here anyway
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ || exit 1
+
+make || exit 1
+make DESTDIR=$PKG install || exit 1
+
+# and the automake does everything neatly for docs and man pages, et al
+# just need the slack-specific files
+mv $PKG/usr/share/doc $PKG/usr
+rmdir $PKG/usr/share
+( cd $PKG/usr/doc/$PRGNAM-$VERSION
+ cat $CWD/$PRGNAM.SlackBuild > $PRGNAM.SlackBuild
+ gzip -d {COPYING.gz,ChangeLog.gz}
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz