summaryrefslogtreecommitdiffstats
path: root/audio/jack-tools
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2018-06-17 20:36:46 -0400
committer David Spencer <idlemoor@slackbuilds.org>2018-06-18 09:07:17 +0100
commit375071ebf3a1ed7b15d1bb26ef3d5cd31e317a34 (patch)
tree43bf382434fc7c32d072988f2018132bd38fe5d0 /audio/jack-tools
parentb7544991ec3016b2e14d407a02d77cdeae579987 (diff)
downloadslackbuilds-375071ebf3a1ed7b15d1bb26ef3d5cd31e317a34.tar.gz
slackbuilds-375071ebf3a1ed7b15d1bb26ef3d5cd31e317a34.tar.xz
audio/jack-tools: Updated for version 20170117, fix VST mess.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'audio/jack-tools')
-rw-r--r--audio/jack-tools/README3
-rw-r--r--audio/jack-tools/README_VST.txt60
-rw-r--r--audio/jack-tools/jack-tools.SlackBuild59
-rw-r--r--audio/jack-tools/jack-tools.info6
-rw-r--r--audio/jack-tools/man/jack-data.1170
-rw-r--r--audio/jack-tools/man/jack-lxvst.1.optional161
-rw-r--r--audio/jack-tools/man/jack-udp.12
-rw-r--r--audio/jack-tools/slack-desc2
8 files changed, 450 insertions, 13 deletions
diff --git a/audio/jack-tools/README b/audio/jack-tools/README
index 7d82241c8b..151310ae1f 100644
--- a/audio/jack-tools/README
+++ b/audio/jack-tools/README
@@ -3,7 +3,10 @@ This collection contains a bunch of small tools for JACK
Included utilities:
+jack-data - JACK audio data onto OSC
jack-dl - JACK shared library dsp loader
+jack-lxvst - Linux native VSTi host. Not included by default.
+ See README_VST.txt for details.
jack-osc - JACK Transport Publication Daemon
jack-play - JACK Sound File Player
jack-plumbing - JACK Plumbing Daemon
diff --git a/audio/jack-tools/README_VST.txt b/audio/jack-tools/README_VST.txt
new file mode 100644
index 0000000000..85396ad39a
--- /dev/null
+++ b/audio/jack-tools/README_VST.txt
@@ -0,0 +1,60 @@
+jack-tools includes a utility called "jack-lxvst", which is a host for
+Linux native VST plugins.
+
+For licensing reasons, the VST headers (copyright Steinberg) cannot
+be included in this SlackBuild. If you need jack-lxvst, you'll have to
+register as a developer at https://www.steinberg.net/ and download the VST
+developers' kit from there. You want version 2.x of the dev kit (which may
+no longer be available; not sure if version 3.x works with jack-lxvst). Once
+you've downloaded the files and extracted them, do one of these things:
+
+- Copy or symlink the files aeffect.h and aeffectx.h to the jack-tools
+ directory (the one that contains jack-tools.SlackBuild).
+
+- Or, export VST_HEADERS=<path> in the environment before running the
+ SlackBuild. <path> is the directory that contains the files aeffect.h
+ and aeffectx.h. Example: export VST_HEADERS=/usr/local/include/VST
+
+If all went well, when you install the jack-tools package, the description
+will say "This package was built WITH Steinberg Linux VST support". Just
+to be on the safe side, do not redistribute the package. I'm not a lawyer
+and I'm not sure whether Steinberg's license would allow redistribution
+of a compiled binary using the VST headers.
+
+If you did the above but the build fails to compile, you might be using
+the wrong version of the VST headers. This would be a problem for upstream
+(the actual author of jack-tools) to fix, so report it there.
+
+The above only has to be done if you actually need jack-lxvst. If you
+don't know whether you need it, read this FAQ:
+
+Q: What is VST?
+A: If you don't know, you don't need jack-lxvst, and you can stop
+ reading now.
+
+Q: What is a Linux native VST?
+A: The vast majority of VST plugins (effects and instruments) are
+ distributed as Windows executables (or DLLs). A Linux native VST is a
+ Linux executable (or shared library), either distributed as source and
+ compiled by the user, or (more often) as a precompiled binary. Linux
+ native VST plugins are pretty rare, although they do exist.
+
+Q: What is jack-lxvst?
+A: jack-lxvst is a standalone host for Linux native VSTs. If you don't
+ use Linux native VSTs, you don't need jack-lxvst.
+
+Q: I want to use Linux native VST plugins in my DAW, which has Linux
+ native VST support. Do I need jack-lxvst?
+A: No. If your DAW supports Linux native VST plugins, you don't need a
+ separate host for them (such as jack-lxvst).
+
+Q: I have this Windows VST plugin I want to use on Linux, do I need
+ jack-lxvst?
+A: No. jack-lxvst is only for Linux native VST plugins. For Windows VSTs,
+ try wineasio. Ardour can also be built with Windows VST support,
+ using WINE. Whatever solution you find for Windows VSTs on Linux
+ will pretty much have to involve WINE somehow.
+
+Q: I have a Linux native VST I want to use with my DAW, but my DAW
+ doesn't have VST support. Can I use jack-lxvst for this?
+A: Yes. This is the intended use for jack-lxvst.
diff --git a/audio/jack-tools/jack-tools.SlackBuild b/audio/jack-tools/jack-tools.SlackBuild
index 70524f89a8..9437bd4046 100644
--- a/audio/jack-tools/jack-tools.SlackBuild
+++ b/audio/jack-tools/jack-tools.SlackBuild
@@ -4,6 +4,26 @@
# Written by B. Watson (yalhcru@gmail.com)
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20180617 bkw:
+# - BUILD=2
+# - Get rid of VST headers, since Steinberg doesn't want us to
+# distribute them. Thanks to idlemoor for cleaning up the mess
+# in the git history.
+# - If the user really needs native VST support, he can get the
+# headers the legit way (from Steinberg) and the script will
+# pick them up. Otherwise, jack-lxvst is just not built. Add
+# README_VST.txt to hopefully clarify the situation.
+
+# 20170127 bkw:
+# - Updated for 20170117 (latest commit). Also updated c-common to
+# latest.
+# - Added man pages for the new jack-data and jack-lxvst utils.
+# - Added VST headers to get jack-lxvst to build. Not sure the
+# licensing status of these, but they were cloned from a public
+# github repo.
+
# 20151110 bkw:
# - Updated for 20141211. This is the date of the latest darcs
# commit. Note that the c-common/ in the source tarball is the
@@ -12,10 +32,8 @@
# and jack-play have changed.
# - Add capability stuff.
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
PRGNAM=jack-tools
-VERSION=${VERSION:-20141211}
+VERSION=${VERSION:-20170117}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,30 +70,55 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}-$VERSION.tar.gz
+tar xvf $CWD/${PRGNAM}-$VERSION.tar.xz
cd $PRGNAM-$VERSION
-sed -i "s,-O.,$SLKCFLAGS," Makefile c-common/Makefile
+# apply our flags. -Wl,-s strips the binaries.
+sed -i "s/-O./$SLKCFLAGS -Wl,-s/" Makefile c-common/Makefile
+
+# Slackware 14.2 doesn't have libtinfo (15.0 will, IIRC).
+sed -i 's,-ltinfo,,' Makefile
+
+# Author's library
make -C c-common
+
+# If the Steinberg VST headers are found, put them where the build can find
+# them. Neither SBo nor upstream can distribute the headers, you have to get
+# them direct from Steinberg.
+VST_HEADERS=${VST_HEADERS:-$CWD}
+if [ -e $VST_HEADERS/aeffect.h -a -e $VST_HEADERS/aeffectx.h ]; then
+ mkdir -p pluginterfaces/vst2.x
+ cp $VST_HEADERS/aeffect.h $VST_HEADERS/aeffectx.h pluginterfaces/vst2.x
+ STEINBERG_ME_HARDER="yes"
+ WITH=WITH
+else
+ sed -i '/^bin=/s,jack-lxvst,,' Makefile
+ WITH=WITHOUT
+fi
+
make
mkdir -p $PKG/usr/bin $PKG/usr/include
make install prefix=$PKG/usr
-strip $PKG/usr/bin/*
-# man pages generated from *.ad asciidoc files, then manually edited
+# man pages generated from *.md markdown files, then manually edited
# to clean up the formatting.
mkdir -p $PKG/usr/man/man1
for page in $CWD/man/*.1; do
gzip -9c < $page > $PKG/usr/man/man1/$( basename $page ).gz
done
+# Only install the lxvst man page if the lxvst binary got built.
+if [ "$STEINBERG_ME_HARDER" = "yes" ]; then
+ gzip -9c < $CWD/man/jack-lxvst.1.optional > $PKG/usr/man/man1/jack-lxvst.1.gz
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat README > $PKG/usr/doc/$PRGNAM-$VERSION/README
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
+sed "s,@WITH@,$WITH," $CWD/slack-desc > $PKG/install/slack-desc
# Only add capability stuff if not disabled:
if [ "${SETCAP:-yes}" = "yes" ]; then
diff --git a/audio/jack-tools/jack-tools.info b/audio/jack-tools/jack-tools.info
index 824e6662ed..04a3cc71c9 100644
--- a/audio/jack-tools/jack-tools.info
+++ b/audio/jack-tools/jack-tools.info
@@ -1,8 +1,8 @@
PRGNAM="jack-tools"
-VERSION="20141211"
+VERSION="20170117"
HOMEPAGE="http://rd.slavepianos.org/?t=rju"
-DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/jack-tools-20141211.tar.gz"
-MD5SUM="6ad8e71fcab77b79fa6dffb0533b3278"
+DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/jack-tools-20170117.tar.xz"
+MD5SUM="1733e89a77b9a5fa1c04f6b0327e362e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="jack-audio-connection-kit liblo"
diff --git a/audio/jack-tools/man/jack-data.1 b/audio/jack-tools/man/jack-data.1
new file mode 100644
index 0000000000..8c59f4c9e0
--- /dev/null
+++ b/audio/jack-tools/man/jack-data.1
@@ -0,0 +1,170 @@
+.\" Automatically generated by Pod::Man 2.28 (Pod::Simple 3.29)
+.\"
+.\" Standard preamble:
+.\" ========================================================================
+.de Sp \" Vertical space (when we can't use .PP)
+.if t .sp .5v
+.if n .sp
+..
+.de Vb \" Begin verbatim text
+.ft CW
+.nf
+.ne \\$1
+..
+.de Ve \" End verbatim text
+.ft R
+.fi
+..
+.\" Set up some character translations and predefined strings. \*(-- will
+.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
+.\" double quote, and \*(R" will give a right double quote. \*(C+ will
+.\" give a nicer C++. Capital omega is used to do unbreakable dashes and
+.\" therefore won't be available. \*(C` and \*(C' expand to `' in nroff,
+.\" nothing in troff, for use with C<>.
+.tr \(*W-
+.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
+.ie n \{\
+. ds -- \(*W-
+. ds PI pi
+. if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
+. if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\" diablo 12 pitch
+. ds L" ""
+. ds R" ""
+. ds C` ""
+. ds C' ""
+'br\}
+.el\{\
+. ds -- \|\(em\|
+. ds PI \(*p
+. ds L" ``
+. ds R" ''
+. ds C`
+. ds C'
+'br\}
+.\"
+.\" Escape single quotes in literal strings from groff's Unicode transform.
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\"
+.\" If the F register is turned on, we'll generate index entries on stderr for
+.\" titles (.TH), headers (.SH), subsections (.SS), items (.Ip), and index
+.\" entries marked with X<> in POD. Of course, you'll have to process the
+.\" output yourself in some meaningful fashion.
+.\"
+.\" Avoid warning from groff about undefined register 'F'.
+.de IX
+..
+.nr rF 0
+.if \n(.g .if rF .nr rF 1
+.if (\n(rF:(\n(.g==0)) \{
+. if \nF \{
+. de IX
+. tm Index:\\$1\t\\n%\t"\\$2"
+..
+. if !\nF==2 \{
+. nr % 0
+. nr F 2
+. \}
+. \}
+.\}
+.rr rF
+.\"
+.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
+.\" Fear. Run. Save yourself. No user-serviceable parts.
+. \" fudge factors for nroff and troff
+.if n \{\
+. ds #H 0
+. ds #V .8m
+. ds #F .3m
+. ds #[ \f1
+. ds #] \fP
+.\}
+.if t \{\
+. ds #H ((1u-(\\\\n(.fu%2u))*.13m)
+. ds #V .6m
+. ds #F 0
+. ds #[ \&
+. ds #] \&
+.\}
+. \" simple accents for nroff and troff
+.if n \{\
+. ds ' \&
+. ds ` \&
+. ds ^ \&
+. ds , \&
+. ds ~ ~
+. ds /
+.\}
+.if t \{\
+. ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
+. ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
+. ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
+. ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
+. ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
+. ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
+.\}
+. \" troff and (daisy-wheel) nroff accents
+.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
+.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
+.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
+.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
+.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
+.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
+.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
+.ds ae a\h'-(\w'a'u*4/10)'e
+.ds Ae A\h'-(\w'A'u*4/10)'E
+. \" corrections for vroff
+.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
+.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
+. \" for low resolution devices (crt and lpr)
+.if \n(.H>23 .if \n(.V>19 \
+\{\
+. ds : e
+. ds 8 ss
+. ds o a
+. ds d- d\h'-1'\(ga
+. ds D- D\h'-1'\(hy
+. ds th \o'bp'
+. ds Th \o'LP'
+. ds ae ae
+. ds Ae AE
+.\}
+.rm #[ #] #H #V #F C
+.\" ========================================================================
+.\"
+.IX Title "JACK-DATA 1"
+.TH JACK-DATA 1 "2017-01-27" "20170126" "SlackBuilds.org"
+.\" For nroff, turn off justification. Always turn off hyphenation; it makes
+.\" way too many mistakes in technical documents.
+.if n .ad l
+.nh
+.SH "NAME"
+jack\-data \- JACK audio data onto OSC
+.SH "SYNOPSIS"
+.IX Header "SYNOPSIS"
+jack-data \fBnc\fR \fBread\fR \fBwrite\fR \fBtype\fR \fBudp\fR
+.SH "OPTIONS"
+.IX Header "OPTIONS"
+\&\fB\-h\fR help
+.SH "DESCRIPTION"
+.IX Header "DESCRIPTION"
+\&\f(CW\*(C`nc\*(C'\fR is the number of input channels, \f(CW\*(C`read\*(C'\fR is the input block size
+in frames, \f(CW\*(C`write\*(C'\fR is the output block size (also in frames), \f(CW\*(C`type\*(C'\fR
+is output data type (either \f(CW\*(C`u8\*(C'\fR or \f(CW\*(C`f32\*(C'\fR), \f(CW\*(C`udp\*(C'\fR is the port number
+to send \s-1OSC\s0 packets to. The packets are sent as \f(CW\*(C`/data\*(C'\fR messages withe
+the first four arguments (ie. nc, read, write and type) followed by the
+resampled (if required) interleaved audio data.
+.PP
+.Vb 5
+\& $ jack\-data 1 512 32 u8 57190 &
+\& $ hosc\-print json \-p 57190
+\& ["/data",1,512,32,"u8",{"blob":[0,3,7,9,10,7,1,6,14,16,12,3, [...]
+\& ^C
+\& $
+.Ve
+.SH "SEE ALSO"
+.IX Header "SEE ALSO"
+\&\fIjackd\fR\|(1), \s-1\fIOSC\s0\fR\|(7) http://opensoundcontrol.org/
+.SH "AUTHOR"
+.IX Header "AUTHOR"
+Rohan Drape <rd@slavepianos.org>
diff --git a/audio/jack-tools/man/jack-lxvst.1.optional b/audio/jack-tools/man/jack-lxvst.1.optional
new file mode 100644
index 0000000000..bbee9f368c
--- /dev/null
+++ b/audio/jack-tools/man/jack-lxvst.1.optional
@@ -0,0 +1,161 @@
+.\" Automatically generated by Pod::Man 2.28 (Pod::Simple 3.29)
+.\"
+.\" Standard preamble:
+.\" ========================================================================
+.de Sp \" Vertical space (when we can't use .PP)
+.if t .sp .5v
+.if n .sp
+..
+.de Vb \" Begin verbatim text
+.ft CW
+.nf
+.ne \\$1
+..
+.de Ve \" End verbatim text
+.ft R
+.fi
+..
+.\" Set up some character translations and predefined strings. \*(-- will
+.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
+.\" double quote, and \*(R" will give a right double quote. \*(C+ will
+.\" give a nicer C++. Capital omega is used to do unbreakable dashes and
+.\" therefore won't be available. \*(C` and \*(C' expand to `' in nroff,
+.\" nothing in troff, for use with C<>.
+.tr \(*W-
+.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
+.ie n \{\
+. ds -- \(*W-
+. ds PI pi
+. if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
+. if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\" diablo 12 pitch
+. ds L" ""
+. ds R" ""
+. ds C` ""
+. ds C' ""
+'br\}
+.el\{\
+. ds -- \|\(em\|
+. ds PI \(*p
+. ds L" ``
+. ds R" ''
+. ds C`
+. ds C'
+'br\}
+.\"
+.\" Escape single quotes in literal strings from groff's Unicode transform.
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\"
+.\" If the F register is turned on, we'll generate index entries on stderr for
+.\" titles (.TH), headers (.SH), subsections (.SS), items (.Ip), and index
+.\" entries marked with X<> in POD. Of course, you'll have to process the
+.\" output yourself in some meaningful fashion.
+.\"
+.\" Avoid warning from groff about undefined register 'F'.
+.de IX
+..
+.nr rF 0
+.if \n(.g .if rF .nr rF 1
+.if (\n(rF:(\n(.g==0)) \{
+. if \nF \{
+. de IX
+. tm Index:\\$1\t\\n%\t"\\$2"
+..
+. if !\nF==2 \{
+. nr % 0
+. nr F 2
+. \}
+. \}
+.\}
+.rr rF
+.\"
+.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
+.\" Fear. Run. Save yourself. No user-serviceable parts.
+. \" fudge factors for nroff and troff
+.if n \{\
+. ds #H 0
+. ds #V .8m
+. ds #F .3m
+. ds #[ \f1
+. ds #] \fP
+.\}
+.if t \{\
+. ds #H ((1u-(\\\\n(.fu%2u))*.13m)
+. ds #V .6m
+. ds #F 0
+. ds #[ \&
+. ds #] \&
+.\}
+. \" simple accents for nroff and troff
+.if n \{\
+. ds ' \&
+. ds ` \&
+. ds ^ \&
+. ds , \&
+. ds ~ ~
+. ds /
+.\}
+.if t \{\
+. ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
+. ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
+. ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
+. ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
+. ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
+. ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
+.\}
+. \" troff and (daisy-wheel) nroff accents
+.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
+.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
+.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
+.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
+.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
+.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
+.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
+.ds ae a\h'-(\w'a'u*4/10)'e
+.ds Ae A\h'-(\w'A'u*4/10)'E
+. \" corrections for vroff
+.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
+.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
+. \" for low resolution devices (crt and lpr)
+.if \n(.H>23 .if \n(.V>19 \
+\{\
+. ds : e
+. ds 8 ss
+. ds o a
+. ds d- d\h'-1'\(ga
+. ds D- D\h'-1'\(hy
+. ds th \o'bp'
+. ds Th \o'LP'
+. ds ae ae
+. ds Ae AE
+.\}
+.rm #[ #] #H #V #F C
+.\" ========================================================================
+.\"
+.IX Title "JACK-LXVST 1"
+.TH JACK-LXVST 1 "2017-01-27" "20170126" "SlackBuilds.org"
+.\" For nroff, turn off justification. Always turn off hyphenation; it makes
+.\" way too many mistakes in technical documents.
+.if n .ad l
+.nh
+.SH "NAME"
+jack\-lxvst \- JACK CLI Linux/VST Host
+.SH "SYNOPSIS"
+.IX Header "SYNOPSIS"
+jack-lxvst \fBvst-file\fR
+.SH "OPTIONS"
+.IX Header "OPTIONS"
+\&\fB\-h\fR help
+.SH "DESCRIPTION"
+.IX Header "DESCRIPTION"
+jack-lxvst is a \s-1JACK CLI\s0 host for Linux/VST plugins.
+.PP
+It consults the environment variables \s-1JACK_LXVST_MIDI_CONNECT_FROM\s0 and
+\&\s-1JACK_LXVST_CONNECT_TO.\s0
+.PP
+It listens for \s-1OSC\s0 messages at port 57210.
+.SH "SEE ALSO"
+.IX Header "SEE ALSO"
+\&\fIjackd\fR\|(1)
+.SH "AUTHOR Rohan Drape <rd@slavepianos.org>"
+.IX Header "AUTHOR Rohan Drape <rd@slavepianos.org>"
diff --git a/audio/jack-tools/man/jack-udp.1 b/audio/jack-tools/man/jack-udp.1
index 6e4e7fffb5..7710e0d764 100644
--- a/audio/jack-tools/man/jack-udp.1
+++ b/audio/jack-tools/man/jack-udp.1
@@ -52,7 +52,7 @@ The remote host name, for use in send mode (default="127\&.0\&.0\&.1")\&.
.sp
jack\-udp is a UDP audio transport mechansim for JACK\&. The send mode reads signals from a set of JACK input ports and sends UDP packets to the indicated port at the indicated host at a rate determined by the local JACK daemon\&. The recv mode reads incoming packets at the indi\- cated port and writes the incoming data to a set of JACK output ports at a rate that is determined by the local JACK daemon\&.
.sp
-This transport mechanism is unreliable\&. Both send and recv clients will report buffer overflow and underflow occurences, and recv clients will report dropped and out\-of\-order packets, and shutdown on channel mismatch packets\&. In practice this mechanism can be made highly reli\- able over local networks\&.
+This transport mechanism is unreliable\&. Both send and recv clients will report buffer overflow and underflow occurences, and recv clients will report dropped and out\-of\-order packets, and shutdown on channel mismatch packets\&. In practice this mechanism can be made highly reliable over local networks\&.
.sp
jack\-udp implements no connection logic, use jack\-plumbing(1) instead\&.
.SH "EXAMPLE"
diff --git a/audio/jack-tools/slack-desc b/audio/jack-tools/slack-desc
index 54e1d8c0eb..03b2ee1709 100644
--- a/audio/jack-tools/slack-desc
+++ b/audio/jack-tools/slack-desc
@@ -11,7 +11,7 @@ jack-tools:
jack-tools: This collection contains a bunch of small tools for JACK
jack-tools: (jack-audio-connection-kit), written by Rohan Drape.
jack-tools:
-jack-tools:
+jack-tools: This package was built @WITH@ Steinberg Linux VST support.
jack-tools:
jack-tools:
jack-tools: