summaryrefslogtreecommitdiffstats
path: root/audio/japa/japa.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2019-12-02 09:49:14 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-12-15 17:06:24 +0700
commit1c72f0976dc6623634b0e0abbe1a61c1d7db134b (patch)
tree50e6b73d015031235b6ed00884d4e36323c1cdc3 /audio/japa/japa.SlackBuild
parent260a9c5776692e4005b56cfd3f6497a3f751e4cc (diff)
downloadslackbuilds-1c72f0976dc6623634b0e0abbe1a61c1d7db134b.tar.gz
slackbuilds-1c72f0976dc6623634b0e0abbe1a61c1d7db134b.tar.xz
audio/japa: Updated for version 0.9.2.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'audio/japa/japa.SlackBuild')
-rw-r--r--audio/japa/japa.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/audio/japa/japa.SlackBuild b/audio/japa/japa.SlackBuild
index c841f2108b..00bda7e3ec 100644
--- a/audio/japa/japa.SlackBuild
+++ b/audio/japa/japa.SlackBuild
@@ -7,7 +7,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=japa
-VERSION=${VERSION:-0.8.4}
+VERSION=${VERSION:-0.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,11 +47,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
@@ -60,6 +57,8 @@ if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
source/Makefile
fi
+sed -i 's,pkgconf,pkg-config,' source/Makefile
+
make -C source PREFIX=/usr
make -C source install PREFIX=$PKG/usr
strip $PKG/usr/bin/$PRGNAM