summaryrefslogtreecommitdiffstats
path: root/audio/jokosher
diff options
context:
space:
mode:
author Binh Nguyen <binhnguyen@fastmail.fm>2010-12-28 23:40:09 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2010-12-28 23:40:09 -0200
commite3bc2751f9d120706aee48c4e18a8062c00dc2c3 (patch)
tree1a588bf2f241a57ccc014aa2e1df8e68000e5190 /audio/jokosher
parent7c4be15ffa5ca7d54e86b6eb0b065ec8c342e211 (diff)
downloadslackbuilds-e3bc2751f9d120706aee48c4e18a8062c00dc2c3.tar.gz
slackbuilds-e3bc2751f9d120706aee48c4e18a8062c00dc2c3.tar.xz
audio/jokosher: Added (a multi-track non-linear audio editor)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'audio/jokosher')
-rw-r--r--audio/jokosher/README8
-rw-r--r--audio/jokosher/doinst.sh13
-rw-r--r--audio/jokosher/jokosher.SlackBuild73
-rw-r--r--audio/jokosher/jokosher.info10
-rw-r--r--audio/jokosher/slack-desc19
5 files changed, 123 insertions, 0 deletions
diff --git a/audio/jokosher/README b/audio/jokosher/README
new file mode 100644
index 0000000000..c2792072c3
--- /dev/null
+++ b/audio/jokosher/README
@@ -0,0 +1,8 @@
+Jokosher is a simple and powerful multi-track studio. Jokosher
+provides a complete application for recording, editing, mixing and
+exporting audio, and has been specifically designed with usability in
+mind. The developers behind Jokosher have re-thought audio production
+at every level, and created something devilishly simple to use.
+
+This requires gnonlin, gst-python, libcanberra, pyxdg and
+pysetuptools.
diff --git a/audio/jokosher/doinst.sh b/audio/jokosher/doinst.sh
new file mode 100644
index 0000000000..031ae07d05
--- /dev/null
+++ b/audio/jokosher/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
diff --git a/audio/jokosher/jokosher.SlackBuild b/audio/jokosher/jokosher.SlackBuild
new file mode 100644
index 0000000000..1239528a36
--- /dev/null
+++ b/audio/jokosher/jokosher.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for jokosher
+
+# Copyright 2010 Binh Nguyen <binhnguyen@fastmail.fm>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=jokosher
+VERSION=${VERSION:-0.11.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --skip-build --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING* PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/jokosher/jokosher.info b/audio/jokosher/jokosher.info
new file mode 100644
index 0000000000..83b699e9b2
--- /dev/null
+++ b/audio/jokosher/jokosher.info
@@ -0,0 +1,10 @@
+PRGNAM="jokosher"
+VERSION="0.11.5"
+HOMEPAGE="http://www.jokosher.org/"
+DOWNLOAD="http://launchpad.net/jokosher/trunk/0.11.5/+download/jokosher-0.11.5.tar.gz"
+MD5SUM="941b1fac0a93e2963afc192545caf320"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Binh Nguyen"
+EMAIL="binhnguyen@fastmail.fm"
+APPROVED="Niels Horn"
diff --git a/audio/jokosher/slack-desc b/audio/jokosher/slack-desc
new file mode 100644
index 0000000000..3b68315bf4
--- /dev/null
+++ b/audio/jokosher/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+jokosher: jokosher (a multi-track non-linear audio editor)
+jokosher:
+jokosher: Jokosher is a simple and powerful multi-track studio. Jokosher
+jokosher: provides a complete application for recording, editing, mixing and
+jokosher: exporting audio, and has been specifically designed with usability in
+jokosher: mind. The developers behind Jokosher have re-thought audio production
+jokosher: at every level, and created something devilishly simple to use.
+jokosher:
+jokosher: Homepage: http://www.jokosher.org/
+jokosher:
+jokosher: