summaryrefslogtreecommitdiffstats
path: root/audio/pianobar/pianobar.SlackBuild
diff options
context:
space:
mode:
author Phillip Warner <pc_warner@yahoo.com>2011-06-03 23:10:23 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-06-13 01:34:34 -0400
commit7f5a294a83ffa7531481da6b3cf41fa3c6f534ed (patch)
tree9381111b4652ac142097a78f3432b78bc09a8fbf /audio/pianobar/pianobar.SlackBuild
parent59ac78b61a272e8ea1f985b0a8110b72377e481b (diff)
downloadslackbuilds-7f5a294a83ffa7531481da6b3cf41fa3c6f534ed.tar.gz
slackbuilds-7f5a294a83ffa7531481da6b3cf41fa3c6f534ed.tar.xz
audio/pianobar: Updated for version 2011.04.27.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'audio/pianobar/pianobar.SlackBuild')
-rw-r--r--audio/pianobar/pianobar.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/audio/pianobar/pianobar.SlackBuild b/audio/pianobar/pianobar.SlackBuild
index 6f284d1a72..c9b95c8655 100644
--- a/audio/pianobar/pianobar.SlackBuild
+++ b/audio/pianobar/pianobar.SlackBuild
@@ -4,7 +4,7 @@
# Written by Phillip Warner <pc_warner@yahoo.com>
PRGNAM=pianobar
-VERSION=${VERSION:-2010.11.06}
+VERSION=${VERSION:-2011.04.27}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,8 +50,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Make sure the CFLAGS is respected
-sed -i "s/CFLAGS:=/CFLAGS+=/" Makefile
+# Fix Makefile and make sure the CFLAGS is respected
+patch -p1 < $CWD/Makefile.diff
CFLAGS="$SLKCFLAGS" \
force_arch="$ARCH" \
@@ -68,11 +68,13 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING README ChangeLog contrib/config-example \
+cp -a COPYING README ChangeLog contrib/config-example \
$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts
-cp contrib/*.{sh,rb} $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts
+cp -a contrib/*.sh contrib/eventcmd-examples/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts
chmod -x $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts/*
+chmod -x $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts/eventcmd-examples/*
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install