summaryrefslogtreecommitdiffstats
path: root/audio/pianobar/pianobar.SlackBuild
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2017-01-16 21:30:56 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-21 07:04:23 +0700
commit87acde30f87714e048ac6088beca9a496986374d (patch)
treeb4bb701393d8ea928ea7094a3008daa1d558e7bb /audio/pianobar/pianobar.SlackBuild
parenta07ce5c323130b81698f16c4187789dd46762db7 (diff)
downloadslackbuilds-87acde30f87714e048ac6088beca9a496986374d.tar.gz
slackbuilds-87acde30f87714e048ac6088beca9a496986374d.tar.xz
audio/pianobar: Updated for version 2016.06.02 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'audio/pianobar/pianobar.SlackBuild')
-rw-r--r--audio/pianobar/pianobar.SlackBuild52
1 files changed, 36 insertions, 16 deletions
diff --git a/audio/pianobar/pianobar.SlackBuild b/audio/pianobar/pianobar.SlackBuild
index 68f7ee6d12..e109370767 100644
--- a/audio/pianobar/pianobar.SlackBuild
+++ b/audio/pianobar/pianobar.SlackBuild
@@ -1,16 +1,36 @@
#!/bin/sh
# Slackware build script for pianobar
-# Written by Phillip Warner <pc_warner@yahoo.com>
+
+# Copyright 2010-2016, Phillip Warner <pc_warner@yahoo.com>
+# Copyright 2017, Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pianobar
-VERSION=${VERSION:-2013.09.15}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2016.06.02}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -21,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -45,16 +65,12 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix Makefile
-patch -p1 < $CWD/Makefile.diff
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
-force_arch="$ARCH" \
gmake
gmake install DESTDIR=$PKG PREFIX="/usr" MANDIR="/usr/man"
@@ -62,18 +78,22 @@ gmake install DESTDIR=$PKG PREFIX="/usr" MANDIR="/usr/man"
# Install helper script
install -m 0755 $CWD/pianobarctl $PKG/usr/bin/pianobarctl
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING README INSTALL ChangeLog contrib/config-example \
+cp -a COPYING README.md INSTALL ChangeLog contrib/config-example \
$PKG/usr/doc/$PRGNAM-$VERSION
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts
cp -a contrib/*.sh contrib/headless_pianobar contrib/eventcmd-examples/ \
$PKG/usr/doc/$PRGNAM-$VERSION/example-scripts
find $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts/ -type f -exec chmod -x '{}' \;
+
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.SBo
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install