summaryrefslogtreecommitdiffstats
path: root/audio/quodlibet/quodlibet.SlackBuild
diff options
context:
space:
mode:
author Frank Caraballo <fecaraballo{at}gmail{dot}com>2010-05-12 23:28:10 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:28:10 +0200
commitd962c7357d28f17a9c8c38dccd97ea404fbc970c (patch)
tree3e2a92837697a12fc26ea7d6372bb56aa2ecd57b /audio/quodlibet/quodlibet.SlackBuild
parent4ae8c97488f8e7e10485198465217330b38a8b39 (diff)
downloadslackbuilds-d962c7357d28f17a9c8c38dccd97ea404fbc970c.tar.gz
slackbuilds-d962c7357d28f17a9c8c38dccd97ea404fbc970c.tar.xz
audio/quodlibet: Added to 12.2 repository
Diffstat (limited to 'audio/quodlibet/quodlibet.SlackBuild')
-rw-r--r--audio/quodlibet/quodlibet.SlackBuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/audio/quodlibet/quodlibet.SlackBuild b/audio/quodlibet/quodlibet.SlackBuild
new file mode 100644
index 0000000000..77977b3fe6
--- /dev/null
+++ b/audio/quodlibet/quodlibet.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for Quod Libet
+
+# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=quodlibet
+VERSION=${VERSION:-2.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z* || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py build || exit 1
+python setup.py install --root $PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+# Add missed man page(s):
+( cd $TMP/$PRGNAM-$VERSION/man
+ install -D -m 0644 quodlibet.1 $PKG/usr/man/man1/quodlibet.1
+ install -D -m 0644 exfalso.1 $PKG/usr/man/man1/exfalso.1
+ gzip -9 $PKG/usr/man/man1/*
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING HACKING NEWS PKG-INFO README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -D -m 0644 quodlibet.desktop.in $PKG/usr/share/applications/quodlibet.desktop
+install -D -m 0644 exfalso.desktop.in $PKG/usr/share/applications/exfalso.desktop
+( cd $PKG/usr/share/pixmaps
+ ln -s ../../lib/python2.5/site-packages/quodlibet/images/quodlibet.png quodlibet.png
+ ln -s ../../lib/python2.5/site-packages/quodlibet/images/exfalso.png exfalso.png
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz